diff options
author | Angela Stegmaier <angelabaker@ti.com> | 2020-05-07 02:04:13 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2020-05-07 01:16:02 +0000 |
commit | c7ce199950713cf3551265f1f1197d634ea7b3fc (patch) | |
tree | e34546726143ff4c9566c97ecf60a532efe178fc /recipes-ti | |
parent | 29b8f2d7ce17b085237535a9fbcb02817d065a51 (diff) | |
download | meta-ti-c7ce199950713cf3551265f1f1197d634ea7b3fc.tar.gz |
ti-ipc: remove am65xx build
Only ipc-lld is supported for am65xx.
Signed-off-by: Angela Stegmaier <angelabaker@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-ti')
-rw-r--r-- | recipes-ti/ipc/ti-ipc-common.inc | 1 | ||||
-rw-r--r-- | recipes-ti/ipc/ti-ipc-examples_git.bb | 2 | ||||
-rw-r--r-- | recipes-ti/ipc/ti-ipc-rtos.inc | 9 | ||||
-rw-r--r-- | recipes-ti/ipc/ti-ipc-rtos_git.bb | 17 | ||||
-rw-r--r-- | recipes-ti/ipc/ti-ipc_git.bb | 1 |
5 files changed, 0 insertions, 30 deletions
diff --git a/recipes-ti/ipc/ti-ipc-common.inc b/recipes-ti/ipc/ti-ipc-common.inc index 96cbd667..449903f1 100644 --- a/recipes-ti/ipc/ti-ipc-common.inc +++ b/recipes-ti/ipc/ti-ipc-common.inc | |||
@@ -15,7 +15,6 @@ PLATFORM_k2g = "66AK2G" | |||
15 | PLATFORM_omapl138 = "OMAPL138" | 15 | PLATFORM_omapl138 = "OMAPL138" |
16 | PLATFORM_c667x-evm = "C6678" | 16 | PLATFORM_c667x-evm = "C6678" |
17 | PLATFORM_c665x-evm = "C6678" | 17 | PLATFORM_c665x-evm = "C6678" |
18 | PLATFORM_am65xx = "AM65XX" | ||
19 | 18 | ||
20 | ALT_PLATFORM_k2hk = "TCI6636" | 19 | ALT_PLATFORM_k2hk = "TCI6636" |
21 | ALT_PLATFORM_am57xx-evm = "AM572X AM571X" | 20 | ALT_PLATFORM_am57xx-evm = "AM572X AM571X" |
diff --git a/recipes-ti/ipc/ti-ipc-examples_git.bb b/recipes-ti/ipc/ti-ipc-examples_git.bb index 43e45e64..c46e5c81 100644 --- a/recipes-ti/ipc/ti-ipc-examples_git.bb +++ b/recipes-ti/ipc/ti-ipc-examples_git.bb | |||
@@ -3,8 +3,6 @@ require ti-ipc-examples.inc | |||
3 | 3 | ||
4 | DEPENDS = "ti-ipc ti-xdctools-native ti-sysbios ti-ipc-rtos zip-native" | 4 | DEPENDS = "ti-ipc ti-xdctools-native ti-sysbios ti-ipc-rtos zip-native" |
5 | 5 | ||
6 | DEPENDS_append_am65xx = " sciclient-rtos" | ||
7 | |||
8 | do_compile_append() { | 6 | do_compile_append() { |
9 | 7 | ||
10 | if [ "${PLATFORM}" != "UNKNOWN" ]; then | 8 | if [ "${PLATFORM}" != "UNKNOWN" ]; then |
diff --git a/recipes-ti/ipc/ti-ipc-rtos.inc b/recipes-ti/ipc/ti-ipc-rtos.inc index c4ab2687..a68ba806 100644 --- a/recipes-ti/ipc/ti-ipc-rtos.inc +++ b/recipes-ti/ipc/ti-ipc-rtos.inc | |||
@@ -53,9 +53,6 @@ DEPENDS_append_omapl138 = " ti-cgt6x-native \ | |||
53 | DEPENDS_append_c66x = " ti-cgt6x-native \ | 53 | DEPENDS_append_c66x = " ti-cgt6x-native \ |
54 | " | 54 | " |
55 | 55 | ||
56 | DEPENDS_append_am65xx = " ti-cgt-arm-native \ | ||
57 | gcc-linaro-baremetal-aarch64-native" | ||
58 | |||
59 | IPC_TARGETS = "" | 56 | IPC_TARGETS = "" |
60 | 57 | ||
61 | IPC_TARGETS_omap-a15 = "\ | 58 | IPC_TARGETS_omap-a15 = "\ |
@@ -79,11 +76,6 @@ IPC_TARGETS_c66x = " \ | |||
79 | ti.targets.elf.C66_big_endian="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" \ | 76 | ti.targets.elf.C66_big_endian="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" \ |
80 | " | 77 | " |
81 | 78 | ||
82 | IPC_TARGETS_am65xx = "\ | ||
83 | gnu.targets.arm.A53F="${GCC_LINARO_BAREMETAL_AARCH64_TOOLCHAIN}" \ | ||
84 | ti.targets.arm.elf.R5F="${M4_TOOLCHAIN_INSTALL_DIR}" \ | ||
85 | " | ||
86 | |||
87 | PARALLEL_XDC = "${@oe.utils.parallel_make_argument(d, '--jobs=%d')}" | 79 | PARALLEL_XDC = "${@oe.utils.parallel_make_argument(d, '--jobs=%d')}" |
88 | EXTRA_OEMAKE = "\ | 80 | EXTRA_OEMAKE = "\ |
89 | PLATFORM=${PLATFORM} \ | 81 | PLATFORM=${PLATFORM} \ |
@@ -93,5 +85,4 @@ EXTRA_OEMAKE = "\ | |||
93 | ${PARALLEL_XDC} \ | 85 | ${PARALLEL_XDC} \ |
94 | JAVA_TOOL_OPTIONS=-Xss2560k \ | 86 | JAVA_TOOL_OPTIONS=-Xss2560k \ |
95 | " | 87 | " |
96 | EXTRA_OEMAKE_append_am65xx = " PDK_INSTALL_DIR=${PDK_INSTALL_DIR}" | ||
97 | 88 | ||
diff --git a/recipes-ti/ipc/ti-ipc-rtos_git.bb b/recipes-ti/ipc/ti-ipc-rtos_git.bb index 4c0e71e6..b292d677 100644 --- a/recipes-ti/ipc/ti-ipc-rtos_git.bb +++ b/recipes-ti/ipc/ti-ipc-rtos_git.bb | |||
@@ -3,7 +3,6 @@ require ti-ipc-common.inc | |||
3 | require ti-ipc-rtos.inc | 3 | require ti-ipc-rtos.inc |
4 | 4 | ||
5 | DEPENDS = "ti-xdctools-native ti-sysbios doxygen-native zip-native" | 5 | DEPENDS = "ti-xdctools-native ti-sysbios doxygen-native zip-native" |
6 | DEPENDS_append_am65xx = " sciclient-rtos" | ||
7 | 6 | ||
8 | PACKAGES =+ "${PN}-fw" | 7 | PACKAGES =+ "${PN}-fw" |
9 | FILES_${PN}-fw = "${base_libdir}/firmware/*" | 8 | FILES_${PN}-fw = "${base_libdir}/firmware/*" |
@@ -62,12 +61,6 @@ do_compile() { | |||
62 | fi | 61 | fi |
63 | } | 62 | } |
64 | 63 | ||
65 | do_install_prepend_am65xx () { | ||
66 | # Trim directory name | ||
67 | mv ${S}/packages/ti/ipc/tests/bin/ti_platforms_cortexR_AM65X_false_R5F0 ${S}/packages/ti/ipc/tests/bin/ti_platforms_cortexR_AM65X_R5F0 | ||
68 | mv ${S}/packages/ti/ipc/tests/bin/ti_platforms_cortexR_AM65X_false_R5F1 ${S}/packages/ti/ipc/tests/bin/ti_platforms_cortexR_AM65X_R5F1 | ||
69 | } | ||
70 | |||
71 | do_install() { | 64 | do_install() { |
72 | CP_ARGS="-Prf --preserve=mode,timestamps --no-preserve=ownership" | 65 | CP_ARGS="-Prf --preserve=mode,timestamps --no-preserve=ownership" |
73 | IPC_VERSION=`echo ${PV}${RELEASE_SUFFIX} | sed -e 's|\.|_|g'` | 66 | IPC_VERSION=`echo ${PV}${RELEASE_SUFFIX} | sed -e 's|\.|_|g'` |
@@ -129,13 +122,3 @@ pkg_postinst_${PN}-fw_omapl138 () { | |||
129 | pkg_postrm_${PN}-fw_omapl138 () { | 122 | pkg_postrm_${PN}-fw_omapl138 () { |
130 | update-alternatives --remove rproc-dsp-fw ipc/ti_platforms_evmOMAPL138_DSP/messageq_single.xe674 | 123 | update-alternatives --remove rproc-dsp-fw ipc/ti_platforms_evmOMAPL138_DSP/messageq_single.xe674 |
131 | } | 124 | } |
132 | |||
133 | pkg_postinst_${PN}-fw_am65xx () { | ||
134 | update-alternatives --install /lib/firmware/am65x-mcu-r5f0_0-fw am65x-mcu-r5f0_0-fw ipc/ti_platforms_cortexR_AM65X_R5F0/messageq_single.xer5f ${ALTERNATIVE_PRIORITY} | ||
135 | update-alternatives --install /lib/firmware/am65x-mcu-r5f0_1-fw am65x-mcu-r5f0_1-fw ipc/ti_platforms_cortexR_AM65X_R5F1/messageq_single.xer5f ${ALTERNATIVE_PRIORITY} | ||
136 | } | ||
137 | |||
138 | pkg_postrm_${PN}-fw_am65xx () { | ||
139 | update-alternatives --remove am65x-mcu-r5f0_0-fw ipc/ti_platforms_cortexR_AM65X_R5F0/messageq_single.xer5f | ||
140 | update-alternatives --remove am65x-mcu-r5f0_1-fw ipc/ti_platforms_cortexR_AM65X_R5F1/messageq_single.xer5f | ||
141 | } | ||
diff --git a/recipes-ti/ipc/ti-ipc_git.bb b/recipes-ti/ipc/ti-ipc_git.bb index 2ebd03fd..425ca4e1 100644 --- a/recipes-ti/ipc/ti-ipc_git.bb +++ b/recipes-ti/ipc/ti-ipc_git.bb | |||
@@ -22,7 +22,6 @@ DAEMON_k2l = "lad_tci6630" | |||
22 | DAEMON_k2e = "lad_66ak2e" | 22 | DAEMON_k2e = "lad_66ak2e" |
23 | DAEMON_k2g = "lad_66ak2g" | 23 | DAEMON_k2g = "lad_66ak2g" |
24 | DAEMON_omapl138 = "lad_omapl138" | 24 | DAEMON_omapl138 = "lad_omapl138" |
25 | DAEMON_k3 = "lad_am65xx" | ||
26 | 25 | ||
27 | inherit autotools-brokensep pkgconfig update-rc.d systemd | 26 | inherit autotools-brokensep pkgconfig update-rc.d systemd |
28 | 27 | ||