diff options
author | Gou, Hongmei <h-gou@ti.com> | 2015-12-03 02:50:47 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2015-12-03 13:30:02 -0500 |
commit | 3cb73c27e6a5e98eaeaadcd97da9cab3a2d8d770 (patch) | |
tree | 3acf2e296ae8194edccfd814d0e4fec78986ec1b /recipes-ti | |
parent | 163786e74a8d15f4828be06e5fcf7b0591f7fa32 (diff) | |
download | meta-ti-3cb73c27e6a5e98eaeaadcd97da9cab3a2d8d770.tar.gz |
dsplib-c66x: add version 3.4.0.0
Signed-off-by: Hongmei Gou <h-gou@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-ti')
-rw-r--r-- | recipes-ti/dsplib/dsplib-c66x.inc | 26 | ||||
-rw-r--r-- | recipes-ti/dsplib/dsplib-c66x_3.4.0.0.bb | 9 | ||||
-rw-r--r-- | recipes-ti/includes/ti-paths.inc | 2 |
3 files changed, 37 insertions, 0 deletions
diff --git a/recipes-ti/dsplib/dsplib-c66x.inc b/recipes-ti/dsplib/dsplib-c66x.inc new file mode 100644 index 00000000..31acc1e8 --- /dev/null +++ b/recipes-ti/dsplib/dsplib-c66x.inc | |||
@@ -0,0 +1,26 @@ | |||
1 | DESCRIPTION = "DSPLIB contains optimized general-purpose signal-processing routines for TI DSPs" | ||
2 | HOMEPAGE = "http://www.ti.com/tool/sprc265" | ||
3 | SECTION = "devel" | ||
4 | LICENSE = "BSD-3-Clause" | ||
5 | |||
6 | require ../includes/ti-paths.inc | ||
7 | require ../includes/ti-staging.inc | ||
8 | require ../includes/ti-unpack.inc | ||
9 | |||
10 | COMPATIBLE_MACHINE = "omap-a15|keystone" | ||
11 | |||
12 | SRC_URI = "http://software-dl.ti.com/sdoemb/sdoemb_public_sw/dsplib/${PV}/exports/${BINFILE};name=dsplib" | ||
13 | |||
14 | BINFILE = "dsplib_c66x_${PV}_Linux.bin" | ||
15 | TI_BIN_UNPK_ARGS = "--mode silent --prefix ${S}" | ||
16 | TI_BIN_UNPK_CMDS = "" | ||
17 | |||
18 | do_install() { | ||
19 | install -d ${D}${DSPLIB_C66_INSTALL_DIR_RECIPE} | ||
20 | cp -pPrf ${S}/* ${D}${DSPLIB_C66_INSTALL_DIR_RECIPE} | ||
21 | } | ||
22 | |||
23 | ALLOW_EMPTY_${PN} = "1" | ||
24 | FILES_${PN}-dev += "${DSPLIB_C66_INSTALL_DIR_RECIPE}" | ||
25 | |||
26 | INSANE_SKIP_${PN}-dev = "arch" | ||
diff --git a/recipes-ti/dsplib/dsplib-c66x_3.4.0.0.bb b/recipes-ti/dsplib/dsplib-c66x_3.4.0.0.bb new file mode 100644 index 00000000..f1273f3b --- /dev/null +++ b/recipes-ti/dsplib/dsplib-c66x_3.4.0.0.bb | |||
@@ -0,0 +1,9 @@ | |||
1 | require dsplib-c66x.inc | ||
2 | |||
3 | PV = "3_4_0_0" | ||
4 | PR = "r1" | ||
5 | |||
6 | LIC_FILES_CHKSUM = "file://packages/ti/dsplib/dsplib.h;beginline=9;endline=35;md5=17733f9e1100f8a628512f47c4bf676a" | ||
7 | |||
8 | SRC_URI[dsplib.md5sum] = "66785604729c153dcad5282097dee8bf" | ||
9 | SRC_URI[dsplib.sha256sum] = "e88909b6271ce6c4c62e2ab90181b7adb36c7f28f5c52836668eb35888785ce8" | ||
diff --git a/recipes-ti/includes/ti-paths.inc b/recipes-ti/includes/ti-paths.inc index ad4ff783..37feb939 100644 --- a/recipes-ti/includes/ti-paths.inc +++ b/recipes-ti/includes/ti-paths.inc | |||
@@ -49,6 +49,7 @@ export M4_TOOLCHAIN_INSTALL_DIR_RECIPE = "${installdir}/ti-cgt-arm" | |||
49 | export CCSV6_INSTALL_DIR_RECIPE = "${installdir}/ccsv6" | 49 | export CCSV6_INSTALL_DIR_RECIPE = "${installdir}/ccsv6" |
50 | export GCC_ARM_NONE_TOOLCHAIN_RECIPE = "${installdir}/gcc-arm-none-eabi" | 50 | export GCC_ARM_NONE_TOOLCHAIN_RECIPE = "${installdir}/gcc-arm-none-eabi" |
51 | export TI_CGT_PRU_INSTALL_DIR_RECIPE = "${installdir}/cgt-pru" | 51 | export TI_CGT_PRU_INSTALL_DIR_RECIPE = "${installdir}/cgt-pru" |
52 | export DSPLIB_C66_INSTALL_DIR_RECIPE = "${installdir}/ti-dsplib-c66x-tree" | ||
52 | 53 | ||
53 | 54 | ||
54 | # This is where the tools will end up in sysroot | 55 | # This is where the tools will end up in sysroot |
@@ -89,6 +90,7 @@ export M4_TOOLCHAIN_INSTALL_DIR = "${STAGING_DIR_NATIVE}${M4_TOOLCHAIN_INSTAL | |||
89 | export CCSV6_INSTALL_DIR = "${STAGING_DIR_NATIVE}${CCSV6_INSTALL_DIR_RECIPE}" | 90 | export CCSV6_INSTALL_DIR = "${STAGING_DIR_NATIVE}${CCSV6_INSTALL_DIR_RECIPE}" |
90 | export GCC_ARM_NONE_TOOLCHAIN = "${STAGING_DIR_NATIVE}${GCC_ARM_NONE_TOOLCHAIN_RECIPE}" | 91 | export GCC_ARM_NONE_TOOLCHAIN = "${STAGING_DIR_NATIVE}${GCC_ARM_NONE_TOOLCHAIN_RECIPE}" |
91 | export TI_CGT_PRU_INSTALL_DIR = "${STAGING_DIR_NATIVE}${TI_CGT_PRU_INSTALL_DIR_RECIPE}" | 92 | export TI_CGT_PRU_INSTALL_DIR = "${STAGING_DIR_NATIVE}${TI_CGT_PRU_INSTALL_DIR_RECIPE}" |
93 | export DSPLIB_C66_INSTALL_DIR = "${STAGING_DIR_TARGET}${DSPLIB_C66_INSTALL_DIR_RECIPE}" | ||
92 | 94 | ||
93 | DSPSUFFIX_omapl137 = "x674" | 95 | DSPSUFFIX_omapl137 = "x674" |
94 | DSPSUFFIX_omapl138 = "x674" | 96 | DSPSUFFIX_omapl138 = "x674" |