summaryrefslogtreecommitdiffstats
path: root/recipes-ti/ti-softhsmv2
diff options
context:
space:
mode:
authorSam Nelson <sam.nelson@ti.com>2015-01-29 22:11:25 +0000
committerDenys Dmytriyenko <denys@ti.com>2015-02-02 15:15:26 -0500
commit02faeb98837ac068ff056f8480a5c8e86eb4041b (patch)
tree390382935b269a4a1423d179e7f88b2ed767d40b /recipes-ti/ti-softhsmv2
parent766d60e931325b8114878a1556d3b4bb1dca61ea (diff)
downloadmeta-ti-02faeb98837ac068ff056f8480a5c8e86eb4041b.tar.gz
ti-softhsmv2: Add recipe for ti customised softhsm package
- Provide library, deamon and util for ti customised softhsm Signed-off-by: Sam Nelson <sam.nelson@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-ti/ti-softhsmv2')
-rw-r--r--recipes-ti/ti-softhsmv2/ti-softhsmv2_git.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/recipes-ti/ti-softhsmv2/ti-softhsmv2_git.bb b/recipes-ti/ti-softhsmv2/ti-softhsmv2_git.bb
new file mode 100644
index 00000000..518508c3
--- /dev/null
+++ b/recipes-ti/ti-softhsmv2/ti-softhsmv2_git.bb
@@ -0,0 +1,43 @@
1DESCRIPTION = "TI softhsmv2 package"
2LICENSE = "BSD-2-Clause | BSD-3-Clause | ISC | IBM-License | FSFULLR | Zlib"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=55144a048ba54f211a1aaa38c7fd2424"
4SECTION = "libs"
5
6mntdir = "/mnt"
7
8inherit autotools pkgconfig
9
10DEPENDS = "openssl libdaemon"
11COMPATIBLE_MACHINE = "(tci6614-evm|keystone)"
12
13BRANCH="master"
14SRC_URI = "git://git.ti.com/keystone-linux/ti-softhsmv2.git;protocol=git;branch=${BRANCH}"
15#Following commit corresponds to tag DEV.SOFTHSM-01.03.00.01
16SRCREV = "c79d93ac2a326567a7245dda1b903ef340b5650c"
17PV = "1.3.0.1"
18
19S = "${WORKDIR}/git"
20
21CFLAGS += " -mno-unaligned-access"
22CPPFLAGS += " -mno-unaligned-access"
23
24INITSCRIPT_NAME = "softhsm-daemon.sh"
25INITSCRIPT_PARAMS = "defaults 10"
26
27inherit update-rc.d
28
29SELECTED_OPTIMIZATION := "${@d.getVar("SELECTED_OPTIMIZATION", True).replace("-O2", "-O3")}"
30SELECTED_OPTIMIZATION := "${@d.getVar("SELECTED_OPTIMIZATION", True).replace("-ggdb2", "")}"
31
32FILES_${PN} += "${libdir}/softhsm/lib*.so.* ${mntdir}/*"
33FILES_${PN}-dbg += "${libdir}/softhsm/.debug"
34FILES_${PN}-staticdev += "${libdir}/softhsm/*.a "
35FILES_${PN}-dev += "${libdir}/softhsm/*.la ${libdir}/softhsm/lib*.so"
36
37do_install_append() {
38 install -d ${D}${mntdir}/securedbv0
39 install -d ${D}${mntdir}/securedbv1
40
41 install -d ${D}${sysconfdir}/init.d/
42 install -c -m 755 ${S}/src/bin/daemon/softhsm-daemon.sh ${D}${sysconfdir}/init.d/${INITSCRIPT_NAME}
43}