diff options
author | Joshua Watt <jpewhacker@gmail.com> | 2018-02-22 03:53:05 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2018-02-26 19:43:00 -0500 |
commit | bd3bd8632e15424e14349634251c77823b6639d3 (patch) | |
tree | 2626fd7f9377f9da820e1294e45e6d31c6c30d9b /recipes-ti/ti-pdk-build | |
parent | 32873763134dd341d02f0b2aa7c217b9e8764292 (diff) | |
download | meta-ti-bd3bd8632e15424e14349634251c77823b6639d3.tar.gz |
ti-pdk: Allow Doxygen generation to be optional
Users can choose to completely disable doxygen generation in pdk recipes
by setting TI_PDK_DOXYGEN_SUPPORT = "0" in local.conf
Signed-off-by: Joshua Watt <JPEWhacker@gmail.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-ti/ti-pdk-build')
-rw-r--r-- | recipes-ti/ti-pdk-build/ti-pdk-build-rtos/0001-comp_mk-Allow-doxygen-support-to-be-overridden.patch | 50 | ||||
-rw-r--r-- | recipes-ti/ti-pdk-build/ti-pdk-build-rtos_git.bb | 5 |
2 files changed, 54 insertions, 1 deletions
diff --git a/recipes-ti/ti-pdk-build/ti-pdk-build-rtos/0001-comp_mk-Allow-doxygen-support-to-be-overridden.patch b/recipes-ti/ti-pdk-build/ti-pdk-build-rtos/0001-comp_mk-Allow-doxygen-support-to-be-overridden.patch new file mode 100644 index 00000000..2a10d37e --- /dev/null +++ b/recipes-ti/ti-pdk-build/ti-pdk-build-rtos/0001-comp_mk-Allow-doxygen-support-to-be-overridden.patch | |||
@@ -0,0 +1,50 @@ | |||
1 | From e5dfce58161aaee80ca45c3e992a059efac459d7 Mon Sep 17 00:00:00 2001 | ||
2 | From: Joshua Watt <JPEWhacker@gmail.com> | ||
3 | Date: Wed, 21 Feb 2018 13:38:35 -0600 | ||
4 | Subject: [PATCH] comp_mk: Allow doxygen support to be overridden | ||
5 | |||
6 | Support for Doxygen can be globally disabled by setting the | ||
7 | DOXYGEN_SUPPORT environment variable to "no" | ||
8 | |||
9 | Signed-off-by: Joshua Watt <JPEWhacker@gmail.com> | ||
10 | --- | ||
11 | comp_top.mk | 9 +++++++-- | ||
12 | 1 file changed, 7 insertions(+), 2 deletions(-) | ||
13 | |||
14 | diff --git a/comp_top.mk b/comp_top.mk | ||
15 | index 28700ba..e331132 100644 | ||
16 | --- a/comp_top.mk | ||
17 | +++ b/comp_top.mk | ||
18 | @@ -114,6 +114,11 @@ comp_FIRM_LIST_CLEAN = $(addsuffix _clean, $($(COMP)_FIRM_LIST)) | ||
19 | comp_PKG_LIST_ALL_CLEAN = $(addsuffix _clean, $(comp_PKG_LIST_ALL)) | ||
20 | comp_PKG_LIST_PACKAGE = $(addsuffix _package, $(comp_PKG_LIST_ALL)) | ||
21 | |||
22 | +# If the component enables doxygen, this will evaluate to "yesyes" and doxygen | ||
23 | +# will be built. If this value is overridden by the user to any other value, or | ||
24 | +# $(COMP)_DOXYGEN_SUPPORT is not "yes", doxygen is not built. | ||
25 | +DOXYGEN_SUPPORT ?= yes$($(COMP)_DOXYGEN_SUPPORT) | ||
26 | + | ||
27 | .PHONY : apps appcores app_clean clean_appcores \ | ||
28 | lib libcores lib_allendians lib_clean clean_libcores clean_lib_allendians \ | ||
29 | all comp_libs comp_libs_clean examples examples_clean clean package $(comp_PKG_LIST_ALL) \ | ||
30 | @@ -230,7 +235,7 @@ xdc_meta_clean: | ||
31 | $(XDC) clean XDCBUILDCFG=config_mk.bld | ||
32 | |||
33 | doxygen: | ||
34 | -ifeq ($($(COMP)_DOXYGEN_SUPPORT),yes) | ||
35 | +ifeq ($(DOXYGEN_SUPPORT),yesyes) | ||
36 | $(ECHO) Creating Doxygen API guide ... | ||
37 | @doxygen docs/Doxyfile | ||
38 | else | ||
39 | @@ -238,7 +243,7 @@ else | ||
40 | endif | ||
41 | |||
42 | clean_doxygen: | ||
43 | -ifeq ($($(COMP)_DOXYGEN_SUPPORT),yes) | ||
44 | +ifeq ($(DOXYGEN_SUPPORT),yesyes) | ||
45 | $(ECHO) cleaned Doxygen API guide ... | ||
46 | $(RM) -rf docs/doxygen | ||
47 | else | ||
48 | -- | ||
49 | 2.14.3 | ||
50 | |||
diff --git a/recipes-ti/ti-pdk-build/ti-pdk-build-rtos_git.bb b/recipes-ti/ti-pdk-build/ti-pdk-build-rtos_git.bb index 0999b5c5..fbb82ace 100644 --- a/recipes-ti/ti-pdk-build/ti-pdk-build-rtos_git.bb +++ b/recipes-ti/ti-pdk-build/ti-pdk-build-rtos_git.bb | |||
@@ -15,7 +15,10 @@ PDK_BUILD_GIT_BRANCH = "master" | |||
15 | PDK_BUILD_SRCREV = "cbac264f08aa9cdc2cd533d1433ef57b922cccb5" | 15 | PDK_BUILD_SRCREV = "cbac264f08aa9cdc2cd533d1433ef57b922cccb5" |
16 | 16 | ||
17 | BRANCH = "${PDK_BUILD_GIT_BRANCH}" | 17 | BRANCH = "${PDK_BUILD_GIT_BRANCH}" |
18 | SRC_URI = "${PDK_BUILD_GIT_URI};protocol=${PDK_BUILD_GIT_PROTOCOL};branch=${BRANCH}" | 18 | SRC_URI = "\ |
19 | ${PDK_BUILD_GIT_URI};protocol=${PDK_BUILD_GIT_PROTOCOL};branch=${BRANCH} \ | ||
20 | file://0001-comp_mk-Allow-doxygen-support-to-be-overridden.patch \ | ||
21 | " | ||
19 | 22 | ||
20 | SRCREV = "${PDK_BUILD_SRCREV}" | 23 | SRCREV = "${PDK_BUILD_SRCREV}" |
21 | 24 | ||