summaryrefslogtreecommitdiffstats
path: root/recipes-ti/swtools
diff options
context:
space:
mode:
authorJianzhong Xu <xuj@ti.com>2018-09-24 20:59:33 +0000
committerDenys Dmytriyenko <denys@ti.com>2018-09-24 16:34:45 +0000
commit6a854e93404a9b190ed7b80fd18bb5e849da47f5 (patch)
tree5287ec2d0e401825c658abb8f17d29c2448f1be0 /recipes-ti/swtools
parent103a0c10388ab7dbd5ce5181bc5bcbca6e118c23 (diff)
downloadmeta-ti-6a854e93404a9b190ed7b80fd18bb5e849da47f5.tar.gz
swtools: common tools for xdc-based component build
Add SWTOOLS which is needed to build xdc-based processor libs such as DSPLIB, MATHLIB, etc from source. Signed-off-by: Jianzhong Xu <xuj@ti.com> Signed-off-by: Jacob Stiffler <j-stiffler@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-ti/swtools')
-rw-r--r--recipes-ti/swtools/swtools_git.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/recipes-ti/swtools/swtools_git.bb b/recipes-ti/swtools/swtools_git.bb
new file mode 100644
index 00000000..425a0690
--- /dev/null
+++ b/recipes-ti/swtools/swtools_git.bb
@@ -0,0 +1,44 @@
1SUMMARY = "TI Software Tools"
2HOMEPAGE = "https://git.ti.com/ep-processor-libraries/swtools"
3SECTION = "devel"
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://ti/mas/swtools/copyright.txt;md5=b1f52a1435051fdb18f8885b0384147d"
6
7require ../includes/ti-paths.inc
8
9DEPENDS = "ti-cgt6x-native \
10 ti-sysbios \
11 ti-xdctools-native"
12
13PV = "5_0_8"
14PR = "r0"
15S = "${WORKDIR}/git"
16BRANCH = "master"
17SRC_URI = "git://git.ti.com/ep-processor-libraries/swtools.git;protocol=git;branch=${BRANCH}"
18SRCREV = "881267836907de650edadc56b8e57ab45428021d"
19
20export C64PCODEGENTOOL = "${CGTOOLS_INSTALL_DIR}"
21export C674CODEGENTOOL = "${CGTOOLS_INSTALL_DIR}"
22export C66CODEGENTOOL = "${CGTOOLS_INSTALL_DIR}"
23
24PATH_append = ":${XDC_INSTALL_DIR}"
25
26XDCPATH .= "${XDCCGROOT}/include;${XDC_INSTALL_DIR}/packages;${SYSBIOS_INSTALL_DIR}/packages;"
27
28export XDCPATH
29
30do_compile() {
31 cd ${S}/ti/mas/swtools
32 xdc
33}
34
35do_install() {
36 CP_ARGS="-Prf --preserve=mode,timestamps --no-preserve=ownership"
37 install -d ${D}${SWTOOLS_INSTALL_DIR_RECIPE}
38 cp -pPrf ${S}/* ${D}${SWTOOLS_INSTALL_DIR_RECIPE}
39}
40
41FILES_${PN}-dev += "${SWTOOLS_INSTALL_DIR_RECIPE}"
42
43INSANE_SKIP_${PN}-dev = "arch staticdev"
44ALLOW_EMPTY_${PN} = "1"