summaryrefslogtreecommitdiffstats
path: root/recipes-ti/openmp-rtos
diff options
context:
space:
mode:
authorJacob Stiffler <j-stiffler@ti.com>2016-03-04 18:41:06 +0000
committerDenys Dmytriyenko <denys@ti.com>2016-03-04 12:07:24 -0500
commit8120df0a4f278fdcc83eb5a3508d552468440c93 (patch)
treead2076efeaf90667c0cf95d7b53f8ed136eba42e /recipes-ti/openmp-rtos
parent9af397c36d3cf31b0138bc82b1af8a2ffb1e5986 (diff)
downloadmeta-ti-8120df0a4f278fdcc83eb5a3508d552468440c93.tar.gz
openmp-rtos: Bump version to 2.2.1.0 and add k2g-evm
Signed-off-by: Jacob Stiffler <j-stiffler@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-ti/openmp-rtos')
-rw-r--r--recipes-ti/openmp-rtos/openmp-rtos_git.bb15
1 files changed, 11 insertions, 4 deletions
diff --git a/recipes-ti/openmp-rtos/openmp-rtos_git.bb b/recipes-ti/openmp-rtos/openmp-rtos_git.bb
index b735ec4d..4869686f 100644
--- a/recipes-ti/openmp-rtos/openmp-rtos_git.bb
+++ b/recipes-ti/openmp-rtos/openmp-rtos_git.bb
@@ -4,7 +4,7 @@ LICENSE = "BSD"
4 4
5require recipes-ti/includes/ti-paths.inc 5require recipes-ti/includes/ti-paths.inc
6 6
7PV = "2_02_00_02" 7PV = "2_02_01_00"
8PR = "r0" 8PR = "r0"
9 9
10OPENMP_RTOS_GIT_URI = "git://git.ti.com/openmp/ti-openmp-dsp-runtime.git" 10OPENMP_RTOS_GIT_URI = "git://git.ti.com/openmp/ti-openmp-dsp-runtime.git"
@@ -15,12 +15,14 @@ BRANCH = "${OPENMP_RTOS_GIT_BRANCH}"
15SRC_URI = "${OPENMP_RTOS_GIT_URI};protocol=${OPENMP_RTOS_GIT_PROTOCOL};branch=${BRANCH} \ 15SRC_URI = "${OPENMP_RTOS_GIT_URI};protocol=${OPENMP_RTOS_GIT_PROTOCOL};branch=${BRANCH} \
16" 16"
17 17
18SRCREV = "5599f2218be68274c58110a12c85a97c6ed1a2d9" 18SRCREV = "f0fe1ce874734b83dacadfe33dacc862afc8ed00"
19 19
20LIC_FILES_CHKSUM = "file://docs/license/omp_manifest_template.html;md5=61a6972303c0447b7c056195d7ebafee" 20LIC_FILES_CHKSUM = "file://docs/license/omp_manifest_template.html;md5=61a6972303c0447b7c056195d7ebafee"
21 21
22DEPENDS = "common-csl-ip-rtos ti-xdctools ti-ipc-rtos ti-sysbios ti-cgt6x-native libulm" 22DEPENDS = "common-csl-ip-rtos ti-xdctools ti-ipc-rtos ti-sysbios ti-cgt6x-native libulm"
23DEPENDS_append_keystone = " qmss-lld-rtos cppi-lld-rtos" 23DEPENDS_append_k2hk-evm = " qmss-lld-rtos cppi-lld-rtos"
24DEPENDS_append_k2e-evm = " qmss-lld-rtos cppi-lld-rtos"
25DEPENDS_append_k2l-evm = " qmss-lld-rtos cppi-lld-rtos"
24 26
25COMPATIBLE_MACHINE = "keystone|omap-a15" 27COMPATIBLE_MACHINE = "keystone|omap-a15"
26PACKAGE_ARCH = "${MACHINE_ARCH}" 28PACKAGE_ARCH = "${MACHINE_ARCH}"
@@ -32,17 +34,22 @@ export BIOS_DIR = "${SYSBIOS_INSTALL_DIR}"
32export ULM_DIR ="${STAGING_DIR_TARGET}/usr/share/ti/ulm" 34export ULM_DIR ="${STAGING_DIR_TARGET}/usr/share/ti/ulm"
33export C6636_PDK_DIR ="${PDK_INSTALL_DIR}" 35export C6636_PDK_DIR ="${PDK_INSTALL_DIR}"
34export AM572_PDK_DIR ="${PDK_INSTALL_DIR}" 36export AM572_PDK_DIR ="${PDK_INSTALL_DIR}"
37export K2G_PDK_DIR ="${PDK_INSTALL_DIR}"
35export XDCCGROOT = "${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" 38export XDCCGROOT = "${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x"
36 39
37export BUILD_K2H = "0" 40export BUILD_K2H = "0"
38export BUILD_AM572 = "0" 41export BUILD_AM572 = "0"
42export BUILD_K2G = "0"
39 43
40BUILD_K2H_keystone = "1" 44BUILD_K2H_keystone = "1"
41BUILD_AM572_omap-a15 = "1" 45BUILD_AM572_omap-a15 = "1"
46BUILD_K2H_k2g-evm = "0"
47BUILD_K2G_k2g-evm = "1"
42 48
43RELEASE_TARGET = "" 49RELEASE_TARGET = ""
44RELEASE_TARGET_keystone = "k2x" 50RELEASE_TARGET_keystone = "k2x"
45RELEASE_TARGET_omap-a15 = "am57xx" 51RELEASE_TARGET_omap-a15 = "am57xx"
52RELEASE_TARGET_k2g-evm = "k2g"
46 53
47do_compile() { 54do_compile() {
48 make -f utils/product/Makefile .zipfile 55 make -f utils/product/Makefile .zipfile
@@ -50,7 +57,7 @@ do_compile() {
50 57
51do_install() { 58do_install() {
52 install -d ${D}${OMP_INSTALL_DIR_RECIPE} 59 install -d ${D}${OMP_INSTALL_DIR_RECIPE}
53 cp -r ${S}/exports/openmp_dsp_${RELEASE_TARGET}_${PV}/. -d ${D}${OMP_INSTALL_DIR_RECIPE} 60 cp -r ${S}/exports/openmp_dsp_${RELEASE_TARGET}_*/. -d ${D}${OMP_INSTALL_DIR_RECIPE}
54} 61}
55 62
56ALLOW_EMPTY_${PN} = "1" 63ALLOW_EMPTY_${PN} = "1"