diff options
author | Jacob Stiffler <j-stiffler@ti.com> | 2016-01-27 03:16:50 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2016-01-27 15:54:29 -0500 |
commit | ac917dc7863b37b4390746e22df32294de7728c1 (patch) | |
tree | 80b4a36dd132d2f38ea5cb84b27bf642b4469f18 /recipes-ti/openmp-rtos | |
parent | d2281f5a67062706d671d4f16ea601662666c98e (diff) | |
download | meta-ti-ac917dc7863b37b4390746e22df32294de7728c1.tar.gz |
openmp-rtos: Add the OpenMP RTOS package
* supports OpenMP on c66x cores
Signed-off-by: Jacob Stiffler <j-stiffler@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-ti/openmp-rtos')
-rw-r--r-- | recipes-ti/openmp-rtos/openmp-rtos_git.bb | 62 |
1 files changed, 62 insertions, 0 deletions
diff --git a/recipes-ti/openmp-rtos/openmp-rtos_git.bb b/recipes-ti/openmp-rtos/openmp-rtos_git.bb new file mode 100644 index 00000000..b735ec4d --- /dev/null +++ b/recipes-ti/openmp-rtos/openmp-rtos_git.bb | |||
@@ -0,0 +1,62 @@ | |||
1 | DESCRIPTION = "TI OpenMP RTOS" | ||
2 | HOMEPAGE = "git://git.ti.com/openmp/ti-openmp-dsp-runtime.git" | ||
3 | LICENSE = "BSD" | ||
4 | |||
5 | require recipes-ti/includes/ti-paths.inc | ||
6 | |||
7 | PV = "2_02_00_02" | ||
8 | PR = "r0" | ||
9 | |||
10 | OPENMP_RTOS_GIT_URI = "git://git.ti.com/openmp/ti-openmp-dsp-runtime.git" | ||
11 | OPENMP_RTOS_GIT_PROTOCOL = "git" | ||
12 | OPENMP_RTOS_GIT_BRANCH = "master" | ||
13 | |||
14 | BRANCH = "${OPENMP_RTOS_GIT_BRANCH}" | ||
15 | SRC_URI = "${OPENMP_RTOS_GIT_URI};protocol=${OPENMP_RTOS_GIT_PROTOCOL};branch=${BRANCH} \ | ||
16 | " | ||
17 | |||
18 | SRCREV = "5599f2218be68274c58110a12c85a97c6ed1a2d9" | ||
19 | |||
20 | LIC_FILES_CHKSUM = "file://docs/license/omp_manifest_template.html;md5=61a6972303c0447b7c056195d7ebafee" | ||
21 | |||
22 | DEPENDS = "common-csl-ip-rtos ti-xdctools ti-ipc-rtos ti-sysbios ti-cgt6x-native libulm" | ||
23 | DEPENDS_append_keystone = " qmss-lld-rtos cppi-lld-rtos" | ||
24 | |||
25 | COMPATIBLE_MACHINE = "keystone|omap-a15" | ||
26 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
27 | |||
28 | S = "${WORKDIR}/git" | ||
29 | export IPC_DIR = "${IPC_INSTALL_DIR}" | ||
30 | export XDC_DIR = "${XDC_INSTALL_DIR}" | ||
31 | export BIOS_DIR = "${SYSBIOS_INSTALL_DIR}" | ||
32 | export ULM_DIR ="${STAGING_DIR_TARGET}/usr/share/ti/ulm" | ||
33 | export C6636_PDK_DIR ="${PDK_INSTALL_DIR}" | ||
34 | export AM572_PDK_DIR ="${PDK_INSTALL_DIR}" | ||
35 | export XDCCGROOT = "${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" | ||
36 | |||
37 | export BUILD_K2H = "0" | ||
38 | export BUILD_AM572 = "0" | ||
39 | |||
40 | BUILD_K2H_keystone = "1" | ||
41 | BUILD_AM572_omap-a15 = "1" | ||
42 | |||
43 | RELEASE_TARGET = "" | ||
44 | RELEASE_TARGET_keystone = "k2x" | ||
45 | RELEASE_TARGET_omap-a15 = "am57xx" | ||
46 | |||
47 | do_compile() { | ||
48 | make -f utils/product/Makefile .zipfile | ||
49 | } | ||
50 | |||
51 | do_install() { | ||
52 | install -d ${D}${OMP_INSTALL_DIR_RECIPE} | ||
53 | cp -r ${S}/exports/openmp_dsp_${RELEASE_TARGET}_${PV}/. -d ${D}${OMP_INSTALL_DIR_RECIPE} | ||
54 | } | ||
55 | |||
56 | ALLOW_EMPTY_${PN} = "1" | ||
57 | |||
58 | FILES_${PN}-dev += " \ | ||
59 | ${OMP_INSTALL_DIR_RECIPE}/ \ | ||
60 | " | ||
61 | |||
62 | INSANE_SKIP_${PN}-dev = "arch" | ||