summaryrefslogtreecommitdiffstats
path: root/recipes-ti/multiprocmgr
diff options
context:
space:
mode:
authorJacob Stiffler <j-stiffler@ti.com>2016-01-28 19:07:33 +0000
committerDenys Dmytriyenko <denys@ti.com>2016-01-28 13:21:35 -0500
commitf6ab2c715fbac9000b1d24ee6700c4f2d6e143ab (patch)
tree98b0f217ed5679bdfe13661040888c6b050c3602 /recipes-ti/multiprocmgr
parent401b85924a57c336c500b907794ca9b4893a36da (diff)
downloadmeta-ti-f6ab2c715fbac9000b1d24ee6700c4f2d6e143ab.tar.gz
multiprocmgr-rtos: Add RTOS package for multiprocmgr
Signed-off-by: Jacob Stiffler <j-stiffler@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-ti/multiprocmgr')
-rw-r--r--recipes-ti/multiprocmgr/multiprocmgr-rtos_git.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes-ti/multiprocmgr/multiprocmgr-rtos_git.bb b/recipes-ti/multiprocmgr/multiprocmgr-rtos_git.bb
new file mode 100644
index 00000000..50e50493
--- /dev/null
+++ b/recipes-ti/multiprocmgr/multiprocmgr-rtos_git.bb
@@ -0,0 +1,28 @@
1SUMMARY = "TI Multiproc Manager (RTOS) for KeyStone II"
2DESCRIPTION = "Provides download, debug and other utilities for other cores in the SOC like DSP"
3
4require recipes-ti/includes/ti-paths.inc
5require recipes-ti/multiprocmgr/multiprocmgr.inc
6
7DEPENDS = "ti-cgt6x-native"
8
9PR = "${INC_PR}.0"
10
11export LOCAL_SYSROOT="${STAGING_DIR_TARGET}"
12export C6X_GEN_INSTALL_PATH="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x"
13
14do_compile() {
15 make c66x
16 make test_c66x
17 sourceipk_do_create_srcipk
18}
19
20do_install() {
21 install -d ${D}${MPM_INSTALL_DIR_RECIPE}
22 cp -pPrf ${S}/* ${D}${MPM_INSTALL_DIR_RECIPE}
23}
24
25FILES_${PN}-dev += "${MPM_INSTALL_DIR_RECIPE}"
26INSANE_SKIP_${PN}-dev = "arch"
27
28ALLOW_EMPTY_${PN} = "1"