diff options
author | Sam Nelson <sam.nelson@ti.com> | 2015-01-16 18:20:26 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2015-01-21 15:15:14 -0500 |
commit | a9fe62d130146ed94dc248f35c563c1e76206517 (patch) | |
tree | 82112da40dab180b6325a5a0749b29f51c728064 /recipes-ti/multiprocmgr | |
parent | 73d028e699ad28120e83e93d5da596e9f05f4420 (diff) | |
download | meta-ti-a9fe62d130146ed94dc248f35c563c1e76206517.tar.gz |
multiprocmgr: Update to new version of MPM 2.0.1.7
- Recipe split into main and test recipes.
- Added dependency on mpm-transport & libdaemon & syslog-ng
- Added startup scripts for daemon
- Removed PR
Signed-off-by: Sam Nelson <sam.nelson@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-ti/multiprocmgr')
-rw-r--r-- | recipes-ti/multiprocmgr/multiprocmgr-test_git.bb | 18 | ||||
-rw-r--r-- | recipes-ti/multiprocmgr/multiprocmgr.inc | 14 | ||||
-rw-r--r-- | recipes-ti/multiprocmgr/multiprocmgr_git.bb | 34 |
3 files changed, 55 insertions, 11 deletions
diff --git a/recipes-ti/multiprocmgr/multiprocmgr-test_git.bb b/recipes-ti/multiprocmgr/multiprocmgr-test_git.bb new file mode 100644 index 00000000..b05cd44e --- /dev/null +++ b/recipes-ti/multiprocmgr/multiprocmgr-test_git.bb | |||
@@ -0,0 +1,18 @@ | |||
1 | DESCRIPTION = "TI Multiproc Manager test code" | ||
2 | |||
3 | include multiprocmgr.inc | ||
4 | |||
5 | DEPENDS = "multiprocmgr cmem" | ||
6 | RDEPENDS_${PN} = "multiprocmgr mpm-transport cmem" | ||
7 | |||
8 | CC += "-I${STAGING_KERNEL_DIR}/include" | ||
9 | |||
10 | do_compile() { | ||
11 | make -C ${S} test | ||
12 | } | ||
13 | |||
14 | do_install() { | ||
15 | install -d ${D}${bindir}/ | ||
16 | install -c -m 755 ${S}/test/filetestdemo/host/bin/demo_filetest ${D}${bindir}/mpm_demo_filetest | ||
17 | install -c -m 755 ${S}/test/sync_test/host/bin/sync_test ${D}${bindir}/mpm_sync_test | ||
18 | } | ||
diff --git a/recipes-ti/multiprocmgr/multiprocmgr.inc b/recipes-ti/multiprocmgr/multiprocmgr.inc new file mode 100644 index 00000000..26c89590 --- /dev/null +++ b/recipes-ti/multiprocmgr/multiprocmgr.inc | |||
@@ -0,0 +1,14 @@ | |||
1 | HOMEPAGE = "http://git.ti.com/cgit/cgit.cgi/keystone-linux/multi-proc-manager.git" | ||
2 | LICENSE = "BSD-3-Clause & MIT" | ||
3 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=fce208c498eb9669223724dc9c1d8fe4" | ||
4 | SECTION = "console" | ||
5 | COMPATIBLE_MACHINE = "keystone" | ||
6 | |||
7 | BRANCH = "master" | ||
8 | # The following commits correspond to DEV.MPM-2.00.01.07 | ||
9 | SRCREV = "b79e1cdaed78014569d82cf2f748d3f5f91623ee" | ||
10 | PV = "2.0.1.7" | ||
11 | |||
12 | SRC_URI = "git://git.ti.com/keystone-linux/multi-proc-manager.git;protocol=git;branch=${BRANCH}" | ||
13 | |||
14 | S = "${WORKDIR}/git" | ||
diff --git a/recipes-ti/multiprocmgr/multiprocmgr_git.bb b/recipes-ti/multiprocmgr/multiprocmgr_git.bb index 3f2e52c6..e1c4f2fd 100644 --- a/recipes-ti/multiprocmgr/multiprocmgr_git.bb +++ b/recipes-ti/multiprocmgr/multiprocmgr_git.bb | |||
@@ -1,20 +1,32 @@ | |||
1 | DESCRIPTION = "TI Multiproc Manager for KeyStone II" | 1 | DESCRIPTION = "TI Multiproc Manager for KeyStone II" |
2 | HOMEPAGE = "http://gtgit01.gt.design.ti.com/git/?p=projects/multiprocmgr.git;a=summary" | 2 | SUMMARY = "Provides download, debug and other utilities for other cores in the SOC like DSP" |
3 | LICENSE = "BSD & MIT" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=fce208c498eb9669223724dc9c1d8fe4" | ||
5 | SECTION = "console" | ||
6 | COMPATIBLE_MACHINE = "keystone" | ||
7 | 3 | ||
8 | PR = "r1" | 4 | include multiprocmgr.inc |
9 | 5 | ||
10 | BRANCH ?= "master" | 6 | DEPENDS = "mpm-transport libdaemon" |
11 | SRCREV = "8a97fb5c2c06d5f02d30106629f27fe0ca8a4f95" | 7 | RDEPENDS_${PN} = "syslog-ng" |
12 | 8 | ||
13 | SRC_URI = "git://gtgit01.gt.design.ti.com/git/projects/multiprocmgr.git;protocol=git;branch=${BRANCH}" | ||
14 | 9 | ||
15 | S = "${WORKDIR}/git" | 10 | CC += "-I${STAGING_KERNEL_DIR}/include" |
11 | |||
12 | INITSCRIPT_NAME = "mpmsrv-daemon.sh" | ||
13 | INITSCRIPT_PARAMS = "defaults 10" | ||
14 | |||
15 | inherit update-rc.d | ||
16 | 16 | ||
17 | do_install() { | 17 | do_install() { |
18 | install -d ${D}${bindir}/ | 18 | install -d ${D}${bindir}/ |
19 | install -c -m 755 ${S}/mpmsrv ${D}${bindir}/mpmsrv | 19 | install -c -m 755 ${S}/bin/mpmsrv ${D}${bindir}/mpmsrv |
20 | install -c -m 755 ${S}/bin/mpmcl ${D}${bindir}/mpmcl | ||
21 | |||
22 | install -d ${D}${sysconfdir}/init.d/ | ||
23 | install -c -m 755 ${S}/scripts/mpmsrv-daemon.sh ${D}${sysconfdir}/init.d/${INITSCRIPT_NAME} | ||
24 | install -d ${D}${sysconfdir}/mpm/ | ||
25 | install -c -m 755 ${S}/scripts/crash_callback.sh ${D}${sysconfdir}/mpm/crash_callback.sh | ||
26 | |||
27 | install -d ${D}${includedir}/ | ||
28 | install -c -m 755 ${S}/include/* ${D}${includedir}/ | ||
29 | |||
30 | install -d ${D}${libdir}/ | ||
31 | cp -a ${S}/lib/* ${D}${libdir}/ | ||
20 | } | 32 | } |