diff options
author | Denys Dmytriyenko <denys@ti.com> | 2020-02-12 04:19:12 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2020-02-11 22:17:39 +0000 |
commit | 6a701a3a5d1a08590f2fc7108ead4fc2c65e5c34 (patch) | |
tree | c069ef88a593707c7fd9c87f1aa1f648d26598d9 /recipes-ti/multiprocmgr | |
parent | 7e1182b72e2eabc66c332fdce952e8a00d1678cb (diff) | |
download | meta-ti-6a701a3a5d1a08590f2fc7108ead4fc2c65e5c34.tar.gz |
multiprocmgr: do not mix kernel and user-space headers, fully depend on uapi
As multiprocmgr is a user-space app and should only use uapi headers, drop
extra -I for the kernel headers. Patch out any assumptions of direct access
to the kernel headers.
Cc: Suman Anna <s-anna@ti.com>
Cc: Sam Nelson <sam.nelson@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-ti/multiprocmgr')
-rw-r--r-- | recipes-ti/multiprocmgr/multiprocmgr/0001-mpmdlif.c-don-t-suppress-kernel-linux-types.h-inclus.patch | 28 | ||||
-rw-r--r-- | recipes-ti/multiprocmgr/multiprocmgr_git.bb | 3 |
2 files changed, 29 insertions, 2 deletions
diff --git a/recipes-ti/multiprocmgr/multiprocmgr/0001-mpmdlif.c-don-t-suppress-kernel-linux-types.h-inclus.patch b/recipes-ti/multiprocmgr/multiprocmgr/0001-mpmdlif.c-don-t-suppress-kernel-linux-types.h-inclus.patch new file mode 100644 index 00000000..c3315cfc --- /dev/null +++ b/recipes-ti/multiprocmgr/multiprocmgr/0001-mpmdlif.c-don-t-suppress-kernel-linux-types.h-inclus.patch | |||
@@ -0,0 +1,28 @@ | |||
1 | From 95921ccf77ae037bb3b95f45a632f60975c6c9bb Mon Sep 17 00:00:00 2001 | ||
2 | From: Denys Dmytriyenko <denys@ti.com> | ||
3 | Date: Tue, 11 Feb 2020 17:03:18 -0500 | ||
4 | Subject: [PATCH] mpmdlif.c: don't suppress kernel <linux/types.h> inclusion | ||
5 | |||
6 | Defining _LINUX_TYPES_H before including <linux/keystone_remoteproc.h> causes | ||
7 | <linux/types.h> to skip defining kernel types, resulting in undefined __u32 | ||
8 | |||
9 | Signed-off-by: Denys Dmytriyenko <denys@ti.com> | ||
10 | --- | ||
11 | src/daemon/mpmdlif.c | 1 - | ||
12 | 1 file changed, 1 deletion(-) | ||
13 | |||
14 | diff --git a/src/daemon/mpmdlif.c b/src/daemon/mpmdlif.c | ||
15 | index 0c31604..1abd00f 100644 | ||
16 | --- a/src/daemon/mpmdlif.c | ||
17 | +++ b/src/daemon/mpmdlif.c | ||
18 | @@ -46,7 +46,6 @@ | ||
19 | #include <byteswap.h> | ||
20 | #include <stdint.h> | ||
21 | |||
22 | -#define _LINUX_TYPES_H | ||
23 | #include "linux/keystone_remoteproc.h" | ||
24 | #include "internal/rsc_types.h" | ||
25 | //#include <elf.h> | ||
26 | -- | ||
27 | 2.7.4 | ||
28 | |||
diff --git a/recipes-ti/multiprocmgr/multiprocmgr_git.bb b/recipes-ti/multiprocmgr/multiprocmgr_git.bb index 6143341d..aea24456 100644 --- a/recipes-ti/multiprocmgr/multiprocmgr_git.bb +++ b/recipes-ti/multiprocmgr/multiprocmgr_git.bb | |||
@@ -6,6 +6,7 @@ include multiprocmgr.inc | |||
6 | SRC_URI += " \ | 6 | SRC_URI += " \ |
7 | file://mpmsrv-daemon.service \ | 7 | file://mpmsrv-daemon.service \ |
8 | file://0001-mpmdlif.c-don-t-hardcode-kernel-s-uapi-location-keys.patch \ | 8 | file://0001-mpmdlif.c-don-t-hardcode-kernel-s-uapi-location-keys.patch \ |
9 | file://0001-mpmdlif.c-don-t-suppress-kernel-linux-types.h-inclus.patch \ | ||
9 | " | 10 | " |
10 | 11 | ||
11 | PR = "${INC_PR}.2" | 12 | PR = "${INC_PR}.2" |
@@ -14,8 +15,6 @@ DEPENDS = "mpm-transport libdaemon virtual/kernel cmem" | |||
14 | 15 | ||
15 | PACKAGE_ARCH = "${MACHINE_ARCH}" | 16 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
16 | 17 | ||
17 | CC += "-I${STAGING_KERNEL_DIR}/include -I${STAGING_KERNEL_DIR}/include/uapi" | ||
18 | |||
19 | INITSCRIPT_NAME = "mpmsrv-daemon.sh" | 18 | INITSCRIPT_NAME = "mpmsrv-daemon.sh" |
20 | INITSCRIPT_PARAMS = "defaults 10" | 19 | INITSCRIPT_PARAMS = "defaults 10" |
21 | 20 | ||