summaryrefslogtreecommitdiffstats
path: root/recipes-ti/multiprocmgr/multiprocmgr_git.bb
diff options
context:
space:
mode:
authorSam Nelson <sam.nelson@ti.com>2015-01-16 18:20:26 +0000
committerDenys Dmytriyenko <denys@ti.com>2015-01-21 15:15:14 -0500
commita9fe62d130146ed94dc248f35c563c1e76206517 (patch)
tree82112da40dab180b6325a5a0749b29f51c728064 /recipes-ti/multiprocmgr/multiprocmgr_git.bb
parent73d028e699ad28120e83e93d5da596e9f05f4420 (diff)
downloadmeta-ti-a9fe62d130146ed94dc248f35c563c1e76206517.tar.gz
multiprocmgr: Update to new version of MPM 2.0.1.7
- Recipe split into main and test recipes. - Added dependency on mpm-transport & libdaemon & syslog-ng - Added startup scripts for daemon - Removed PR Signed-off-by: Sam Nelson <sam.nelson@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-ti/multiprocmgr/multiprocmgr_git.bb')
-rw-r--r--recipes-ti/multiprocmgr/multiprocmgr_git.bb34
1 files changed, 23 insertions, 11 deletions
diff --git a/recipes-ti/multiprocmgr/multiprocmgr_git.bb b/recipes-ti/multiprocmgr/multiprocmgr_git.bb
index 3f2e52c6..e1c4f2fd 100644
--- a/recipes-ti/multiprocmgr/multiprocmgr_git.bb
+++ b/recipes-ti/multiprocmgr/multiprocmgr_git.bb
@@ -1,20 +1,32 @@
1DESCRIPTION = "TI Multiproc Manager for KeyStone II" 1DESCRIPTION = "TI Multiproc Manager for KeyStone II"
2HOMEPAGE = "http://gtgit01.gt.design.ti.com/git/?p=projects/multiprocmgr.git;a=summary" 2SUMMARY = "Provides download, debug and other utilities for other cores in the SOC like DSP"
3LICENSE = "BSD & MIT"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=fce208c498eb9669223724dc9c1d8fe4"
5SECTION = "console"
6COMPATIBLE_MACHINE = "keystone"
7 3
8PR = "r1" 4include multiprocmgr.inc
9 5
10BRANCH ?= "master" 6DEPENDS = "mpm-transport libdaemon"
11SRCREV = "8a97fb5c2c06d5f02d30106629f27fe0ca8a4f95" 7RDEPENDS_${PN} = "syslog-ng"
12 8
13SRC_URI = "git://gtgit01.gt.design.ti.com/git/projects/multiprocmgr.git;protocol=git;branch=${BRANCH}"
14 9
15S = "${WORKDIR}/git" 10CC += "-I${STAGING_KERNEL_DIR}/include"
11
12INITSCRIPT_NAME = "mpmsrv-daemon.sh"
13INITSCRIPT_PARAMS = "defaults 10"
14
15inherit update-rc.d
16 16
17do_install() { 17do_install() {
18 install -d ${D}${bindir}/ 18 install -d ${D}${bindir}/
19 install -c -m 755 ${S}/mpmsrv ${D}${bindir}/mpmsrv 19 install -c -m 755 ${S}/bin/mpmsrv ${D}${bindir}/mpmsrv
20 install -c -m 755 ${S}/bin/mpmcl ${D}${bindir}/mpmcl
21
22 install -d ${D}${sysconfdir}/init.d/
23 install -c -m 755 ${S}/scripts/mpmsrv-daemon.sh ${D}${sysconfdir}/init.d/${INITSCRIPT_NAME}
24 install -d ${D}${sysconfdir}/mpm/
25 install -c -m 755 ${S}/scripts/crash_callback.sh ${D}${sysconfdir}/mpm/crash_callback.sh
26
27 install -d ${D}${includedir}/
28 install -c -m 755 ${S}/include/* ${D}${includedir}/
29
30 install -d ${D}${libdir}/
31 cp -a ${S}/lib/* ${D}${libdir}/
20} 32}