summaryrefslogtreecommitdiffstats
path: root/recipes-ti/mpm-transport
diff options
context:
space:
mode:
authorSam Nelson <sam.nelson@ti.com>2015-04-13 20:38:49 +0000
committerDenys Dmytriyenko <denys@ti.com>2015-04-20 16:19:18 -0400
commit44b0f284c51f831d66b21c33809890247d05234c (patch)
treeed74f3f5677d321c40cf355b5624780f0f9c817a /recipes-ti/mpm-transport
parent3a38871f3cd81fa30023767f9105c7aea2a371f5 (diff)
downloadmeta-ti-44b0f284c51f831d66b21c33809890247d05234c.tar.gz
mpm-transport: Update to new version 1.0.6.0
- Add new transport using qmss, srio modules - Update new dependency on cmem, rm-lld, qmss-lld, cppi-lld & srio-lld Signed-off-by: Sam Nelson <sam.nelson@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-ti/mpm-transport')
-rw-r--r--recipes-ti/mpm-transport/mpm-transport_git.bb19
1 files changed, 13 insertions, 6 deletions
diff --git a/recipes-ti/mpm-transport/mpm-transport_git.bb b/recipes-ti/mpm-transport/mpm-transport_git.bb
index cb0f6c4d..fd68721e 100644
--- a/recipes-ti/mpm-transport/mpm-transport_git.bb
+++ b/recipes-ti/mpm-transport/mpm-transport_git.bb
@@ -1,22 +1,29 @@
1DESCRIPTION = "Multiproc transport layer for KeyStone devices: Provide basic transport layer for moving data between different processing nodes" 1DESCRIPTION = "Multiproc transport layer for KeyStone devices: Provide basic transport layer for moving data between different processing nodes"
2HOMEPAGE = "http://git.ti.com/cgit/cgit.cgi/keystone-linux/mpm-transport.git" 2HOMEPAGE = "http://git.ti.com/cgit/cgit.cgi/keystone-linux/mpm-transport.git"
3LICENSE = "BSD-3-Clause & MIT" 3LICENSE = "BSD-3-Clause & MIT"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=2c17cd1dc60dc06a4c4f2a2c45472a51" 4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=122b7757f366f3f6fe11988715258fc9"
5COMPATIBLE_MACHINE = "keystone" 5COMPATIBLE_MACHINE = "keystone"
6DEPENDS = "common-csl-ip hyplnk-lld edma3-lld mmap-lld" 6DEPENDS = "common-csl-ip hyplnk-lld edma3-lld mmap-lld cmem rm-lld qmss-lld cppi-lld srio-lld"
7 7
8SRC_URI = "git://git.ti.com/keystone-linux/mpm-transport.git;protocol=git;branch=${BRANCH}" 8SRC_URI = "git://git.ti.com/keystone-linux/mpm-transport.git;protocol=git;branch=${BRANCH}"
9 9
10BRANCH = "master" 10BRANCH = "master"
11# This commit corresponds to tag DEV.MPM-TRANSPORT-01.00.06.00 11# This commit corresponds to tag DEV.MPM-TRANSPORT-01.00.07.00A
12SRCREV = "af2d2ad8721b769012662c539a86b94f7d44dbda" 12SRCREV = "267db40a9c551bd91dbed470d57cd1ed0d9e9141"
13PV = "1.0.6.0" 13
14PV = "1.0.7.0"
14PR = "r1" 15PR = "r1"
15 16
16S = "${WORKDIR}/git" 17S = "${WORKDIR}/git"
17 18
18PACKAGES =+ "${PN}-test" 19PACKAGES =+ "${PN}-test"
19FILES_${PN}-test = "${bindir}/mpm_transport_test.out ${bindir}/mpm_transport_hyplnk_loopback.out ${bindir}/mpm_transport_hyplnk_remote.out ${bindir}/mpm_transport_hyplnk_loopback_dma.out ${bindir}/mpm_transport_hyplnk_loopback64.out" 20FILES_${PN}-test = "${bindir}/mpm_transport_test.out \
21 ${bindir}/mpm_transport_hyplnk_loopback.out \
22 ${bindir}/mpm_transport_hyplnk_remote.out \
23 ${bindir}/mpm_transport_hyplnk_loopback_dma.out \
24 ${bindir}/mpm_transport_hyplnk_loopback64.out \
25 ${bindir}/mpm_transport_qmss_arm_mt.out \
26 ${bindir}/mpm_transport_srio_arm_mt.out"
20 27
21do_compile () { 28do_compile () {
22 cd ${S} 29 cd ${S}