summaryrefslogtreecommitdiffstats
path: root/recipes-ti/mpm-transport
diff options
context:
space:
mode:
authorSam Nelson <sam.nelson@ti.com>2014-12-18 21:54:17 +0000
committerDenys Dmytriyenko <denys@ti.com>2014-12-18 12:43:33 -0500
commitce24dff877407018ffeadc7d2538aa670bc8b688 (patch)
treee5bcda2a6063077a43d09549b8674082f4c54684 /recipes-ti/mpm-transport
parentd0a7ce516faddbff49f6e7065d7c6ea6c0165c3f (diff)
downloadmeta-ti-ce24dff877407018ffeadc7d2538aa670bc8b688.tar.gz
mpm-transport: Add new recipe for multiproc transport library and test code
- mpm-transport provide basic transport layer for moving data between different processing nodes - Support communication with the process nodes using shared memory and hyperlink interface Signed-off-by: Sam Nelson <sam.nelson@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-ti/mpm-transport')
-rw-r--r--recipes-ti/mpm-transport/mpm-transport_git.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/recipes-ti/mpm-transport/mpm-transport_git.bb b/recipes-ti/mpm-transport/mpm-transport_git.bb
new file mode 100644
index 00000000..fe671959
--- /dev/null
+++ b/recipes-ti/mpm-transport/mpm-transport_git.bb
@@ -0,0 +1,37 @@
1DESCRIPTION = "Multiproc transport layer for KeyStone devices: Provide basic transport layer for moving data between different processing nodes"
2HOMEPAGE = "http://git.ti.com/cgit/cgit.cgi/keystone-linux/mpm-transport.git"
3LICENSE = "BSD-3-Clause & MIT"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=2c17cd1dc60dc06a4c4f2a2c45472a51"
5COMPATIBLE_MACHINE = "keystone"
6DEPENDS = "common-csl-ip hyplnk-lld edma3-lld mmap-lld"
7
8SRC_URI = "git://git.ti.com/keystone-linux/mpm-transport.git;protocol=git;branch=${BRANCH}"
9
10BRANCH = "master"
11# This commit corresponds to tag DEV.MPM-TRANSPORT-01.00.04.00E
12SRCREV = "56640c6296f9f4816140364b7620b1d1a483ac40"
13PV = "1.0.4.0"
14PR = "r0"
15
16S = "${WORKDIR}/git"
17
18PACKAGES =+ "${PN}-test"
19FILES_${PN}-test = "${bindir}/mpm_transport_test.out ${bindir}/mpm_transport_hyplnk_loopback.out ${bindir}/mpm_transport_hyplnk_remote.out ${bindir}/mpm_transport_hyplnk_loopback_dma.out ${bindir}/mpm_transport_hyplnk_loopback64.out"
20
21do_compile () {
22 cd ${S}
23 make PDK_INSTALL_PATH=${STAGING_INCDIR}
24}
25
26do_install() {
27 make installbin BASE_DIR=${S} INSTALL_BIN_BASE_DIR=${D}/${bindir}
28
29 install -d ${D}${includedir}/
30 install -c -m 755 ${S}/include/* ${D}${includedir}/
31
32 install -d ${D}${libdir}/
33 cp -a ${S}/lib/* ${D}${libdir}/
34
35 install -d ${D}${sysconfdir}/mpm/
36 install -c -m 755 ${S}/scripts/mpm_config.json ${D}${sysconfdir}/mpm/mpm_config.json
37}