summaryrefslogtreecommitdiffstats
path: root/recipes-ti/matrix
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-08-05 17:14:28 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-08-05 17:14:28 +0200
commita19aa726e23825bbf106e1196028cefd8fab2e76 (patch)
treec53edc4aaa0099c59aa32be05f89b181cd863dd8 /recipes-ti/matrix
parent3ca3c5e07a1f78c524942a4dc184d9d30fecae64 (diff)
downloadmeta-ti-a19aa726e23825bbf106e1196028cefd8fab2e76.tar.gz
matrix: move into a seperate dir
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'recipes-ti/matrix')
-rw-r--r--recipes-ti/matrix/files/0001-matrix_gui.pro-add-dbus-to-QT-features-to-fix-linkin.patch31
-rw-r--r--recipes-ti/matrix/matrix-gui-common.inc44
-rw-r--r--recipes-ti/matrix/matrix-gui-common_1.4.bb8
-rw-r--r--recipes-ti/matrix/matrix-gui-e.inc48
-rw-r--r--recipes-ti/matrix/matrix-gui-e_1.3.bb7
-rw-r--r--recipes-ti/matrix/matrix-gui.inc51
-rw-r--r--recipes-ti/matrix/matrix-gui_1.3.bb6
-rw-r--r--recipes-ti/matrix/matrix-tui.inc45
-rwxr-xr-xrecipes-ti/matrix/matrix-tui/init24
-rw-r--r--recipes-ti/matrix/matrix-tui_1.1.bb4
10 files changed, 268 insertions, 0 deletions
diff --git a/recipes-ti/matrix/files/0001-matrix_gui.pro-add-dbus-to-QT-features-to-fix-linkin.patch b/recipes-ti/matrix/files/0001-matrix_gui.pro-add-dbus-to-QT-features-to-fix-linkin.patch
new file mode 100644
index 00000000..324f9808
--- /dev/null
+++ b/recipes-ti/matrix/files/0001-matrix_gui.pro-add-dbus-to-QT-features-to-fix-linkin.patch
@@ -0,0 +1,31 @@
1From 420cadec0f7a6048a0fafccf4c658d543b7dbf19 Mon Sep 17 00:00:00 2001
2From: Koen Kooi <k-kooi@ti.com>
3Date: Tue, 26 Jul 2011 14:25:39 +0200
4Subject: [PATCH] matrix_gui.pro: add dbus to QT features to fix linking with -Wl,--as-needed
5
6This fixes:
7
8| ccache arm-angstrom-linux-gnueabi-g++ -march=armv7-a -mtune=cortex-a8 -mfpu=neon -mfloat-abi=softfp -fno-tree-vectorize -mthumb-interwork -mno-thumb --sysroot=/home/koen/angstrom-core/build/tmp-angstrom_2010_x-eglibc/sysroots/beagleboard -Wl,-O1 -Wl,--hash-style=gnu -Wl,--as-needed -Wl,-rpath-link,/home/koen/angstrom-core/build/tmp-angstrom_2010_x-eglibc/sysroots/beagleboard/usr/lib -o matrix_gui main.o mainwindow.o buttonfactory.o buttonlaunch.o customstyle.o menupage.o osdmanager.o matrixcontrol.o moc_mainwindow.o moc_buttonfactory.o moc_buttonlaunch.o moc_customstyle.o moc_menupage.o moc_osdmanager.o moc_matrixcontrol.o -L/home/koen/angstrom-core/build/tmp-angstrom_2010_x-eglibc/sysroots/beagleboard/usr/lib -lpng -lfreetype -lz -lgthread-2.0 -lQtWebKit -lQtGui -lQtNetwork -lQtCore -lpthread
9| ux-gnueabi/4.5.4/ld: }: invalid DSO for symbol `QDBusConnection::registerService(QString const&)' definition
10| /home/koen/angstrom-core/build/tmp-angstrom_2010_x-eglibc/sysroots/beagleboard/usr/lib/libQtDBus.so.4: could not read symbols: Bad value
11| collect2: ld returned 1 exit status
12
13Signed-off-by: Koen Kooi <k-kooi@ti.com>
14---
15 matrix_gui.pro | 3 ++-
16 1 files changed, 2 insertions(+), 1 deletions(-)
17
18diff --git a/matrix_gui.pro b/matrix_gui.pro
19index 5463310..908e8a7 100644
20--- a/matrix_gui.pro
21+++ b/matrix_gui.pro
22@@ -1,4 +1,5 @@
23-QT += webkit \
24+QT += dbus \
25+ webkit \
26 network
27 LIBS += -lpng -lfreetype -lz -lgthread-2.0
28 HEADERS = mainwindow.h \
29--
301.7.4.4
31
diff --git a/recipes-ti/matrix/matrix-gui-common.inc b/recipes-ti/matrix/matrix-gui-common.inc
new file mode 100644
index 00000000..6b61081b
--- /dev/null
+++ b/recipes-ti/matrix/matrix-gui-common.inc
@@ -0,0 +1,44 @@
1DESCRIPTION = "Common files for all versions of Matrix GUI"
2HOMEPAGE = "https://gforge.ti.com/gf/project/matrix_gui/"
3LICENSE = "BSD"
4LIC_FILES_CHKSUM = "file://main.cpp;beginline=1;endline=37;md5=a802a01a3a58f2ebb1e83c25f883f0c0"
5
6SECTION = "multimedia"
7
8INC_PR = "r10"
9
10COMPATIBLE_MACHINE = "(dm365|omapl138|omap3|ti816x|ti814x)"
11
12PLATFORM_dm365-evm = "dm365"
13PLATFORM_dm368-evm = "dm368"
14PLATFORM_omapl138 = "omapl138"
15PLATFORM_omap3evm = "omap3530"
16PLATFORM_dm37x-evm = "dm3730"
17PLATFORM_am37x-evm = "am3715"
18PLATFORM_beagleboard = "beagleboard"
19PLATFORM_ti816x = "ti816x"
20PLATFORM_ti814x = "ti814x"
21PLATFORM_am180x-evm = "am180x"
22PLATFORM_am181x-evm = "am181x"
23PLATFORM_am3517-evm = "am3517"
24
25#Checkout the project repository to get access to the scripts and data
26#files.
27SRC_URI = "svn://gforge.ti.com/svn/matrix_gui/;module=trunk;proto=https;user=anonymous;pswd='' "
28
29S = "${WORKDIR}/trunk"
30
31PACKAGE_ARCH = ${MACHINE_ARCH}
32
33do_install() {
34 install -d ${D}/${bindir}
35 install -m 0755 ${S}/${PLATFORM}/bin/* ${D}/${bindir}/
36 install -d ${D}/${datadir}/matrix/html
37 install -m 0644 ${S}/${PLATFORM}/html/* ${D}/${datadir}/matrix/html
38 install -d ${D}/${datadir}/matrix/images
39 install -m 0644 ${S}/images/*.png ${D}/${datadir}/matrix/images/
40 install -m 0644 ${S}/images/*.svg ${D}/${datadir}/matrix/images/
41
42}
43
44FILES_${PN} += "${datadir}/matrix/*"
diff --git a/recipes-ti/matrix/matrix-gui-common_1.4.bb b/recipes-ti/matrix/matrix-gui-common_1.4.bb
new file mode 100644
index 00000000..add2a261
--- /dev/null
+++ b/recipes-ti/matrix/matrix-gui-common_1.4.bb
@@ -0,0 +1,8 @@
1require matrix-gui-common.inc
2
3# Use the mem_util application from am-sysinfo instead of a
4# prebuilt version in the repository.
5RRECOMMENDS_${PN} = "am-sysinfo"
6
7SRCREV = "275"
8PR = "${INC_PR}.6"
diff --git a/recipes-ti/matrix/matrix-gui-e.inc b/recipes-ti/matrix/matrix-gui-e.inc
new file mode 100644
index 00000000..481f4f4e
--- /dev/null
+++ b/recipes-ti/matrix/matrix-gui-e.inc
@@ -0,0 +1,48 @@
1DESCRIPTION = "Matrix GUI for Qt Embedded"
2HOMEPAGE = "https://gforge.ti.com/gf/project/matrix_gui/"
3LICENSE = "BSD"
4LIC_FILES_CHKSUM = "file://main.cpp;beginline=1;endline=37;md5=a802a01a3a58f2ebb1e83c25f883f0c0"
5
6SECTION = "multimedia"
7
8INC_PR = "r24"
9
10COMPATIBLE_MACHINE = "(dm365|omapl138|omap3|ti816x|ti814x)"
11
12PLATFORM_dm365-evm = "dm365"
13PLATFORM_dm368-evm = "dm368"
14PLATFORM_omapl138 = "omapl138"
15PLATFORM_omap3evm = "omap3530"
16PLATFORM_dm37x-evm = "dm3730"
17PLATFORM_am37x-evm = "am3715"
18PLATFORM_beagleboard = "beagleboard"
19PLATFORM_ti816x = "ti816x"
20PLATFORM_ti814x = "ti814x"
21PLATFORM_am180x-evm = "am180x"
22PLATFORM_am181x-evm = "am181x"
23PLATFORM_am3517-evm = "am3517"
24
25SRC_URI = "svn://gforge.ti.com/svn/matrix_gui/;module=trunk;proto=https;user=anonymous;pswd='' "
26
27S = "${WORKDIR}/trunk"
28
29INITSCRIPT_NAME = "matrix-gui-e"
30INITSCRIPT_PARAMS = "defaults 99"
31#INITSCRIPT_PARAMS = "start 99 3 . stop 99 3 ."
32
33CXXFLAGS_omapl138_append = " -DPlatform_omapl138 "
34CXXFLAGS_dm365_append = " -DPlatform_dm365 "
35PACKAGE_ARCH = ${MACHINE_ARCH}
36
37inherit qt4e update-rc.d
38
39do_install() {
40 install -d ${D}/${bindir}
41 install -m 0755 ${S}/matrix_gui ${D}/${bindir}/matrix_guiE
42 install -d ${D}${sysconfdir}/init.d/
43 install -c -m 0755 ${S}/${PLATFORM}/etc/init ${D}${sysconfdir}/init.d/matrix-gui-e
44
45}
46
47RRECOMMENDS_${PN} = "qt4-embedded-plugin-mousedriver-tslib qt4-embedded-fonts"
48RDEPENDS_${PN} += "matrix-gui-common"
diff --git a/recipes-ti/matrix/matrix-gui-e_1.3.bb b/recipes-ti/matrix/matrix-gui-e_1.3.bb
new file mode 100644
index 00000000..bddb3e03
--- /dev/null
+++ b/recipes-ti/matrix/matrix-gui-e_1.3.bb
@@ -0,0 +1,7 @@
1require matrix-gui-e.inc
2
3SRCREV = "275"
4SRC_URI += "file://0001-matrix_gui.pro-add-dbus-to-QT-features-to-fix-linkin.patch"
5
6PR = "${INC_PR}.1"
7
diff --git a/recipes-ti/matrix/matrix-gui.inc b/recipes-ti/matrix/matrix-gui.inc
new file mode 100644
index 00000000..40494a95
--- /dev/null
+++ b/recipes-ti/matrix/matrix-gui.inc
@@ -0,0 +1,51 @@
1DESCRIPTION = "Matrix GUI for Qt X11"
2HOMEPAGE = "https://gforge.ti.com/gf/project/matrix_gui/"
3LICENSE = "BSD"
4LIC_FILES_CHKSUM = "file://main.cpp;beginline=1;endline=37;md5=a802a01a3a58f2ebb1e83c25f883f0c0"
5
6SECTION = "multimedia"
7
8INC_PR = "r22"
9
10COMPATIBLE_MACHINE = "(dm365|omapl138|omap3|ti816x|ti814x)"
11
12PLATFORM_dm365-evm = "dm365"
13PLATFORM_dm368-evm = "dm368"
14PLATFORM_omapl138 = "omapl138"
15PLATFORM_omap3evm = "omap3530"
16PLATFORM_dm37x-evm = "dm3730"
17PLATFORM_am37x-evm = "am3715"
18PLATFORM_beagleboard = "beagleboard"
19PLATFORM_ti816x = "ti816x"
20PLATFORM_ti814x = "ti814x"
21PLATFORM_am180x-evm = "am180x"
22PLATFORM_am181x-evm = "am181x"
23PLATFORM_am3517-evm = "am3517"
24
25SRC_URI = "svn://gforge.ti.com/svn/matrix_gui/;module=trunk;proto=https;user=anonymous;pswd='' "
26
27S = "${WORKDIR}/trunk"
28
29CXXFLAGS_omapl138_append = " -DPlatform_omapl138 "
30CXXFLAGS_dm365_append = " -DPlatform_dm365 "
31PACKAGE_ARCH = ${MACHINE_ARCH}
32
33inherit qt4x11
34
35do_install() {
36 install -d ${D}/${bindir}
37 install -m 0755 ${S}/matrix_gui ${D}/${bindir}
38 install -d ${D}${sysconfdir}/init.d/
39 install -c -m 0755 ${S}/${PLATFORM}/etc/x11/init ${D}${sysconfdir}/init.d/matrix-gui
40 install -d ${D}/${sysconfdir}/xdg/autostart
41 install -m 0755 ${S}/${PLATFORM}/etc/x11/matrix-gui.desktop ${D}/${sysconfdir}/xdg/autostart
42}
43
44FILES_${PN}-autostart = "${sysconfdir}/xdg/autostart/matrix-gui.desktop"
45
46#Make autostart package depend on matrix-gui package. Doesn't make sense
47#to install the autostart package without the underlying matrix-gui package.
48RDEPENDS_${PN}-autostart += "${PN}"
49PACKAGES =+ "${PN}-autostart"
50
51RDEPENDS_${PN} += "matrix-gui-common"
diff --git a/recipes-ti/matrix/matrix-gui_1.3.bb b/recipes-ti/matrix/matrix-gui_1.3.bb
new file mode 100644
index 00000000..f91d8817
--- /dev/null
+++ b/recipes-ti/matrix/matrix-gui_1.3.bb
@@ -0,0 +1,6 @@
1require matrix-gui.inc
2
3SRCREV = "275"
4SRC_URI += "file://0001-matrix_gui.pro-add-dbus-to-QT-features-to-fix-linkin.patch"
5
6PR = "${INC_PR}.1"
diff --git a/recipes-ti/matrix/matrix-tui.inc b/recipes-ti/matrix/matrix-tui.inc
new file mode 100644
index 00000000..ef89f1fa
--- /dev/null
+++ b/recipes-ti/matrix/matrix-tui.inc
@@ -0,0 +1,45 @@
1DESCRIPTION = "Matrix TUI"
2HOMEPAGE = "https://gforge.ti.com/gf/project/matrix_tui/"
3LICENSE = "BSD"
4SECTION = "multimedia"
5PRIORITY = "optional"
6DEPENDS = "libxml2 zlib ncurses"
7
8INC_PR = "r7"
9
10COMPATIBLE_MACHINE = "(omapl138|omap3)"
11
12SRC_URI = "svn://gforge.ti.com/svn/matrix_tui/;module=trunk;proto=https;user=anonymous;pswd='' \
13 file://init \
14"
15
16S = "${WORKDIR}/trunk"
17
18# Do not auto-start TUI by default, uncomment otherwise
19#inherit update-rc.d
20#INITSCRIPT_NAME = "matrix-tui"
21#INITSCRIPT_PARAMS = "defaults 99"
22
23do_configure() {
24 sed -i -e 's|LIBS :=|LIBS := ${LDFLAGS} |' Release/objects.mk
25}
26
27do_compile() {
28 # don't build debug version
29 touch debug
30 export CROSS_COMPILE=${TARGET_PREFIX}
31 export TUI_INCLUDE_PATH=${STAGING_INCDIR}
32 export XML_INCLUDE_PATH=${STAGING_INCDIR}/libxml2
33 export TUI_LIB_PATH=${STAGING_LIBDIR}
34 export PLATFORM=${MACHINE}
35 make release
36}
37
38do_install() {
39 export PLATFORM=${MACHINE}
40 make DESTDIR=${D} install
41 install -d ${D}${sysconfdir}/init.d/
42 install -c -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/matrix-tui
43}
44
45FILES_${PN} += "${datadir}/matrix/*"
diff --git a/recipes-ti/matrix/matrix-tui/init b/recipes-ti/matrix/matrix-tui/init
new file mode 100755
index 00000000..e5813825
--- /dev/null
+++ b/recipes-ti/matrix/matrix-tui/init
@@ -0,0 +1,24 @@
1#! /bin/sh
2
3matrixtui="/usr/bin/matrix_tui"
4TUI_OPTS="/usr/share/matrix/xml/matrix.xml"
5
6test -x "$matrixtui" || exit 0
7
8case "$1" in
9 start)
10 echo -n "Starting Matrix TUI application"
11 start-stop-daemon --start --quiet --background --pidfile /var/run/matrix-tui.pid --exec $matrixtui -- $TUI_OPTS
12 echo "."
13 ;;
14 stop)
15 echo -n "Stopping Matrix TUI application"
16 start-stop-daemon --stop --quiet --pidfile /var/run/matrix-tui.pid
17 echo "."
18 ;;
19 *)
20 echo "Usage: /etc/init.d/matrix-tui {start|stop}"
21 exit 1
22esac
23
24exit 0
diff --git a/recipes-ti/matrix/matrix-tui_1.1.bb b/recipes-ti/matrix/matrix-tui_1.1.bb
new file mode 100644
index 00000000..9814d5fa
--- /dev/null
+++ b/recipes-ti/matrix/matrix-tui_1.1.bb
@@ -0,0 +1,4 @@
1require matrix-tui.inc
2
3SRCREV = "37"
4PR = "${INC_PR}.4"