summaryrefslogtreecommitdiffstats
path: root/recipes-ti/matrix/matrix-gui_2.0.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-11-02 16:14:46 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2011-11-02 16:14:46 +0100
commit51a7587cde6e7380181907caee86b2cff678f5b6 (patch)
tree0b1946fab398b4dbc8640d496fb8eb808c81ba84 /recipes-ti/matrix/matrix-gui_2.0.bb
parent5ccf189cb5605549f407d5287f134fccaa638277 (diff)
downloadmeta-ti-51a7587cde6e7380181907caee86b2cff678f5b6.tar.gz
matrix: sync with arago
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'recipes-ti/matrix/matrix-gui_2.0.bb')
-rw-r--r--recipes-ti/matrix/matrix-gui_2.0.bb17
1 files changed, 11 insertions, 6 deletions
diff --git a/recipes-ti/matrix/matrix-gui_2.0.bb b/recipes-ti/matrix/matrix-gui_2.0.bb
index 60b1a040..a0965d57 100644
--- a/recipes-ti/matrix/matrix-gui_2.0.bb
+++ b/recipes-ti/matrix/matrix-gui_2.0.bb
@@ -6,12 +6,12 @@ LIC_FILES_CHKSUM = "file://scripts/jquery-1.6.2.min.js;md5=a1a8cb16a060f6280a767
6 6
7SECTION = "multimedia" 7SECTION = "multimedia"
8 8
9PR = "r2" 9PR = "r3"
10 10
11inherit allarch 11inherit allarch
12 12
13BRANCH ?= "master" 13BRANCH ?= "master"
14SRCREV = "9f5d27fec216f223c43b48fa146edf4a4bb7aa24" 14SRCREV = "8e2bd5ffdded23bb662476fcd2490fa1526801f8"
15 15
16SRC_URI = "git://gitorious.org/matrix-gui-v2/matrix-gui-v2.git;protocol=git;branch=${BRANCH} \ 16SRC_URI = "git://gitorious.org/matrix-gui-v2/matrix-gui-v2.git;protocol=git;branch=${BRANCH} \
17 file://matrix-gui.service" 17 file://matrix-gui.service"
@@ -22,10 +22,14 @@ S = "${WORKDIR}/git"
22 22
23do_install(){ 23do_install(){
24 install -d ${D}${MATRIX_BASE_DIR} 24 install -d ${D}${MATRIX_BASE_DIR}
25 cp -rf ${S}/* ${D}${MATRIX_BASE_DIR} 25 install -d ${D}${MATRIX_WEB_DIR}
26 cp -rf ${S}/* ${D}${MATRIX_WEB_DIR}
27
28 # Install our php.ini file
29 install -m 0644 ${WORKDIR}/php.ini ${D}${MATRIX_BASE_DIR}/
26 30
27 # Set the proper path in the init script 31 # Set the proper path in the init script
28 sed -i -e s=__MATRIX_BASE_DIR__=${MATRIX_BASE_DIR}=g ${WORKDIR}/matrix-gui.service 32 sed -i -e s=__MATRIX_WEB_DIR__=${MATRIX_WEB_DIR}=g ${WORKDIR}/matrix-gui.service
29 33
30 install -d ${D}${base_libdir}/systemd/system/ 34 install -d ${D}${base_libdir}/systemd/system/
31 install -m 0755 ${WORKDIR}/matrix-gui.service ${D}${base_libdir}/systemd/system/ 35 install -m 0755 ${WORKDIR}/matrix-gui.service ${D}${base_libdir}/systemd/system/
@@ -35,5 +39,6 @@ do_install(){
35 ln -sf ../matrix-gui.service ${D}${base_libdir}/systemd/system/multi-user.target.wants/ 39 ln -sf ../matrix-gui.service ${D}${base_libdir}/systemd/system/multi-user.target.wants/
36} 40}
37 41
38RDEPENDS_${PN} += "nodejs" 42RDEPENDS_${PN} += "lighttpd lighttpd-module-cgi lighttpd-module-compress lighttpd-module-expire php php-cgi php-cli matrix-gui-browser"
39FILES_${PN} += "${MATRIX_BASE_DIR}/* ${base_libdir}/systemd/system" 43
44FILES_${PN} += "${MATRIX_BASE_DIR}/*"