diff options
author | Koen Kooi <koen@dominion.thruhere.net> | 2011-03-15 18:50:50 +0100 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2011-03-15 18:50:50 +0100 |
commit | 4385b6e36cd409a787827a5d5ff2e8e943d7a902 (patch) | |
tree | 53a18997318a8a10cf4591f647b606aed039cddd /recipes-ti/local-power-manager | |
parent | ac2942e80e4982463b59290e2d9086e502eb4b01 (diff) | |
download | meta-ti-4385b6e36cd409a787827a5d5ff2e8e943d7a902.tar.gz |
ti-local-power-manager: avoid parse errors when variables aren't defined
This fixes:
ERROR: Error parsing
/home/kraj/work/setup-scripts/sources/angstrom-layers/BSP/TI/recipes-ti/local-power-manager/ti-local-power-manager_1.24.02.09.bb:
LexToken(PIPE,'|',0,0)
followed by:
LexToken(TOKEN,'sed',0,0)
LexToken(TOKEN,'s:\\\\.:_:g',0,0)
ERROR: Command execution failed: Exited with 1
As reported by Khem Raj
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'recipes-ti/local-power-manager')
-rw-r--r-- | recipes-ti/local-power-manager/ti-local-power-manager.inc | 6 |
1 files changed, 3 insertions, 3 deletions
diff --git a/recipes-ti/local-power-manager/ti-local-power-manager.inc b/recipes-ti/local-power-manager/ti-local-power-manager.inc index 836e1181..6b2e3437 100644 --- a/recipes-ti/local-power-manager/ti-local-power-manager.inc +++ b/recipes-ti/local-power-manager/ti-local-power-manager.inc | |||
@@ -26,11 +26,11 @@ DEPENDS += "virtual/kernel" | |||
26 | 26 | ||
27 | LPMDSPPOWERSOC_omap3 = "omap3530" | 27 | LPMDSPPOWERSOC_omap3 = "omap3530" |
28 | LPMDSPPOWERSOC_dm6446 = "dm6446" | 28 | LPMDSPPOWERSOC_dm6446 = "dm6446" |
29 | LPMDSPPOWERSOC ?= "<UNDEFINED_LPMDSPPOWERSOC>" | 29 | LPMDSPPOWERSOC ?= "UNDEFINED_LPMDSPPOWERSOC" |
30 | 30 | ||
31 | XDC_PLATFORM_dm6446 = "ti.platforms.evmDM6446" | 31 | XDC_PLATFORM_dm6446 = "ti.platforms.evmDM6446" |
32 | XDC_PLATFORM_omap3 = "ti.platforms.evm3530" | 32 | XDC_PLATFORM_omap3 = "ti.platforms.evm3530" |
33 | XDC_PLATFORM ?= "<UNDEFINED_XDC_PLATFORM>" | 33 | XDC_PLATFORM ?= "UNDEFINED_XDC_PLATFORM" |
34 | 34 | ||
35 | do_configure () { | 35 | do_configure () { |
36 | 36 | ||
@@ -100,7 +100,7 @@ do_install () { | |||
100 | 100 | ||
101 | # Install the Utilities | 101 | # Install the Utilities |
102 | install -d ${D}/${installdir}/ti-lpm-utils | 102 | install -d ${D}/${installdir}/ti-lpm-utils |
103 | install -m 0755 ${S}/packages/ti/bios/power/utils/bin/$(echo ${XDC_PLATFORM} | sed s:\\.:_:g)/linux/release/* ${D}/${installdir}/ti-lpm-utils | 103 | install -m 0755 ${S}/packages/ti/bios/power/utils/bin/$(echo ${XDC_PLATFORM} | tr . _)/linux/release/* ${D}/${installdir}/ti-lpm-utils |
104 | 104 | ||
105 | # Install/Stage the Source Tree | 105 | # Install/Stage the Source Tree |
106 | install -d ${D}${LPM_INSTALL_DIR_RECIPE} | 106 | install -d ${D}${LPM_INSTALL_DIR_RECIPE} |