diff options
author | Sam Nelson <sam.nelson@ti.com> | 2017-10-17 09:19:52 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2017-10-19 15:42:10 -0400 |
commit | 85d95b93dd48accdb1803101bce35f69a59cf3c7 (patch) | |
tree | a3b8b2093451a598d1225c60fb628629afa65abf /recipes-ti/ipc | |
parent | 8ac18852dca3fbffce580944a6191d8ab9edd7cc (diff) | |
download | meta-ti-85d95b93dd48accdb1803101bce35f69a59cf3c7.tar.gz |
ti-ipc: Update to new version 3.47.00.00
Needs BIOS 6_52_00_12 and in turn needs gcc tools gcc-arm-none-
eabi-6-2017-q1-update
ti-ipc-examples: Separate Host linux and bios examples
This should save some build time as well, as ti-ipc-examples-linux will
only build linux host examples
Signed-off-by: Sam Nelson <sam.nelson@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-ti/ipc')
-rw-r--r-- | recipes-ti/ipc/ti-ipc-common.inc | 4 | ||||
-rw-r--r-- | recipes-ti/ipc/ti-ipc-examples-linux_git.bb | 48 | ||||
-rw-r--r-- | recipes-ti/ipc/ti-ipc-examples.inc | 31 | ||||
-rw-r--r-- | recipes-ti/ipc/ti-ipc-examples_git.bb | 64 | ||||
-rw-r--r-- | recipes-ti/ipc/ti-ipc-rtos.inc | 8 | ||||
-rw-r--r-- | recipes-ti/ipc/ti-ipc.inc | 6 |
6 files changed, 94 insertions, 67 deletions
diff --git a/recipes-ti/ipc/ti-ipc-common.inc b/recipes-ti/ipc/ti-ipc-common.inc index f2df6785..2fb7ffbc 100644 --- a/recipes-ti/ipc/ti-ipc-common.inc +++ b/recipes-ti/ipc/ti-ipc-common.inc | |||
@@ -1,5 +1,5 @@ | |||
1 | PV = "3.46.02.04" | 1 | PV = "3.47.00.00" |
2 | INC_PR = "r1" | 2 | INC_PR = "r0" |
3 | 3 | ||
4 | PACKAGE_ARCH = "${MACHINE_ARCH}" | 4 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
5 | 5 | ||
diff --git a/recipes-ti/ipc/ti-ipc-examples-linux_git.bb b/recipes-ti/ipc/ti-ipc-examples-linux_git.bb new file mode 100644 index 00000000..2340206c --- /dev/null +++ b/recipes-ti/ipc/ti-ipc-examples-linux_git.bb | |||
@@ -0,0 +1,48 @@ | |||
1 | DESCRIPTION = "TI Inter Process Communication (IPC) examples with Host running bios" | ||
2 | require ti-ipc-examples.inc | ||
3 | |||
4 | DEPENDS = "ti-ipc ti-xdctools ti-sysbios ti-ipc-rtos" | ||
5 | |||
6 | do_compile_append() { | ||
7 | |||
8 | if [ "${PLATFORM}" != "UNKNOWN" ]; then | ||
9 | oe_runmake extract HOSTOS="linux" IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" | ||
10 | |||
11 | if [ ! -z ${ALT_PLATFORM} ]; then | ||
12 | oe_runmake extract PLATFORM="${ALT_PLATFORM}" HOSTOS="linux" \ | ||
13 | IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" | ||
14 | fi | ||
15 | oe_runmake -C examples all HOSTOS="linux" \ | ||
16 | LINUX_SYSROOT_DIR="${STAGING_INCDIR}" \ | ||
17 | IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" | ||
18 | |||
19 | if [ ! -z ${ALT_PLATFORM} ]; then | ||
20 | oe_runmake -C examples all HOSTOS="linux" \ | ||
21 | LINUX_SYSROOT_DIR="${STAGING_INCDIR}" \ | ||
22 | IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \ | ||
23 | PLATFORM="${ALT_PLATFORM}" | ||
24 | fi | ||
25 | fi | ||
26 | } | ||
27 | |||
28 | do_install_append() { | ||
29 | cd ${S_ipc-examples}/src | ||
30 | IPC_VERSION=`echo ${PV}${RELEASE_SUFFIX} | sed -e 's|\.|_|g'` | ||
31 | |||
32 | if [ "${PLATFORM}" != "UNKNOWN" ]; then | ||
33 | # Install directory for linux examples | ||
34 | install -d ${D}${bindir}/ipc/examples | ||
35 | oe_runmake -C examples install IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \ | ||
36 | LINUX_SYSROOT_DIR="${STAGING_INCDIR}" \ | ||
37 | HOSTOS="linux" EXEC_DIR="${D}/${bindir}/ipc/examples" | ||
38 | |||
39 | if [ ! -z ${ALT_PLATFORM} ]; then | ||
40 | oe_runmake -C examples install IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \ | ||
41 | LINUX_SYSROOT_DIR="${STAGING_INCDIR}" \ | ||
42 | HOSTOS="linux" EXEC_DIR="${D}/${bindir}/ipc/examples" \ | ||
43 | PLATFORM="${ALT_PLATFORM}" | ||
44 | fi | ||
45 | fi | ||
46 | } | ||
47 | |||
48 | FILES_${PN} += "${bindir}/*" | ||
diff --git a/recipes-ti/ipc/ti-ipc-examples.inc b/recipes-ti/ipc/ti-ipc-examples.inc new file mode 100644 index 00000000..c9fe2cbc --- /dev/null +++ b/recipes-ti/ipc/ti-ipc-examples.inc | |||
@@ -0,0 +1,31 @@ | |||
1 | HOMEPAGE = "http://processors.wiki.ti.com/index.php/Category:IPC" | ||
2 | require ti-ipc-common.inc | ||
3 | require ti-ipc-rtos.inc | ||
4 | |||
5 | LICENSE = "BSD" | ||
6 | LIC_FILES_CHKSUM = "file://${S_ipc-examples}/src/makefile;beginline=1;endline=30;md5=fb83580b16bce88e8ed568a6005c8f02" | ||
7 | |||
8 | INSANE_SKIP_${PN} += "arch" | ||
9 | |||
10 | ALLOW_EMPTY_${PN} = "1" | ||
11 | |||
12 | IPC_INSTALL_DIR = "${STAGING_DIR_TARGET}/usr/share/ti/ti-ipc-tree" | ||
13 | |||
14 | do_compile() { | ||
15 | |||
16 | cd ${S_ipc-examples}/src | ||
17 | oe_runmake .examples \ | ||
18 | IPCTOOLS="${S_ipc-metadata}/src/etc" | ||
19 | |||
20 | if [ ! -z ${ALT_PLATFORM} ]; then | ||
21 | oe_runmake .examples "PLATFORM=${ALT_PLATFORM}" \ | ||
22 | IPCTOOLS="${S_ipc-metadata}/src/etc" | ||
23 | fi | ||
24 | } | ||
25 | |||
26 | do_install() { | ||
27 | cd ${S_ipc-examples}/src | ||
28 | IPC_VERSION=`echo ${PV}${RELEASE_SUFFIX} | sed -e 's|\.|_|g'` | ||
29 | } | ||
30 | |||
31 | INHIBIT_PACKAGE_STRIP = "1" | ||
diff --git a/recipes-ti/ipc/ti-ipc-examples_git.bb b/recipes-ti/ipc/ti-ipc-examples_git.bb index 34735d29..d728983e 100644 --- a/recipes-ti/ipc/ti-ipc-examples_git.bb +++ b/recipes-ti/ipc/ti-ipc-examples_git.bb | |||
@@ -1,80 +1,35 @@ | |||
1 | DESCRIPTION = "TI Inter Process Communication (IPC) examples" | 1 | DESCRIPTION = "TI Inter Process Communication (IPC) examples with Host running linux" |
2 | HOMEPAGE = "http://processors.wiki.ti.com/index.php/Category:IPC" | 2 | require ti-ipc-examples.inc |
3 | require ti-ipc-common.inc | ||
4 | require ti-ipc-rtos.inc | ||
5 | |||
6 | LICENSE = "BSD" | ||
7 | LIC_FILES_CHKSUM = "file://${S_ipc-examples}/src/makefile;beginline=1;endline=30;md5=fb83580b16bce88e8ed568a6005c8f02" | ||
8 | 3 | ||
9 | DEPENDS = "ti-ipc ti-xdctools ti-sysbios ti-ipc-rtos zip-native" | 4 | DEPENDS = "ti-ipc ti-xdctools ti-sysbios ti-ipc-rtos zip-native" |
10 | 5 | ||
11 | INSANE_SKIP_${PN} += "arch" | 6 | do_compile_append() { |
12 | |||
13 | ALLOW_EMPTY_${PN} = "1" | ||
14 | |||
15 | PACKAGES =+ "${PN}-linux" | ||
16 | |||
17 | INSANE_SKIP_${PN}-linux += "arch" | ||
18 | ALLOW_EMPTY_${PN}-linux = "1" | ||
19 | |||
20 | IPC_INSTALL_DIR = "${STAGING_DIR_TARGET}/usr/share/ti/ti-ipc-tree" | ||
21 | |||
22 | do_compile() { | ||
23 | |||
24 | cd ${S_ipc-examples}/src | ||
25 | oe_runmake .examples \ | ||
26 | IPCTOOLS="${S_ipc-metadata}/src/etc" | ||
27 | 7 | ||
28 | if [ ! -z ${ALT_PLATFORM} ]; then | ||
29 | oe_runmake .examples "PLATFORM=${ALT_PLATFORM}" \ | ||
30 | IPCTOOLS="${S_ipc-metadata}/src/etc" | ||
31 | echo test | ||
32 | fi | ||
33 | if [ "${PLATFORM}" != "UNKNOWN" ]; then | 8 | if [ "${PLATFORM}" != "UNKNOWN" ]; then |
34 | oe_runmake extract HOSTOS="bios" IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" | 9 | oe_runmake extract HOSTOS="bios" IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" |
35 | oe_runmake extract HOSTOS="linux" IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" | ||
36 | 10 | ||
37 | if [ ! -z ${ALT_PLATFORM} ]; then | 11 | if [ ! -z ${ALT_PLATFORM} ]; then |
38 | oe_runmake extract PLATFORM="${ALT_PLATFORM}" HOSTOS="bios" \ | 12 | oe_runmake extract PLATFORM="${ALT_PLATFORM}" HOSTOS="bios" \ |
39 | IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" | 13 | IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" |
40 | oe_runmake extract PLATFORM="${ALT_PLATFORM}" HOSTOS="linux" \ | ||
41 | IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" | ||
42 | fi | 14 | fi |
43 | oe_runmake -C examples all HOSTOS="bios" \ | 15 | oe_runmake -C examples all HOSTOS="bios" \ |
44 | IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" | 16 | IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" |
45 | oe_runmake -C examples all HOSTOS="linux" \ | ||
46 | LINUX_SYSROOT_DIR="${STAGING_INCDIR}" \ | ||
47 | IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" | ||
48 | if [ ! -z ${ALT_PLATFORM} ]; then | 17 | if [ ! -z ${ALT_PLATFORM} ]; then |
49 | oe_runmake -C examples all HOSTOS="bios" \ | 18 | oe_runmake -C examples all HOSTOS="bios" \ |
50 | IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" PLATFORM="${ALT_PLATFORM}" | 19 | IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" PLATFORM="${ALT_PLATFORM}" |
51 | oe_runmake -C examples all HOSTOS="linux" \ | ||
52 | LINUX_SYSROOT_DIR="${STAGING_INCDIR}" \ | ||
53 | IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \ | ||
54 | PLATFORM="${ALT_PLATFORM}" | ||
55 | echo testing | ||
56 | fi | 20 | fi |
57 | fi | 21 | fi |
58 | } | 22 | } |
59 | 23 | ||
60 | do_install() { | 24 | do_install_append() { |
61 | cd ${S_ipc-examples}/src | ||
62 | IPC_VERSION=`echo ${PV}${RELEASE_SUFFIX} | sed -e 's|\.|_|g'` | ||
63 | |||
64 | if [ "${PLATFORM}" != "UNKNOWN" ]; then | 25 | if [ "${PLATFORM}" != "UNKNOWN" ]; then |
65 | # Install directory for bios examples | 26 | # Install directory for bios examples |
66 | install -d ${D}/ipc_${IPC_VERSION}/examples/bios | 27 | install -d ${D}/ipc_${IPC_VERSION}/examples/bios |
67 | # Install directory for linux examples | ||
68 | install -d ${D}${bindir}/ipc/examples | ||
69 | oe_runmake -C examples install IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \ | 28 | oe_runmake -C examples install IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \ |
70 | HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples/bios" | 29 | HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples/bios" |
71 | oe_runmake -C examples install_rov IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \ | 30 | oe_runmake -C examples install_rov IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \ |
72 | HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples/bios" | 31 | HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples/bios" |
73 | 32 | ||
74 | oe_runmake -C examples install IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \ | ||
75 | LINUX_SYSROOT_DIR="${STAGING_INCDIR}" \ | ||
76 | HOSTOS="linux" EXEC_DIR="${D}/${bindir}/ipc/examples" | ||
77 | |||
78 | if [ ! -z ${ALT_PLATFORM} ]; then | 33 | if [ ! -z ${ALT_PLATFORM} ]; then |
79 | oe_runmake -C examples install IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \ | 34 | oe_runmake -C examples install IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \ |
80 | HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples/bios" \ | 35 | HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples/bios" \ |
@@ -82,15 +37,8 @@ do_install() { | |||
82 | oe_runmake -C examples install_rov IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \ | 37 | oe_runmake -C examples install_rov IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \ |
83 | HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples/bios" \ | 38 | HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples/bios" \ |
84 | PLATFORM="${ALT_PLATFORM}" | 39 | PLATFORM="${ALT_PLATFORM}" |
85 | |||
86 | oe_runmake -C examples install IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \ | ||
87 | LINUX_SYSROOT_DIR="${STAGING_INCDIR}" \ | ||
88 | HOSTOS="linux" EXEC_DIR="${D}/${bindir}/ipc/examples" \ | ||
89 | PLATFORM="${ALT_PLATFORM}" | ||
90 | fi | 40 | fi |
91 | fi | 41 | fi |
92 | } | 42 | } |
93 | 43 | ||
94 | FILES_${PN} += "ipc_*" | 44 | FILES_${PN} += "ipc_*" |
95 | FILES_${PN}-linux += "${bindir}/*" | ||
96 | INHIBIT_PACKAGE_STRIP = "1" | ||
diff --git a/recipes-ti/ipc/ti-ipc-rtos.inc b/recipes-ti/ipc/ti-ipc-rtos.inc index a7c1b3af..57cd1325 100644 --- a/recipes-ti/ipc/ti-ipc-rtos.inc +++ b/recipes-ti/ipc/ti-ipc-rtos.inc | |||
@@ -24,11 +24,11 @@ protocol=${TI_IPC_METADATA_GIT_PROTOCOL};\ | |||
24 | branch=${TI_IPC_METADATA_GIT_BRANCH};\ | 24 | branch=${TI_IPC_METADATA_GIT_BRANCH};\ |
25 | name=${TI_IPC_METADATA_NAME}" | 25 | name=${TI_IPC_METADATA_NAME}" |
26 | 26 | ||
27 | # Corresponds to tag: 3.46.02.04 | 27 | # Corresponds to tag: 3.47.00.00 |
28 | SRCREV_ipc-examples = "b833c759d620b4218ece6d64fae91e4777ef823a" | 28 | SRCREV_ipc-examples = "e71b82187a324faa9394b83e39495be38255f05b" |
29 | 29 | ||
30 | # Corresponds to tag: 3.46.02.04 | 30 | # Corresponds to tag: 3.47.00.00 |
31 | SRCREV_ipc-metadata = "afdcf6855f05c97d2bb77867f4f150aed29c1b12" | 31 | SRCREV_ipc-metadata = "f026a364d0b9c1aba5c695bf0aac0be8ede95f59" |
32 | 32 | ||
33 | S_ipc-examples = "${WORKDIR}/git/ipc-examples" | 33 | S_ipc-examples = "${WORKDIR}/git/ipc-examples" |
34 | S_ipc-metadata = "${WORKDIR}/git/ipc-metadata" | 34 | S_ipc-metadata = "${WORKDIR}/git/ipc-metadata" |
diff --git a/recipes-ti/ipc/ti-ipc.inc b/recipes-ti/ipc/ti-ipc.inc index c3742c1b..02f3c8d3 100644 --- a/recipes-ti/ipc/ti-ipc.inc +++ b/recipes-ti/ipc/ti-ipc.inc | |||
@@ -6,10 +6,10 @@ LIC_FILES_CHKSUM = "file://${S}/ipc-linux.mak;beginline=1;endline=30;md5=7b327f9 | |||
6 | 6 | ||
7 | TI_IPC_GIT_URI = "git://git.ti.com/ipc/ipcdev.git" | 7 | TI_IPC_GIT_URI = "git://git.ti.com/ipc/ipcdev.git" |
8 | TI_IPC_GIT_PROTOCOL = "git" | 8 | TI_IPC_GIT_PROTOCOL = "git" |
9 | TI_IPC_GIT_BRANCH = "3.46" | 9 | TI_IPC_GIT_BRANCH = "3.47" |
10 | 10 | ||
11 | #Corresponds to 3.46.02.04 | 11 | #Corresponds to 3.47.00.00 |
12 | TI_IPC_SRCREV = "bf355e7d0f5c3993f56a6ea778743b656ef6b536" | 12 | TI_IPC_SRCREV = "e576990e3a220ad394b287588c1c7e85e8644d23" |
13 | 13 | ||
14 | BRANCH = "${TI_IPC_GIT_BRANCH}" | 14 | BRANCH = "${TI_IPC_GIT_BRANCH}" |
15 | SRC_URI = "${TI_IPC_GIT_URI};protocol=${TI_IPC_GIT_PROTOCOL};branch=${BRANCH};name=ipcdev" | 15 | SRC_URI = "${TI_IPC_GIT_URI};protocol=${TI_IPC_GIT_PROTOCOL};branch=${BRANCH};name=ipcdev" |