diff options
author | Maupin, Chase <chase.maupin@ti.com> | 2014-05-20 01:19:40 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2014-05-21 15:36:58 -0400 |
commit | ec17eef312f281484e4cb96c1370303ca57b6daf (patch) | |
tree | a00f07497cf1b967b51a6a3de94afa82825cbea4 /recipes-ti/ipc | |
parent | cc23fcacc1445adcc586a082f0f59170ccaee2ee (diff) | |
download | meta-ti-ec17eef312f281484e4cb96c1370303ca57b6daf.tar.gz |
ti-ipc: Consolidate include file and old recipe
* The ti-ipc.inc file was for the legacy 1.24.00.16 version of
ti-ipc. So consolidate these files together since there is
only one version of the ti-ipc recipe that needs that .inc
file and there are no updates planned for it.
Signed-off-by: Chase Maupin <Chase.Maupin@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-ti/ipc')
-rw-r--r-- | recipes-ti/ipc/ti-ipc.inc | 36 | ||||
-rw-r--r-- | recipes-ti/ipc/ti-ipc_1.24.00.16.bb | 37 |
2 files changed, 35 insertions, 38 deletions
diff --git a/recipes-ti/ipc/ti-ipc.inc b/recipes-ti/ipc/ti-ipc.inc deleted file mode 100644 index 7f4b919b..00000000 --- a/recipes-ti/ipc/ti-ipc.inc +++ /dev/null | |||
@@ -1,36 +0,0 @@ | |||
1 | DESCRIPTION = "TI Inter Process Ccommunication (IPC) Mechanisms (for Uni- and Multi- Processor Configurations)" | ||
2 | HOMEPAGE = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/ipc/index.html" | ||
3 | |||
4 | SECTION = "devel" | ||
5 | LICENSE = "BSD" | ||
6 | |||
7 | require ../includes/ti-paths.inc | ||
8 | require ../includes/ti-staging.inc | ||
9 | require ../includes/ti-eula-unpack.inc | ||
10 | |||
11 | S = "${WORKDIR}/ipc_${PV}" | ||
12 | |||
13 | SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/ipc/${PV}/exports/ipc_setuplinux_${PV}.bin;name=ipcbin" | ||
14 | |||
15 | SRC_URI =+ "file://ipc.pc" | ||
16 | |||
17 | DEPENDS = "ti-sysbios ti-cgt6x ti-xdctools" | ||
18 | |||
19 | BINFILE="ipc_setuplinux_${PV}.bin" | ||
20 | TI_BIN_UNPK_CMDS="Y: q:workdir:Y" | ||
21 | |||
22 | do_configure() { | ||
23 | sed -i -e s:@VERSION@:${PV}:g ${WORKDIR}/ipc.pc | ||
24 | |||
25 | cp ${WORKDIR}/ipc.pc ${S} | ||
26 | } | ||
27 | |||
28 | do_install() { | ||
29 | install -d ${D}${IPC_INSTALL_DIR_RECIPE} | ||
30 | cp -pPrf ${S}/* ${D}${IPC_INSTALL_DIR_RECIPE} | ||
31 | |||
32 | install -d ${D}/${libdir}/pkgconfig | ||
33 | install ${S}/ipc.pc ${D}/${libdir}/pkgconfig/ | ||
34 | } | ||
35 | |||
36 | FILES_${PN}-dev = "${libdir}/*" | ||
diff --git a/recipes-ti/ipc/ti-ipc_1.24.00.16.bb b/recipes-ti/ipc/ti-ipc_1.24.00.16.bb index e7ae7ef1..420d0f7d 100644 --- a/recipes-ti/ipc/ti-ipc_1.24.00.16.bb +++ b/recipes-ti/ipc/ti-ipc_1.24.00.16.bb | |||
@@ -1,8 +1,41 @@ | |||
1 | require ti-ipc.inc | 1 | DESCRIPTION = "TI Inter Process Ccommunication (IPC) Mechanisms (for Uni- and Multi- Processor Configurations)" |
2 | HOMEPAGE = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/ipc/index.html" | ||
3 | SECTION = "devel" | ||
4 | LICENSE = "BSD" | ||
5 | LIC_FILES_CHKSUM = "file://ipc_${PV}_manifest.html;md5=573f5a5c0448d28bf8db35f438244d7f" | ||
6 | |||
7 | |||
8 | require ../includes/ti-paths.inc | ||
9 | require ../includes/ti-staging.inc | ||
10 | require ../includes/ti-eula-unpack.inc | ||
2 | 11 | ||
3 | PV = "1_24_00_16" | 12 | PV = "1_24_00_16" |
4 | 13 | ||
5 | LIC_FILES_CHKSUM = "file://ipc_${PV}_manifest.html;md5=573f5a5c0448d28bf8db35f438244d7f" | 14 | S = "${WORKDIR}/ipc_${PV}" |
15 | |||
16 | SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/ipc/${PV}/exports/ipc_setuplinux_${PV}.bin;name=ipcbin \ | ||
17 | file://ipc.pc" | ||
18 | |||
19 | DEPENDS = "ti-sysbios ti-cgt6x ti-xdctools" | ||
20 | |||
21 | BINFILE="ipc_setuplinux_${PV}.bin" | ||
22 | TI_BIN_UNPK_CMDS="Y: q:workdir:Y" | ||
23 | |||
24 | do_configure() { | ||
25 | sed -i -e s:@VERSION@:${PV}:g ${WORKDIR}/ipc.pc | ||
26 | |||
27 | cp ${WORKDIR}/ipc.pc ${S} | ||
28 | } | ||
29 | |||
30 | do_install() { | ||
31 | install -d ${D}${IPC_INSTALL_DIR_RECIPE} | ||
32 | cp -pPrf ${S}/* ${D}${IPC_INSTALL_DIR_RECIPE} | ||
33 | |||
34 | install -d ${D}/${libdir}/pkgconfig | ||
35 | install ${S}/ipc.pc ${D}/${libdir}/pkgconfig/ | ||
36 | } | ||
37 | |||
38 | FILES_${PN}-dev = "${libdir}/*" | ||
6 | 39 | ||
7 | SRC_URI[ipcbin.md5sum] = "d2f7cc82310d555ca039dcd353bd94c5" | 40 | SRC_URI[ipcbin.md5sum] = "d2f7cc82310d555ca039dcd353bd94c5" |
8 | SRC_URI[ipcbin.sha256sum] = "96df7835e920c7dabcd63d30ec8bc2aea7cd0c6197c9fb9ca0f8a9b681aa5396" | 41 | SRC_URI[ipcbin.sha256sum] = "96df7835e920c7dabcd63d30ec8bc2aea7cd0c6197c9fb9ca0f8a9b681aa5396" |