diff options
author | Mertz, Timothy <timothy.mertz@garmin.com> | 2017-12-17 00:06:15 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2017-12-21 23:11:55 -0500 |
commit | de8bb5892cee542419667f6a3ec6590e098eab44 (patch) | |
tree | ee46df4f2602ca357d0617ffe66de5c9c641282b /recipes-ti/ipc | |
parent | 15f036ff15a7de69647252a6aec651fdcbc088a3 (diff) | |
download | meta-ti-de8bb5892cee542419667f6a3ec6590e098eab44.tar.gz |
ti-xdctools: extend to native and nativesdk
ti-xdctools should be a native recipe as it more accurately reflects how
it is supposed to be used. In addition, this allows it to be built as
nativesdk and included in SDK image tools
Signed-off-by: "Mertz, Timothy" <timothy.mertz@garmin.com>
Signed-off-by: Joshua Watt <JPEWhacker@gmail.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Acked-by: Jacob Stiffler <j-stiffler@ti.com>
Diffstat (limited to 'recipes-ti/ipc')
-rw-r--r-- | recipes-ti/ipc/ti-ipc-examples-linux_git.bb | 2 | ||||
-rw-r--r-- | recipes-ti/ipc/ti-ipc-examples_git.bb | 2 | ||||
-rw-r--r-- | recipes-ti/ipc/ti-ipc-rtos_git.bb | 2 |
3 files changed, 3 insertions, 3 deletions
diff --git a/recipes-ti/ipc/ti-ipc-examples-linux_git.bb b/recipes-ti/ipc/ti-ipc-examples-linux_git.bb index 4701ebaa..ddbe48f5 100644 --- a/recipes-ti/ipc/ti-ipc-examples-linux_git.bb +++ b/recipes-ti/ipc/ti-ipc-examples-linux_git.bb | |||
@@ -1,7 +1,7 @@ | |||
1 | DESCRIPTION = "TI Inter Process Communication (IPC) examples with Host running bios" | 1 | DESCRIPTION = "TI Inter Process Communication (IPC) examples with Host running bios" |
2 | require ti-ipc-examples.inc | 2 | require ti-ipc-examples.inc |
3 | 3 | ||
4 | DEPENDS = "ti-ipc ti-xdctools ti-sysbios ti-ipc-rtos zip-native" | 4 | DEPENDS = "ti-ipc ti-xdctools-native ti-sysbios ti-ipc-rtos zip-native" |
5 | 5 | ||
6 | do_compile_append() { | 6 | do_compile_append() { |
7 | 7 | ||
diff --git a/recipes-ti/ipc/ti-ipc-examples_git.bb b/recipes-ti/ipc/ti-ipc-examples_git.bb index d728983e..8aad69c9 100644 --- a/recipes-ti/ipc/ti-ipc-examples_git.bb +++ b/recipes-ti/ipc/ti-ipc-examples_git.bb | |||
@@ -1,7 +1,7 @@ | |||
1 | DESCRIPTION = "TI Inter Process Communication (IPC) examples with Host running linux" | 1 | DESCRIPTION = "TI Inter Process Communication (IPC) examples with Host running linux" |
2 | require ti-ipc-examples.inc | 2 | require ti-ipc-examples.inc |
3 | 3 | ||
4 | DEPENDS = "ti-ipc ti-xdctools ti-sysbios ti-ipc-rtos zip-native" | 4 | DEPENDS = "ti-ipc ti-xdctools-native ti-sysbios ti-ipc-rtos zip-native" |
5 | 5 | ||
6 | do_compile_append() { | 6 | do_compile_append() { |
7 | 7 | ||
diff --git a/recipes-ti/ipc/ti-ipc-rtos_git.bb b/recipes-ti/ipc/ti-ipc-rtos_git.bb index 886beb9a..4040c4d9 100644 --- a/recipes-ti/ipc/ti-ipc-rtos_git.bb +++ b/recipes-ti/ipc/ti-ipc-rtos_git.bb | |||
@@ -2,7 +2,7 @@ require ti-ipc.inc | |||
2 | require ti-ipc-common.inc | 2 | require ti-ipc-common.inc |
3 | require ti-ipc-rtos.inc | 3 | require ti-ipc-rtos.inc |
4 | 4 | ||
5 | DEPENDS = "ti-xdctools ti-sysbios zip-native" | 5 | DEPENDS = "ti-xdctools-native ti-sysbios doxygen-native zip-native" |
6 | 6 | ||
7 | PACKAGES =+ "${PN}-fw" | 7 | PACKAGES =+ "${PN}-fw" |
8 | FILES_${PN}-fw = "${base_libdir}/firmware/*" | 8 | FILES_${PN}-fw = "${base_libdir}/firmware/*" |