summaryrefslogtreecommitdiffstats
path: root/recipes-ti/ipc
diff options
context:
space:
mode:
authorSam Nelson <sam.nelson@ti.com>2018-05-17 23:04:44 +0000
committerDenys Dmytriyenko <denys@ti.com>2018-06-01 18:29:37 +0000
commitdd8400c12149163576723a4778e11ebd01a89b37 (patch)
treee0d5e6ebf3c6868e8a11d88e84dbadc6b59152fe /recipes-ti/ipc
parent12e2064557ac7b97ed60217ad1b0f768d1ad64f1 (diff)
downloadmeta-ti-dd8400c12149163576723a4778e11ebd01a89b37.tar.gz
ti-ipc: Update to new version 3.47.02.00
Adds new example for AM571X Signed-off-by: Sam Nelson <sam.nelson@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-ti/ipc')
-rw-r--r--recipes-ti/ipc/ti-ipc-common.inc5
-rw-r--r--recipes-ti/ipc/ti-ipc-examples.inc6
-rw-r--r--recipes-ti/ipc/ti-ipc-examples_git.bb24
-rw-r--r--recipes-ti/ipc/ti-ipc-rtos.inc10
-rw-r--r--recipes-ti/ipc/ti-ipc-rtos_git.bb20
-rw-r--r--recipes-ti/ipc/ti-ipc.inc4
6 files changed, 35 insertions, 34 deletions
diff --git a/recipes-ti/ipc/ti-ipc-common.inc b/recipes-ti/ipc/ti-ipc-common.inc
index 00e4e915..7f938428 100644
--- a/recipes-ti/ipc/ti-ipc-common.inc
+++ b/recipes-ti/ipc/ti-ipc-common.inc
@@ -1,5 +1,5 @@
1PV = "3.47.01.00" 1PV = "3.47.02.00"
2INC_PR = "r1" 2INC_PR = "r0"
3 3
4PACKAGE_ARCH = "${MACHINE_ARCH}" 4PACKAGE_ARCH = "${MACHINE_ARCH}"
5 5
@@ -15,3 +15,4 @@ PLATFORM_c667x-evm = "C6678"
15PLATFORM_c665x-evm = "C6678" 15PLATFORM_c665x-evm = "C6678"
16 16
17ALT_PLATFORM_k2hk = "TCI6636" 17ALT_PLATFORM_k2hk = "TCI6636"
18ALT_PLATFORM_am57xx-evm = "AM572X AM571X"
diff --git a/recipes-ti/ipc/ti-ipc-examples.inc b/recipes-ti/ipc/ti-ipc-examples.inc
index c9fe2cbc..cd2240cd 100644
--- a/recipes-ti/ipc/ti-ipc-examples.inc
+++ b/recipes-ti/ipc/ti-ipc-examples.inc
@@ -17,10 +17,10 @@ do_compile() {
17 oe_runmake .examples \ 17 oe_runmake .examples \
18 IPCTOOLS="${S_ipc-metadata}/src/etc" 18 IPCTOOLS="${S_ipc-metadata}/src/etc"
19 19
20 if [ ! -z ${ALT_PLATFORM} ]; then 20 for alt_platform in ${ALT_PLATFORM}; do
21 oe_runmake .examples "PLATFORM=${ALT_PLATFORM}" \ 21 oe_runmake .examples "PLATFORM=${alt_platform}" \
22 IPCTOOLS="${S_ipc-metadata}/src/etc" 22 IPCTOOLS="${S_ipc-metadata}/src/etc"
23 fi 23 done
24} 24}
25 25
26do_install() { 26do_install() {
diff --git a/recipes-ti/ipc/ti-ipc-examples_git.bb b/recipes-ti/ipc/ti-ipc-examples_git.bb
index 8aad69c9..c46e5c81 100644
--- a/recipes-ti/ipc/ti-ipc-examples_git.bb
+++ b/recipes-ti/ipc/ti-ipc-examples_git.bb
@@ -8,16 +8,16 @@ do_compile_append() {
8 if [ "${PLATFORM}" != "UNKNOWN" ]; then 8 if [ "${PLATFORM}" != "UNKNOWN" ]; then
9 oe_runmake extract HOSTOS="bios" IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" 9 oe_runmake extract HOSTOS="bios" IPC_INSTALL_DIR="${IPC_INSTALL_DIR}"
10 10
11 if [ ! -z ${ALT_PLATFORM} ]; then 11 for alt_platform in ${ALT_PLATFORM}; do
12 oe_runmake extract PLATFORM="${ALT_PLATFORM}" HOSTOS="bios" \ 12 oe_runmake extract PLATFORM="${alt_platform}" HOSTOS="bios" \
13 IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" 13 IPC_INSTALL_DIR="${IPC_INSTALL_DIR}"
14 fi 14 done
15 oe_runmake -C examples all HOSTOS="bios" \ 15 oe_runmake -C examples all HOSTOS="bios" \
16 IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" 16 IPC_INSTALL_DIR="${IPC_INSTALL_DIR}"
17 if [ ! -z ${ALT_PLATFORM} ]; then 17 for alt_platform in ${ALT_PLATFORM}; do
18 oe_runmake -C examples all HOSTOS="bios" \ 18 oe_runmake -C examples all HOSTOS="bios" \
19 IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" PLATFORM="${ALT_PLATFORM}" 19 IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" PLATFORM="${alt_platform}"
20 fi 20 done
21 fi 21 fi
22} 22}
23 23
@@ -30,14 +30,14 @@ do_install_append() {
30 oe_runmake -C examples install_rov IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \ 30 oe_runmake -C examples install_rov IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \
31 HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples/bios" 31 HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples/bios"
32 32
33 if [ ! -z ${ALT_PLATFORM} ]; then 33 for alt_platform in ${ALT_PLATFORM}; do
34 oe_runmake -C examples install IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \ 34 oe_runmake -C examples install IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \
35 HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples/bios" \ 35 HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples/${alt_platform}/bios" \
36 PLATFORM="${ALT_PLATFORM}" 36 PLATFORM="${alt_platform}"
37 oe_runmake -C examples install_rov IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \ 37 oe_runmake -C examples install_rov IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \
38 HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples/bios" \ 38 HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples/${alt_platform}/bios" \
39 PLATFORM="${ALT_PLATFORM}" 39 PLATFORM="${alt_platform}"
40 fi 40 done
41 fi 41 fi
42} 42}
43 43
diff --git a/recipes-ti/ipc/ti-ipc-rtos.inc b/recipes-ti/ipc/ti-ipc-rtos.inc
index 3f876d3f..868743e6 100644
--- a/recipes-ti/ipc/ti-ipc-rtos.inc
+++ b/recipes-ti/ipc/ti-ipc-rtos.inc
@@ -24,11 +24,11 @@ protocol=${TI_IPC_METADATA_GIT_PROTOCOL};\
24branch=${TI_IPC_METADATA_GIT_BRANCH};\ 24branch=${TI_IPC_METADATA_GIT_BRANCH};\
25name=${TI_IPC_METADATA_NAME}" 25name=${TI_IPC_METADATA_NAME}"
26 26
27# Corresponds to tag: 3.47.01.00B 27# Corresponds to tag: 3.47.02.00
28SRCREV_ipc-examples = "03ff856444b5bb9e60a907125a1f042b29b25d7b" 28SRCREV_ipc-metadata = "e8aff83111b8a0d64d7a77413b6f66d3106084d8"
29 29
30# Corresponds to tag: 3.47.01.00A 30# Corresponds to tag: 3.47.02.00
31SRCREV_ipc-metadata = "72578cce9c9f9a932eb22b3397b46131efb12d69" 31SRCREV_ipc-examples = "351e9a6d94c68f7ff64b2c002ee6750242ece6d9"
32 32
33S_ipc-examples = "${WORKDIR}/git/ipc-examples" 33S_ipc-examples = "${WORKDIR}/git/ipc-examples"
34S_ipc-metadata = "${WORKDIR}/git/ipc-metadata" 34S_ipc-metadata = "${WORKDIR}/git/ipc-metadata"
@@ -36,7 +36,7 @@ S_ipc-metadata = "${WORKDIR}/git/ipc-metadata"
36RELEASE_TYPE = "GA" 36RELEASE_TYPE = "GA"
37RELEASE_SUFFIX = "" 37RELEASE_SUFFIX = ""
38 38
39PR = "${INC_PR}.r5" 39PR = "${INC_PR}.r0"
40 40
41DEPENDS_append_keystone = " ti-cgt6x-native \ 41DEPENDS_append_keystone = " ti-cgt6x-native \
42 gcc-arm-none-eabi-native \ 42 gcc-arm-none-eabi-native \
diff --git a/recipes-ti/ipc/ti-ipc-rtos_git.bb b/recipes-ti/ipc/ti-ipc-rtos_git.bb
index 53ab76da..b292d677 100644
--- a/recipes-ti/ipc/ti-ipc-rtos_git.bb
+++ b/recipes-ti/ipc/ti-ipc-rtos_git.bb
@@ -27,20 +27,20 @@ do_compile() {
27 cd ${S_ipc-examples}/src 27 cd ${S_ipc-examples}/src
28 oe_runmake .examples \ 28 oe_runmake .examples \
29 IPCTOOLS="${S_ipc-metadata}/src/etc" 29 IPCTOOLS="${S_ipc-metadata}/src/etc"
30 if [ ! -z ${ALT_PLATFORM} ]; then 30 for alt_platform in ${ALT_PLATFORM}; do
31 oe_runmake .examples \ 31 oe_runmake .examples \
32 IPCTOOLS="${S_ipc-metadata}/src/etc" \ 32 IPCTOOLS="${S_ipc-metadata}/src/etc" \
33 PLATFORM=${ALT_PLATFORM} 33 PLATFORM=${alt_platform}
34 fi 34 done
35 35
36 if [ "${PLATFORM}" != "UNKNOWN" ]; then 36 if [ "${PLATFORM}" != "UNKNOWN" ]; then
37 oe_runmake extract HOSTOS="bios" IPC_INSTALL_DIR="${S}" 37 oe_runmake extract HOSTOS="bios" IPC_INSTALL_DIR="${S}"
38 oe_runmake extract HOSTOS="linux" IPC_INSTALL_DIR="${S}" 38 oe_runmake extract HOSTOS="linux" IPC_INSTALL_DIR="${S}"
39 39
40 if [ ! -z ${ALT_PLATFORM} ]; then 40 for alt_platform in ${ALT_PLATFORM}; do
41 oe_runmake extract PLATFORM=${ALT_PLATFORM} HOSTOS="bios" IPC_INSTALL_DIR="${S}" 41 oe_runmake extract PLATFORM=${alt_platform} HOSTOS="bios" IPC_INSTALL_DIR="${S}"
42 oe_runmake extract PLATFORM=${ALT_PLATFORM} HOSTOS="linux" IPC_INSTALL_DIR="${S}" 42 oe_runmake extract PLATFORM=${alt_platform} HOSTOS="linux" IPC_INSTALL_DIR="${S}"
43 fi 43 done
44 fi 44 fi
45 45
46 IPC_VERSION=`echo ${PV}${RELEASE_SUFFIX} | sed -e 's|\.|_|g'` 46 IPC_VERSION=`echo ${PV}${RELEASE_SUFFIX} | sed -e 's|\.|_|g'`
@@ -54,9 +54,9 @@ do_compile() {
54 cp -pPf ${S_ipc-examples}/src/examples/*.* ${IPC_PACKAGE_DIR}/examples/ 54 cp -pPf ${S_ipc-examples}/src/examples/*.* ${IPC_PACKAGE_DIR}/examples/
55 cp -pPf ${S_ipc-examples}/src/examples/makefile ${IPC_PACKAGE_DIR}/examples/ 55 cp -pPf ${S_ipc-examples}/src/examples/makefile ${IPC_PACKAGE_DIR}/examples/
56 cp -pPrf ${S_ipc-examples}/src/examples/${PLATFORM}* ${IPC_PACKAGE_DIR}/examples/ 56 cp -pPrf ${S_ipc-examples}/src/examples/${PLATFORM}* ${IPC_PACKAGE_DIR}/examples/
57 if [ ! -z ${ALT_PLATFORM} ]; then 57 for alt_platform in ${ALT_PLATFORM}; do
58 cp -pPrf ${S_ipc-examples}/src/examples/${ALT_PLATFORM}* ${IPC_PACKAGE_DIR}/examples/ 58 cp -pPrf ${S_ipc-examples}/src/examples/${alt_platform}* ${IPC_PACKAGE_DIR}/examples/
59 fi 59 done
60 find ${IPC_PACKAGE_DIR}/examples/ -name "*zip" -type f | xargs -I {} rm {} 60 find ${IPC_PACKAGE_DIR}/examples/ -name "*zip" -type f | xargs -I {} rm {}
61 fi 61 fi
62} 62}
diff --git a/recipes-ti/ipc/ti-ipc.inc b/recipes-ti/ipc/ti-ipc.inc
index 49d8224f..e8038a56 100644
--- a/recipes-ti/ipc/ti-ipc.inc
+++ b/recipes-ti/ipc/ti-ipc.inc
@@ -8,8 +8,8 @@ TI_IPC_GIT_URI = "git://git.ti.com/ipc/ipcdev.git"
8TI_IPC_GIT_PROTOCOL = "git" 8TI_IPC_GIT_PROTOCOL = "git"
9TI_IPC_GIT_BRANCH = "3.47" 9TI_IPC_GIT_BRANCH = "3.47"
10 10
11#Corresponds to 3.47.01.00 11#Corresponds to 3.47.02.00
12TI_IPC_SRCREV = "6a2595a4148fb12f259efc19164a9d33ad2ed294" 12TI_IPC_SRCREV = "24c36385d096613af123d1e1696fb2fee652ef36"
13 13
14BRANCH = "${TI_IPC_GIT_BRANCH}" 14BRANCH = "${TI_IPC_GIT_BRANCH}"
15SRC_URI = "${TI_IPC_GIT_URI};protocol=${TI_IPC_GIT_PROTOCOL};branch=${BRANCH};name=ipcdev" 15SRC_URI = "${TI_IPC_GIT_URI};protocol=${TI_IPC_GIT_PROTOCOL};branch=${BRANCH};name=ipcdev"