summaryrefslogtreecommitdiffstats
path: root/recipes-ti/ipc
diff options
context:
space:
mode:
authorKoen Kooi <k-kooi@ti.com>2011-07-06 09:55:54 +0100
committerKoen Kooi <k-kooi@ti.com>2011-07-06 15:34:44 +0100
commit8f7291208ea7195654fa5ce6a3861f6eebb5916d (patch)
tree8169523bd504ef033032f3c99645df285a76e9ca /recipes-ti/ipc
parentcf66e1cd2881822c7e3fae1284e4b486e55c36c7 (diff)
downloadmeta-ti-8f7291208ea7195654fa5ce6a3861f6eebb5916d.tar.gz
add ipc 1.23.02.27
Signed-off-by: Koen Kooi <k-kooi@ti.com>
Diffstat (limited to 'recipes-ti/ipc')
-rw-r--r--recipes-ti/ipc/ti-ipc.inc36
-rw-r--r--recipes-ti/ipc/ti-ipc/ipc.pc8
-rw-r--r--recipes-ti/ipc/ti-ipc_1.23.02.27.bb9
3 files changed, 53 insertions, 0 deletions
diff --git a/recipes-ti/ipc/ti-ipc.inc b/recipes-ti/ipc/ti-ipc.inc
new file mode 100644
index 00000000..8d1b8020
--- /dev/null
+++ b/recipes-ti/ipc/ti-ipc.inc
@@ -0,0 +1,36 @@
1DESCRIPTION = "TI Inter Process Ccommunication (IPC) Mechanisms (for Uni- and Multi- Processor Configurations)"
2HOMEPAGE = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/ipc/index.html"
3
4SECTION = "devel"
5LICENSE = "BSD"
6
7require ../includes/ti-paths.inc
8require ../includes/ti-staging.inc
9require ../includes/ti-eula-unpack.inc
10
11S = "${WORKDIR}/ipc_${PV}"
12
13SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/ipc/${PV}/exports/ipc_setuplinux_${PV}.bin;name=ipcbin"
14
15SRC_URI =+ "file://ipc.pc"
16
17DEPENDS = "ti-sysbios ti-cgt6x ti-xdctools"
18
19BINFILE="ipc_setuplinux_${PV}.bin"
20TI_BIN_UNPK_CMDS="Y: q:workdir:Y"
21
22do_configure() {
23 sed -i -e s:@VERSION@:${PV}:g ${WORKDIR}/ipc.pc
24
25 cp ${WORKDIR}/ipc.pc ${S}
26}
27
28do_install() {
29 install -d ${D}${IPC_INSTALL_DIR_RECIPE}
30 cp -pPrf ${S}/* ${D}${IPC_INSTALL_DIR_RECIPE}
31
32 install -d ${D}/${libdir}/pkgconfig
33 install ${S}/ipc.pc ${D}/${libdir}/pkgconfig/
34}
35
36FILES_ti-ipc-dev = "${libdir}/*"
diff --git a/recipes-ti/ipc/ti-ipc/ipc.pc b/recipes-ti/ipc/ti-ipc/ipc.pc
new file mode 100644
index 00000000..1a8c52df
--- /dev/null
+++ b/recipes-ti/ipc/ti-ipc/ipc.pc
@@ -0,0 +1,8 @@
1prefix=/../../ipc_@VERSION@
2includedir=${prefix}/ti/ipc
3
4Name: TI IPC
5Description: TI ARM-DSP IPC (Inter Processor Communication)
6Version: @VERSION@
7Requires:
8Cflags: -I${includedir}
diff --git a/recipes-ti/ipc/ti-ipc_1.23.02.27.bb b/recipes-ti/ipc/ti-ipc_1.23.02.27.bb
new file mode 100644
index 00000000..2176b136
--- /dev/null
+++ b/recipes-ti/ipc/ti-ipc_1.23.02.27.bb
@@ -0,0 +1,9 @@
1require ti-ipc.inc
2
3LIC_FILES_CHKSUM = "file://ipc_1_23_02_27_manifest.html;md5=74cbdd9a526809df81e080f19b36eec7"
4
5PV = "1_23_02_27"
6
7SRC_URI[ipcbin.md5sum] = "8c45f6a81cef62f9717335911ee1c9cd"
8SRC_URI[ipcbin.sha256sum] = "b16f29ef016819fe0632468e2f756e05508143cbc732bcaabd269571163b568e"
9