summaryrefslogtreecommitdiffstats
path: root/recipes-ti/ipc
diff options
context:
space:
mode:
authorJacob Stiffler <j-stiffler@ti.com>2014-10-08 18:06:20 +0000
committerDenys Dmytriyenko <denys@ti.com>2014-10-08 13:32:57 -0400
commit2f6b82450106f2e1a0042f884dc84f35dfc41e42 (patch)
tree05af2d6ee33499b3f06e4c1c1734c253e1edec82 /recipes-ti/ipc
parent2dce435ff1dc09637d62f59d179fb89c468c0818 (diff)
downloadmeta-ti-2f6b82450106f2e1a0042f884dc84f35dfc41e42.tar.gz
ti-ipc: Upgrade to IPC 3.30.00.09
* Added new recipe for latest IPC * Removed older recipe versions * Latest recipe points to IPC 3.30.00.09 Signed-off-by: Jacob Stiffler <j-stiffler@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-ti/ipc')
-rw-r--r--recipes-ti/ipc/ti-ipc/0002-ipc-Added-installation-prefix-feature-to-products.ma.patch38
-rw-r--r--recipes-ti/ipc/ti-ipc/ipc.pc8
-rw-r--r--recipes-ti/ipc/ti-ipc_1.24.00.16.bb41
-rw-r--r--recipes-ti/ipc/ti-ipc_3.00.00.bb7
-rw-r--r--recipes-ti/ipc/ti-ipc_3.21.00.07.bb4
-rw-r--r--recipes-ti/ipc/ti-ipc_git.bb (renamed from recipes-ti/ipc/ti-ipc.inc)26
6 files changed, 15 insertions, 109 deletions
diff --git a/recipes-ti/ipc/ti-ipc/0002-ipc-Added-installation-prefix-feature-to-products.ma.patch b/recipes-ti/ipc/ti-ipc/0002-ipc-Added-installation-prefix-feature-to-products.ma.patch
deleted file mode 100644
index 58d77c74..00000000
--- a/recipes-ti/ipc/ti-ipc/0002-ipc-Added-installation-prefix-feature-to-products.ma.patch
+++ /dev/null
@@ -1,38 +0,0 @@
1From 26d09063063593aec760151393226b96bc7ab9f8 Mon Sep 17 00:00:00 2001
2From: Mrinmayee Hingolikar <mrinmayee@ti.com>
3Date: Thu, 5 Sep 2013 17:01:15 +0530
4Subject: [PATCH] ipc: Added installation prefix feature to products.mak
5
6Signed-off-by: Mrinmayee Hingolikar <mrinmayee@ti.com>
7---
8 ipc-linux.mak | 1 +
9 products.mak | 1 +
10 2 files changed, 2 insertions(+)
11
12diff --git a/ipc-linux.mak b/ipc-linux.mak
13index 788a5a2..01579e4 100644
14--- a/ipc-linux.mak
15+++ b/ipc-linux.mak
16@@ -38,6 +38,7 @@ include products.mak
17 config:
18 @echo "Configuring Linux Ipc ..."
19 ./configure --host=$(TOOLCHAIN_LONGNAME) \
20+ --prefix=$(PREFIX) \
21 CC=$(TOOLCHAIN_PREFIX)gcc \
22 PLATFORM=$(PLATFORM) \
23 CMEM_INSTALL_DIR=$(CMEM_INSTALL_DIR) \
24diff --git a/products.mak b/products.mak
25index e418d2f..4578a1e 100644
26--- a/products.mak
27+++ b/products.mak
28@@ -55,6 +55,7 @@ PLATFORM ?=
29 TOOLCHAIN_LONGNAME = arm-none-linux-gnueabi
30 TOOLCHAIN_INSTALL_DIR = $(DEPOT)/_your_arm_code_gen_install_
31 TOOLCHAIN_PREFIX = $(TOOLCHAIN_INSTALL_DIR)/bin/$(TOOLCHAIN_LONGNAME)-
32+PREFIX = /usr/local
33
34 # Optional: Path to Linux Kernel - needed to build the MmRpc user libraries
35 # (for devices that support it)
36--
371.7.9.5
38
diff --git a/recipes-ti/ipc/ti-ipc/ipc.pc b/recipes-ti/ipc/ti-ipc/ipc.pc
deleted file mode 100644
index 1a8c52df..00000000
--- a/recipes-ti/ipc/ti-ipc/ipc.pc
+++ /dev/null
@@ -1,8 +0,0 @@
1prefix=/../../ipc_@VERSION@
2includedir=${prefix}/ti/ipc
3
4Name: TI IPC
5Description: TI ARM-DSP IPC (Inter Processor Communication)
6Version: @VERSION@
7Requires:
8Cflags: -I${includedir}
diff --git a/recipes-ti/ipc/ti-ipc_1.24.00.16.bb b/recipes-ti/ipc/ti-ipc_1.24.00.16.bb
deleted file mode 100644
index 420d0f7d..00000000
--- a/recipes-ti/ipc/ti-ipc_1.24.00.16.bb
+++ /dev/null
@@ -1,41 +0,0 @@
1DESCRIPTION = "TI Inter Process Ccommunication (IPC) Mechanisms (for Uni- and Multi- Processor Configurations)"
2HOMEPAGE = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/ipc/index.html"
3SECTION = "devel"
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://ipc_${PV}_manifest.html;md5=573f5a5c0448d28bf8db35f438244d7f"
6
7
8require ../includes/ti-paths.inc
9require ../includes/ti-staging.inc
10require ../includes/ti-eula-unpack.inc
11
12PV = "1_24_00_16"
13
14S = "${WORKDIR}/ipc_${PV}"
15
16SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/ipc/${PV}/exports/ipc_setuplinux_${PV}.bin;name=ipcbin \
17 file://ipc.pc"
18
19DEPENDS = "ti-sysbios ti-cgt6x ti-xdctools"
20
21BINFILE="ipc_setuplinux_${PV}.bin"
22TI_BIN_UNPK_CMDS="Y: q:workdir:Y"
23
24do_configure() {
25 sed -i -e s:@VERSION@:${PV}:g ${WORKDIR}/ipc.pc
26
27 cp ${WORKDIR}/ipc.pc ${S}
28}
29
30do_install() {
31 install -d ${D}${IPC_INSTALL_DIR_RECIPE}
32 cp -pPrf ${S}/* ${D}${IPC_INSTALL_DIR_RECIPE}
33
34 install -d ${D}/${libdir}/pkgconfig
35 install ${S}/ipc.pc ${D}/${libdir}/pkgconfig/
36}
37
38FILES_${PN}-dev = "${libdir}/*"
39
40SRC_URI[ipcbin.md5sum] = "d2f7cc82310d555ca039dcd353bd94c5"
41SRC_URI[ipcbin.sha256sum] = "96df7835e920c7dabcd63d30ec8bc2aea7cd0c6197c9fb9ca0f8a9b681aa5396"
diff --git a/recipes-ti/ipc/ti-ipc_3.00.00.bb b/recipes-ti/ipc/ti-ipc_3.00.00.bb
deleted file mode 100644
index a6922c03..00000000
--- a/recipes-ti/ipc/ti-ipc_3.00.00.bb
+++ /dev/null
@@ -1,7 +0,0 @@
1require ti-ipc.inc
2
3# For this version of IPC the PLATFORM value is lowercase
4PLATFORM_keystone = "tci6638"
5
6# The following commit corresponds to 3.00.04.29
7SRCREV = "12794ea33870b782bffe1fe4398e86e93fb64396"
diff --git a/recipes-ti/ipc/ti-ipc_3.21.00.07.bb b/recipes-ti/ipc/ti-ipc_3.21.00.07.bb
deleted file mode 100644
index 17cdab0e..00000000
--- a/recipes-ti/ipc/ti-ipc_3.21.00.07.bb
+++ /dev/null
@@ -1,4 +0,0 @@
1require ti-ipc.inc
2
3# This commit corresponds to 3.21.00.07
4SRCREV = "c18fece0c9f0dc76361dc1ee11b7ee2417479847"
diff --git a/recipes-ti/ipc/ti-ipc.inc b/recipes-ti/ipc/ti-ipc_git.bb
index 860f55f6..185e58b8 100644
--- a/recipes-ti/ipc/ti-ipc.inc
+++ b/recipes-ti/ipc/ti-ipc_git.bb
@@ -2,11 +2,22 @@ DESCRIPTION = "TI Inter Process Communication (IPC) Mechanisms (for Uni- and Mul
2HOMEPAGE="http://processors.wiki.ti.com/index.php/Category:IPC" 2HOMEPAGE="http://processors.wiki.ti.com/index.php/Category:IPC"
3 3
4LICENSE = "BSD" 4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://${S}/ipc-linux.mak;beginline=1;endline=30;md5=f2518e421e230f06fe6d449718d02edc" 5LIC_FILES_CHKSUM = "file://${S}/ipc-linux.mak;beginline=1;endline=30;md5=abd112f156e5eb9b0f3e202e48747f9a"
6 6
7DEPENDS += "virtual/kernel" 7DEPENDS += "virtual/kernel"
8 8
9PR = "r1" 9PV = "3.30.00.09"
10
11# This is the first version of the 3.30.00.09
12# PR = "r0"
13
14BRANCH = "master"
15SRC_URI = "git://git.ti.com/ipc/ipcdev.git;protocol=git;branch=${BRANCH} \
16 file://tiipclad-daemon.sh \
17 "
18SRCREV = "595bc3e3bbb2e7ec12a8287145d8e3929291e59d"
19
20S = "${WORKDIR}/git"
10 21
11PACKAGE_ARCH = "${MACHINE_ARCH}" 22PACKAGE_ARCH = "${MACHINE_ARCH}"
12 23
@@ -22,20 +33,13 @@ DAEMON_keystone = "lad_tci6638"
22 33
23inherit autotools pkgconfig update-rc.d 34inherit autotools pkgconfig update-rc.d
24 35
25SRC_URI = "git://git.ti.com/ipc/ipcdev.git;protocol=git \
26 file://0002-ipc-Added-installation-prefix-feature-to-products.ma.patch \
27 file://tiipclad-daemon.sh \
28 "
29
30S = "${WORKDIR}/git"
31
32INITSCRIPT_NAME = "tiipclad-daemon.sh" 36INITSCRIPT_NAME = "tiipclad-daemon.sh"
33INITSCRIPT_PARAMS = "defaults 10" 37INITSCRIPT_PARAMS = "defaults 10"
34 38
35EXTRA_OEMAKE += "KERNEL_INSTALL_DIR=${STAGING_KERNEL_DIR} TOOLCHAIN_INSTALL_DIR=${TOOLCHAIN_PATH} TOOLCHAIN_LONGNAME=${TOOLCHAIN_SYS} PLATFORM=${PLATFORM} PREFIX=${prefix}" 39EXTRA_OECONF += "PLATFORM=${PLATFORM} KERNEL_INSTALL_DIR=${STAGING_KERNEL_DIR}"
36 40
37do_configure() { 41do_configure() {
38 oe_runmake -f ${S}/ipc-linux.mak config 42 oe_runconf
39} 43}
40 44
41do_install_append() { 45do_install_append() {