diff options
author | Denys Dmytriyenko <denys@konsulko.com> | 2022-02-22 04:13:08 +0000 |
---|---|---|
committer | Ryan Eatmon <reatmon@ti.com> | 2022-02-22 12:01:31 -0600 |
commit | 53f4cdf2ce35cbb0aaac0891e5f06e8909caecdd (patch) | |
tree | 2d7a22adf169476666eda7d988767506f40f3d20 /recipes-ti/ipc | |
parent | dd558151806beb2ac95356a7a8275498ccddf125 (diff) | |
download | meta-ti-53f4cdf2ce35cbb0aaac0891e5f06e8909caecdd.tar.gz |
classes,recipes: remove K1/2 PDK RTOS support, FWs and IPC transports
Remove deprecated support for compiling Keystone1/2 RTOS components and
Linux firmwares using PDK, CSL, etc.
Signed-off-by: Denys Dmytriyenko <denys@konsulko.com>
Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'recipes-ti/ipc')
-rw-r--r-- | recipes-ti/ipc/ipc-transport-common-rtos_git.bb | 23 | ||||
-rw-r--r-- | recipes-ti/ipc/ipc-transport-qmss-rtos_git.bb | 23 | ||||
-rw-r--r-- | recipes-ti/ipc/ipc-transport-qmss-test_git.bb | 37 | ||||
-rw-r--r-- | recipes-ti/ipc/ipc-transport-qmss.inc | 14 | ||||
-rw-r--r-- | recipes-ti/ipc/ipc-transport-qmss_git.bb | 19 | ||||
-rw-r--r-- | recipes-ti/ipc/ipc-transport-srio-rtos_git.bb | 22 | ||||
-rw-r--r-- | recipes-ti/ipc/ipc-transport-srio-test_git.bb | 32 | ||||
-rw-r--r-- | recipes-ti/ipc/ipc-transport-srio.inc | 14 | ||||
-rw-r--r-- | recipes-ti/ipc/ipc-transport-srio_git.bb | 19 | ||||
-rw-r--r-- | recipes-ti/ipc/ipc-transport.inc | 15 |
10 files changed, 0 insertions, 218 deletions
diff --git a/recipes-ti/ipc/ipc-transport-common-rtos_git.bb b/recipes-ti/ipc/ipc-transport-common-rtos_git.bb deleted file mode 100644 index ade78022..00000000 --- a/recipes-ti/ipc/ipc-transport-common-rtos_git.bb +++ /dev/null | |||
@@ -1,23 +0,0 @@ | |||
1 | require recipes-ti/includes/ti-paths.inc | ||
2 | require ipc-transport.inc | ||
3 | |||
4 | PR = "${INC_PR}.1" | ||
5 | |||
6 | LIC_FILES_CHKSUM = "file://common_src/bench_common.h;beginline=1;endline=31;md5=a6ddfb26d2097041d513e3881f40e4e8" | ||
7 | |||
8 | COMPATIBLE_MACHINE = "k2hk|k2l|k2e" | ||
9 | |||
10 | IPC_TRANSPORT_COMMON_DESTSUFFIX = "git/c66/example" | ||
11 | |||
12 | S = "${WORKDIR}/${IPC_TRANSPORT_COMMON_DESTSUFFIX}" | ||
13 | |||
14 | do_compile() { | ||
15 | : | ||
16 | } | ||
17 | |||
18 | do_install () { | ||
19 | install -d ${D}${PDK_INSTALL_DIR_RECIPE}/packages/ti/transport/ipc/c66/example | ||
20 | cp -r ${S} ${D}${PDK_INSTALL_DIR_RECIPE}/packages/ti/transport/ipc/c66 | ||
21 | } | ||
22 | |||
23 | FILES:${PN} += "${PDK_INSTALL_DIR_RECIPE}/packages/ti/transport/ipc/c66/example/*" | ||
diff --git a/recipes-ti/ipc/ipc-transport-qmss-rtos_git.bb b/recipes-ti/ipc/ipc-transport-qmss-rtos_git.bb deleted file mode 100644 index 2dffc11e..00000000 --- a/recipes-ti/ipc/ipc-transport-qmss-rtos_git.bb +++ /dev/null | |||
@@ -1,23 +0,0 @@ | |||
1 | inherit ti-pdk | ||
2 | require ipc-transport.inc | ||
3 | |||
4 | PR = "${INC_PR}.4" | ||
5 | |||
6 | LIC_FILES_CHKSUM = "file://TransportQmss.xdc;beginline=1;endline=35;md5=ad783760d74a4cc5b8d4ad3d8a1f28a2" | ||
7 | |||
8 | COMPATIBLE_MACHINE = "k2hk|k2l|k2e" | ||
9 | |||
10 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
11 | |||
12 | DEPENDS:append = " qmss-lld-rtos \ | ||
13 | cppi-lld-rtos \ | ||
14 | ti-ipc-rtos \ | ||
15 | ipc-transport-common-rtos \ | ||
16 | " | ||
17 | |||
18 | IPC_TRANSPORT_QMSS_DESTSUFFIX = "git/c66/qmss" | ||
19 | |||
20 | S = "${WORKDIR}/${IPC_TRANSPORT_QMSS_DESTSUFFIX}" | ||
21 | |||
22 | export IPC_INSTALL_PATH = "${IPC_INSTALL_DIR}" | ||
23 | XDCPATH:append = ";${IPC_INSTALL_DIR}/packages" | ||
diff --git a/recipes-ti/ipc/ipc-transport-qmss-test_git.bb b/recipes-ti/ipc/ipc-transport-qmss-test_git.bb deleted file mode 100644 index 158d1856..00000000 --- a/recipes-ti/ipc/ipc-transport-qmss-test_git.bb +++ /dev/null | |||
@@ -1,37 +0,0 @@ | |||
1 | include ipc-transport-qmss.inc | ||
2 | |||
3 | PR = "${INC_PR}.0" | ||
4 | |||
5 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
6 | |||
7 | DEPENDS = "ipc-transport-qmss ti-ipc" | ||
8 | |||
9 | #FILES_${PN}-test = "${bindir}/multiProcessTest_*.out" | ||
10 | |||
11 | CHOICELIST = "yes no" | ||
12 | |||
13 | DEVICELIST:k2hk = "k2h k2k" | ||
14 | DEVICELIST:k2e = "k2e" | ||
15 | DEVICELIST:k2l = "k2l" | ||
16 | |||
17 | do_compile () { | ||
18 | # Now build the test code | ||
19 | for device in ${DEVICELIST} | ||
20 | do | ||
21 | for choice in ${CHOICELIST} | ||
22 | do | ||
23 | oe_runmake tests \ | ||
24 | IPC_DEVKIT_INSTALL_PATH=${STAGING_INCDIR} \ | ||
25 | USEDYNAMIC_LIB="$choice" DEVICE="$device" | ||
26 | done | ||
27 | done | ||
28 | } | ||
29 | |||
30 | do_install () { | ||
31 | for device in ${DEVICELIST} | ||
32 | do | ||
33 | oe_runmake installbin \ | ||
34 | INSTALL_BIN_BASE_DIR=${D}${bindir} DEVICE="$device" | ||
35 | done | ||
36 | |||
37 | } | ||
diff --git a/recipes-ti/ipc/ipc-transport-qmss.inc b/recipes-ti/ipc/ipc-transport-qmss.inc deleted file mode 100644 index 04705269..00000000 --- a/recipes-ti/ipc/ipc-transport-qmss.inc +++ /dev/null | |||
@@ -1,14 +0,0 @@ | |||
1 | DESCRIPTION = "TI QMSS-Based IPC MessageQ Transport" | ||
2 | LICENSE = "BSD-3-Clause" | ||
3 | |||
4 | require ipc-transport.inc | ||
5 | |||
6 | INC_PR:append = ".1" | ||
7 | |||
8 | LIC_FILES_CHKSUM = "file://COPYING.txt;md5=27bb0deb260c60120a8d7b91da7c3b02" | ||
9 | |||
10 | COMPATIBLE_MACHINE = "keystone" | ||
11 | |||
12 | S = "${WORKDIR}/git/linux/qmss" | ||
13 | |||
14 | EXTRA_OEMAKE += "PDK_INSTALL_PATH=${STAGING_INCDIR} TRANS_QMSS_SRC_DIR=${S}" | ||
diff --git a/recipes-ti/ipc/ipc-transport-qmss_git.bb b/recipes-ti/ipc/ipc-transport-qmss_git.bb deleted file mode 100644 index 93136670..00000000 --- a/recipes-ti/ipc/ipc-transport-qmss_git.bb +++ /dev/null | |||
@@ -1,19 +0,0 @@ | |||
1 | include ipc-transport-qmss.inc | ||
2 | |||
3 | PR = "${INC_PR}.0" | ||
4 | |||
5 | DEPENDS = "ti-ipc mpm-transport" | ||
6 | |||
7 | do_compile () { | ||
8 | # Now build the transport | ||
9 | oe_runmake clean | ||
10 | oe_runmake lib | ||
11 | } | ||
12 | |||
13 | do_install () { | ||
14 | oe_runmake install INSTALL_INC_BASE_DIR=${D}${includedir} \ | ||
15 | INSTALL_LIB_BASE_DIR=${D}${libdir} | ||
16 | chown -R root:root ${D} | ||
17 | } | ||
18 | |||
19 | INHIBIT_PACKAGE_STRIP_FILES = "${PKGD}${libdir}/libTransportQmss.a" | ||
diff --git a/recipes-ti/ipc/ipc-transport-srio-rtos_git.bb b/recipes-ti/ipc/ipc-transport-srio-rtos_git.bb deleted file mode 100644 index 52720916..00000000 --- a/recipes-ti/ipc/ipc-transport-srio-rtos_git.bb +++ /dev/null | |||
@@ -1,22 +0,0 @@ | |||
1 | inherit ti-pdk | ||
2 | require ipc-transport.inc | ||
3 | |||
4 | PR = "${INC_PR}.2" | ||
5 | |||
6 | LIC_FILES_CHKSUM = "file://TransportSrio.xdc;beginline=1;endline=35;md5=4d466471e4b933a0cc353a46bb546fe7" | ||
7 | |||
8 | COMPATIBLE_MACHINE = "k2hk" | ||
9 | |||
10 | DEPENDS:append = " qmss-lld-rtos \ | ||
11 | cppi-lld-rtos \ | ||
12 | srio-lld-rtos \ | ||
13 | ti-ipc-rtos \ | ||
14 | ipc-transport-common-rtos \ | ||
15 | " | ||
16 | |||
17 | IPC_TRANSPORT_SRIO_DESTSUFFIX = "git/c66/srio" | ||
18 | |||
19 | S = "${WORKDIR}/${IPC_TRANSPORT_SRIO_DESTSUFFIX}" | ||
20 | |||
21 | export IPC_INSTALL_PATH = "${IPC_INSTALL_DIR}" | ||
22 | XDCPATH:append = ";${IPC_INSTALL_DIR}/packages" | ||
diff --git a/recipes-ti/ipc/ipc-transport-srio-test_git.bb b/recipes-ti/ipc/ipc-transport-srio-test_git.bb deleted file mode 100644 index 4e23fb21..00000000 --- a/recipes-ti/ipc/ipc-transport-srio-test_git.bb +++ /dev/null | |||
@@ -1,32 +0,0 @@ | |||
1 | include ipc-transport-srio.inc | ||
2 | |||
3 | PR = "${INC_PR}.0" | ||
4 | |||
5 | DEPENDS = "ipc-transport-srio ipc-transport-qmss ti-ipc" | ||
6 | |||
7 | DEVICELIST = "k2h k2k" | ||
8 | |||
9 | CHOICELIST = "yes no" | ||
10 | |||
11 | do_compile () { | ||
12 | # Now build the test code | ||
13 | for device in ${DEVICELIST} | ||
14 | do | ||
15 | for choice in ${CHOICELIST} | ||
16 | do | ||
17 | oe_runmake tests \ | ||
18 | IPC_DEVKIT_INSTALL_PATH=${STAGING_INCDIR} \ | ||
19 | USEDYNAMIC_LIB="$choice" DEVICE="$device" | ||
20 | done | ||
21 | done | ||
22 | } | ||
23 | |||
24 | do_install () { | ||
25 | |||
26 | for device in ${DEVICELIST} | ||
27 | do | ||
28 | oe_runmake installbin \ | ||
29 | INSTALL_BIN_BASE_DIR=${D}${bindir} DEVICE="$device" | ||
30 | done | ||
31 | |||
32 | } | ||
diff --git a/recipes-ti/ipc/ipc-transport-srio.inc b/recipes-ti/ipc/ipc-transport-srio.inc deleted file mode 100644 index 89425703..00000000 --- a/recipes-ti/ipc/ipc-transport-srio.inc +++ /dev/null | |||
@@ -1,14 +0,0 @@ | |||
1 | DESCRIPTION = "TI SRIO-Based IPC MessageQ Transport" | ||
2 | LICENSE = "BSD-3-Clause" | ||
3 | |||
4 | require ipc-transport.inc | ||
5 | |||
6 | INC_PR:append = ".1" | ||
7 | |||
8 | LIC_FILES_CHKSUM = "file://COPYING.txt;md5=27bb0deb260c60120a8d7b91da7c3b02" | ||
9 | |||
10 | COMPATIBLE_MACHINE = "k2hk" | ||
11 | |||
12 | S = "${WORKDIR}/git/linux/srio" | ||
13 | |||
14 | EXTRA_OEMAKE += "PDK_INSTALL_PATH=${STAGING_INCDIR} TRANS_SRIO_SRC_DIR=${S}" | ||
diff --git a/recipes-ti/ipc/ipc-transport-srio_git.bb b/recipes-ti/ipc/ipc-transport-srio_git.bb deleted file mode 100644 index 6001585a..00000000 --- a/recipes-ti/ipc/ipc-transport-srio_git.bb +++ /dev/null | |||
@@ -1,19 +0,0 @@ | |||
1 | include ipc-transport-srio.inc | ||
2 | |||
3 | PR = "${INC_PR}.0" | ||
4 | |||
5 | DEPENDS = "ti-ipc mpm-transport" | ||
6 | |||
7 | do_compile () { | ||
8 | # Now build the transport | ||
9 | oe_runmake clean | ||
10 | oe_runmake lib | ||
11 | } | ||
12 | |||
13 | do_install () { | ||
14 | oe_runmake install INSTALL_INC_BASE_DIR=${D}${includedir} \ | ||
15 | INSTALL_LIB_BASE_DIR=${D}${libdir} | ||
16 | chown -R root:root ${D} | ||
17 | } | ||
18 | |||
19 | INHIBIT_PACKAGE_STRIP_FILES = "${PKGD}${libdir}/libTransportSrio.a" | ||
diff --git a/recipes-ti/ipc/ipc-transport.inc b/recipes-ti/ipc/ipc-transport.inc deleted file mode 100644 index 0c1edef1..00000000 --- a/recipes-ti/ipc/ipc-transport.inc +++ /dev/null | |||
@@ -1,15 +0,0 @@ | |||
1 | LICENSE = "BSD-3-Clause" | ||
2 | |||
3 | IPC_TRANSPORT_GIT_URI = "git://git.ti.com/keystone-linux/ipc-transport.git" | ||
4 | IPC_TRANSPORT_GIT_PROTOCOL = "git" | ||
5 | IPC_TRANSPORT_GIT_BRANCH = "master" | ||
6 | |||
7 | # Below commit ID corresponds to "DEV.IPC-TRANSPORT.02.00.00.02A" | ||
8 | IPC_TRANSPORT_SRCREV = "f75e2e29b9b1b63443a0c82493e41dd2f771c6f5" | ||
9 | |||
10 | BRANCH = "${IPC_TRANSPORT_GIT_BRANCH}" | ||
11 | SRC_URI = "${IPC_TRANSPORT_GIT_URI};protocol=${IPC_TRANSPORT_GIT_PROTOCOL};branch=${BRANCH}" | ||
12 | |||
13 | SRCREV = "${IPC_TRANSPORT_SRCREV}" | ||
14 | PV = "02.00.00.02A" | ||
15 | INC_PR = "r0" | ||