diff options
author | Sam Nelson <sam.nelson@ti.com> | 2014-02-12 05:41:49 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2014-03-04 23:40:36 -0500 |
commit | d2c9c3b981fc900b0e78fb98ff45d0fa7661910e (patch) | |
tree | c0854d6544760065888c54f0d741a7d64e6c1c3e /recipes-ti/ipc | |
parent | 3b596055fe6f5e6c7d4e885e114c121f1ecd0c42 (diff) | |
download | meta-ti-d2c9c3b981fc900b0e78fb98ff45d0fa7661910e.tar.gz |
ti-ipc: Add recipe for ti-ipc version 3.0.x
- Supports communication between processors in TI keystone architecture
Signed-off-by: Sam Nelson <sam.nelson@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-ti/ipc')
-rwxr-xr-x | recipes-ti/ipc/files/tiipclad-daemon.sh | 24 | ||||
-rw-r--r-- | recipes-ti/ipc/ti-ipc_3.00.00.bb | 52 |
2 files changed, 76 insertions, 0 deletions
diff --git a/recipes-ti/ipc/files/tiipclad-daemon.sh b/recipes-ti/ipc/files/tiipclad-daemon.sh new file mode 100755 index 00000000..54b38882 --- /dev/null +++ b/recipes-ti/ipc/files/tiipclad-daemon.sh | |||
@@ -0,0 +1,24 @@ | |||
1 | #! /bin/sh | ||
2 | |||
3 | tiipclad_daemon=/usr/bin/lad_tci6638 | ||
4 | tiipclad_params=lad.txt | ||
5 | |||
6 | test -x "$tiipclad_daemon" || exit 0 | ||
7 | |||
8 | case "$1" in | ||
9 | start) | ||
10 | echo -n "Starting tiipclad daemon" | ||
11 | start-stop-daemon --start --quiet --exec $tiipclad_daemon $tiipclad_params | ||
12 | echo "." | ||
13 | ;; | ||
14 | stop) | ||
15 | echo -n "Stopping tiipclad daemon" | ||
16 | start-stop-daemon --stop --quiet --pidfile /var/run/tiipclad.pid | ||
17 | echo "." | ||
18 | ;; | ||
19 | *) | ||
20 | echo "Usage: /etc/init.d/tiipclad-daemon.sh {start|stop}" | ||
21 | exit 1 | ||
22 | esac | ||
23 | |||
24 | exit 0 | ||
diff --git a/recipes-ti/ipc/ti-ipc_3.00.00.bb b/recipes-ti/ipc/ti-ipc_3.00.00.bb new file mode 100644 index 00000000..c07b7f9b --- /dev/null +++ b/recipes-ti/ipc/ti-ipc_3.00.00.bb | |||
@@ -0,0 +1,52 @@ | |||
1 | DESCRIPTION="This support the communication between processors \ | ||
2 | in a multi-processor environment and communication to peripherals. \ | ||
3 | This communication includes message passing, streams, and linked lists. \ | ||
4 | These modules work transparently in both uni-processor and multi-processor \ | ||
5 | configurations." | ||
6 | |||
7 | HOMEPAGE="http://processors.wiki.ti.com/index.php/Category:IPC" | ||
8 | |||
9 | LICENSE = "BSD" | ||
10 | LIC_FILES_CHKSUM = "file://products.mak;beginline=2;endline=30;md5=195feadf798bb4165bcb1a23ffd50dbb" | ||
11 | SECTION = "console" | ||
12 | COMPATIBLE_MACHINE = "keystone" | ||
13 | TARGET_PLATFORM = "tci6638" | ||
14 | |||
15 | PR = "r0" | ||
16 | |||
17 | BRANCH ?= "master" | ||
18 | # The following commit corresponds to 3.00.04.29 | ||
19 | SRCREV = "12794ea33870b782bffe1fe4398e86e93fb64396" | ||
20 | |||
21 | SRC_URI = " \ | ||
22 | git://git.ti.com/ipc/ipcdev.git;protocol=git;branch=${BRANCH} \ | ||
23 | file://tiipclad-daemon.sh" | ||
24 | |||
25 | S = "${WORKDIR}/git" | ||
26 | |||
27 | export PLATFORM = "${TARGET_PLATFORM}" | ||
28 | |||
29 | export PARALLEL_MAKE = "" | ||
30 | |||
31 | PACKAGES =+ "${PN}-test" | ||
32 | |||
33 | FILES_${PN}-test = " \ | ||
34 | ${bindir}/NameServerApp \ | ||
35 | ${bindir}/MessageQApp \ | ||
36 | ${bindir}/MessageQMulti \ | ||
37 | ${bindir}/ping_rpmsg" | ||
38 | |||
39 | DEPENDS += "virtual/kernel" | ||
40 | |||
41 | EXTRA_OECONF += "KERNEL_INSTALL_DIR=${STAGING_KERNEL_DIR}" | ||
42 | inherit autotools | ||
43 | |||
44 | INITSCRIPT_NAME = "tiipclad-daemon.sh" | ||
45 | INITSCRIPT_PARAMS = "defaults 10" | ||
46 | |||
47 | inherit update-rc.d | ||
48 | |||
49 | do_install_append() { | ||
50 | install -d ${D}${sysconfdir}/init.d/ | ||
51 | install -c -m 755 ${WORKDIR}/tiipclad-daemon.sh ${D}${sysconfdir}/init.d/${INITSCRIPT_NAME} | ||
52 | } | ||