summaryrefslogtreecommitdiffstats
path: root/recipes-ti/ipc/ti-ipc-rtos_git.bb
diff options
context:
space:
mode:
authorSam Nelson <sam.nelson@ti.com>2016-11-29 20:28:10 +0000
committerDenys Dmytriyenko <denys@ti.com>2016-12-06 19:39:26 -0500
commit16bf3379a3428b93e7bf4282b9175f40c4509f21 (patch)
tree68a9d8a84dca3cc3e945611d9979fab7929b8461 /recipes-ti/ipc/ti-ipc-rtos_git.bb
parentf7719a0e1dbb0c3f6ad226338ecd3ccbc876cdd9 (diff)
downloadmeta-ti-16bf3379a3428b93e7bf4282b9175f40c4509f21.tar.gz
ti-ipc: Reorganised recipes to help in adding ipc examples recipes
Created ti-ipc-common.inc & ti-ipc-rtos.inc to gather common definitions Updated commmit ids for ipc-examples Update ti-ipc-rtos to add ALT_PLATFORM examples Signed-off-by: Sam Nelson <sam.nelson@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-ti/ipc/ti-ipc-rtos_git.bb')
-rw-r--r--recipes-ti/ipc/ti-ipc-rtos_git.bb72
1 files changed, 7 insertions, 65 deletions
diff --git a/recipes-ti/ipc/ti-ipc-rtos_git.bb b/recipes-ti/ipc/ti-ipc-rtos_git.bb
index 5b0bed59..693a4e9c 100644
--- a/recipes-ti/ipc/ti-ipc-rtos_git.bb
+++ b/recipes-ti/ipc/ti-ipc-rtos_git.bb
@@ -1,50 +1,8 @@
1require recipes-ti/includes/ti-paths.inc
2require recipes-ti/includes/ti-staging.inc
3require ti-ipc.inc 1require ti-ipc.inc
4 2require ti-ipc-common.inc
5TI_IPC_EXAMPLES_GIT_URI = "git://git.ti.com/ipc/ipc-examples.git" 3require ti-ipc-rtos.inc
6TI_IPC_EXAMPLES_DEST_SUFFIX = "git/ipc-examples"
7TI_IPC_EXAMPLES_GIT_PROTOCOL = "git"
8TI_IPC_EXAMPLES_GIT_BRANCH = "master"
9TI_IPC_EXAMPLES_NAME = "ipc-examples"
10
11SRC_URI += "${TI_IPC_EXAMPLES_GIT_URI};\
12destsuffix=${TI_IPC_EXAMPLES_DEST_SUFFIX};\
13protocol=${TI_IPC_EXAMPLES_GIT_PROTOCOL};\
14branch=${TI_IPC_EXAMPLES_GIT_BRANCH};\
15name=${TI_IPC_EXAMPLES_NAME}"
16
17TI_IPC_METADATA_GIT_URI = "git://git.ti.com/ipc/ipc-metadata.git"
18TI_IPC_METADATA_DEST_SUFFIX = "git/ipc-metadata"
19TI_IPC_METADATA_GIT_PROTOCOL = "git"
20TI_IPC_METADATA_GIT_BRANCH = "master"
21TI_IPC_METADATA_NAME = "ipc-metadata"
22
23SRC_URI += "${TI_IPC_METADATA_GIT_URI};\
24destsuffix=${TI_IPC_METADATA_DEST_SUFFIX};\
25protocol=${TI_IPC_METADATA_GIT_PROTOCOL};\
26branch=${TI_IPC_METADATA_GIT_BRANCH};\
27name=${TI_IPC_METADATA_NAME}"
28
29# Corresponds to tag: 3.44.00.00
30SRCREV_ipc-examples = "a934d057647af00401e4bfd1c6a4a0f6144441b7"
31
32# Corresponds to tag: 3.44.00.00
33SRCREV_ipc-metadata = "07a745d47ecd7b4b64860e7c5d0fbe4e89524f2e"
34
35S_ipc-examples = "${WORKDIR}/git/ipc-examples"
36S_ipc-metadata = "${WORKDIR}/git/ipc-metadata"
37
38PR = "${INC_PR}.3"
39 4
40DEPENDS = "ti-xdctools ti-sysbios doxygen-native zip-native" 5DEPENDS = "ti-xdctools ti-sysbios doxygen-native zip-native"
41DEPENDS_append_keystone = " ti-cgt6x-native \
42 gcc-arm-none-eabi-native \
43"
44DEPENDS_append_omap-a15 = " ti-cgt6x-native \
45 ti-ccsv6-native \
46 gcc-arm-none-eabi-native \
47"
48 6
49PACKAGES =+ "${PN}-fw" 7PACKAGES =+ "${PN}-fw"
50FILES_${PN}-fw = "${base_libdir}/firmware/*" 8FILES_${PN}-fw = "${base_libdir}/firmware/*"
@@ -55,27 +13,6 @@ INSANE_SKIP_${PN}-dev += "arch"
55 13
56ALLOW_EMPTY_${PN} = "1" 14ALLOW_EMPTY_${PN} = "1"
57 15
58IPC_TARGETS = ""
59IPC_TARGETS_omap-a15 = "\
60 gnu.targets.arm.A15F="${GCC_ARM_NONE_TOOLCHAIN}" \
61 ti.targets.elf.C66="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" \
62 ti.targets.elf.C66_big_endian="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" \
63 ti.targets.arm.elf.M4="${M4_TOOLCHAIN_INSTALL_DIR}" \
64"
65
66IPC_TARGETS_keystone = " \
67 gnu.targets.arm.A15F="${GCC_ARM_NONE_TOOLCHAIN}" \
68 ti.targets.elf.C66="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" \
69 ti.targets.elf.C66_big_endian="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" \
70"
71
72EXTRA_OEMAKE = "\
73 PLATFORM=${PLATFORM} \
74 XDC_INSTALL_DIR="${XDC_INSTALL_DIR}" \
75 BIOS_INSTALL_DIR="${SYSBIOS_INSTALL_DIR}" \
76 ${IPC_TARGETS} \
77"
78
79RELEASE_TYPE = "GA" 16RELEASE_TYPE = "GA"
80RELEASE_SUFFIX = "" 17RELEASE_SUFFIX = ""
81 18
@@ -93,6 +30,11 @@ do_compile() {
93 cd ${S_ipc-examples}/src 30 cd ${S_ipc-examples}/src
94 oe_runmake .examples \ 31 oe_runmake .examples \
95 IPCTOOLS="${S_ipc-metadata}/src/etc" 32 IPCTOOLS="${S_ipc-metadata}/src/etc"
33 if [ ! -z ${ALT_PLATFORM} ]; then
34 oe_runmake .examples \
35 IPCTOOLS="${S_ipc-metadata}/src/etc" \
36 PLATFORM=${ALT_PLATFORM}
37 fi
96 38
97 if [ "${PLATFORM}" != "UNKNOWN" ]; then 39 if [ "${PLATFORM}" != "UNKNOWN" ]; then
98 oe_runmake extract HOSTOS="bios" IPC_INSTALL_DIR="${S}" 40 oe_runmake extract HOSTOS="bios" IPC_INSTALL_DIR="${S}"