summaryrefslogtreecommitdiffstats
path: root/recipes-ti/ipc/ti-ipc-rtos_git.bb
diff options
context:
space:
mode:
authorAngela Stegmaier <angelabaker@ti.com>2020-05-07 02:04:13 +0000
committerDenys Dmytriyenko <denys@ti.com>2020-05-07 01:16:02 +0000
commitc7ce199950713cf3551265f1f1197d634ea7b3fc (patch)
treee34546726143ff4c9566c97ecf60a532efe178fc /recipes-ti/ipc/ti-ipc-rtos_git.bb
parent29b8f2d7ce17b085237535a9fbcb02817d065a51 (diff)
downloadmeta-ti-c7ce199950713cf3551265f1f1197d634ea7b3fc.tar.gz
ti-ipc: remove am65xx build
Only ipc-lld is supported for am65xx. Signed-off-by: Angela Stegmaier <angelabaker@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-ti/ipc/ti-ipc-rtos_git.bb')
-rw-r--r--recipes-ti/ipc/ti-ipc-rtos_git.bb17
1 files changed, 0 insertions, 17 deletions
diff --git a/recipes-ti/ipc/ti-ipc-rtos_git.bb b/recipes-ti/ipc/ti-ipc-rtos_git.bb
index 4c0e71e6..b292d677 100644
--- a/recipes-ti/ipc/ti-ipc-rtos_git.bb
+++ b/recipes-ti/ipc/ti-ipc-rtos_git.bb
@@ -3,7 +3,6 @@ require ti-ipc-common.inc
3require ti-ipc-rtos.inc 3require ti-ipc-rtos.inc
4 4
5DEPENDS = "ti-xdctools-native ti-sysbios doxygen-native zip-native" 5DEPENDS = "ti-xdctools-native ti-sysbios doxygen-native zip-native"
6DEPENDS_append_am65xx = " sciclient-rtos"
7 6
8PACKAGES =+ "${PN}-fw" 7PACKAGES =+ "${PN}-fw"
9FILES_${PN}-fw = "${base_libdir}/firmware/*" 8FILES_${PN}-fw = "${base_libdir}/firmware/*"
@@ -62,12 +61,6 @@ do_compile() {
62 fi 61 fi
63} 62}
64 63
65do_install_prepend_am65xx () {
66 # Trim directory name
67 mv ${S}/packages/ti/ipc/tests/bin/ti_platforms_cortexR_AM65X_false_R5F0 ${S}/packages/ti/ipc/tests/bin/ti_platforms_cortexR_AM65X_R5F0
68 mv ${S}/packages/ti/ipc/tests/bin/ti_platforms_cortexR_AM65X_false_R5F1 ${S}/packages/ti/ipc/tests/bin/ti_platforms_cortexR_AM65X_R5F1
69}
70
71do_install() { 64do_install() {
72 CP_ARGS="-Prf --preserve=mode,timestamps --no-preserve=ownership" 65 CP_ARGS="-Prf --preserve=mode,timestamps --no-preserve=ownership"
73 IPC_VERSION=`echo ${PV}${RELEASE_SUFFIX} | sed -e 's|\.|_|g'` 66 IPC_VERSION=`echo ${PV}${RELEASE_SUFFIX} | sed -e 's|\.|_|g'`
@@ -129,13 +122,3 @@ pkg_postinst_${PN}-fw_omapl138 () {
129pkg_postrm_${PN}-fw_omapl138 () { 122pkg_postrm_${PN}-fw_omapl138 () {
130 update-alternatives --remove rproc-dsp-fw ipc/ti_platforms_evmOMAPL138_DSP/messageq_single.xe674 123 update-alternatives --remove rproc-dsp-fw ipc/ti_platforms_evmOMAPL138_DSP/messageq_single.xe674
131} 124}
132
133pkg_postinst_${PN}-fw_am65xx () {
134 update-alternatives --install /lib/firmware/am65x-mcu-r5f0_0-fw am65x-mcu-r5f0_0-fw ipc/ti_platforms_cortexR_AM65X_R5F0/messageq_single.xer5f ${ALTERNATIVE_PRIORITY}
135 update-alternatives --install /lib/firmware/am65x-mcu-r5f0_1-fw am65x-mcu-r5f0_1-fw ipc/ti_platforms_cortexR_AM65X_R5F1/messageq_single.xer5f ${ALTERNATIVE_PRIORITY}
136}
137
138pkg_postrm_${PN}-fw_am65xx () {
139 update-alternatives --remove am65x-mcu-r5f0_0-fw ipc/ti_platforms_cortexR_AM65X_R5F0/messageq_single.xer5f
140 update-alternatives --remove am65x-mcu-r5f0_1-fw ipc/ti_platforms_cortexR_AM65X_R5F1/messageq_single.xer5f
141}