summaryrefslogtreecommitdiffstats
path: root/recipes-ti/ipc/ti-ipc-rtos_git.bb
diff options
context:
space:
mode:
authorSam Nelson <sam.nelson@ti.com>2018-05-17 23:04:44 +0000
committerDenys Dmytriyenko <denys@ti.com>2018-06-01 18:29:37 +0000
commitdd8400c12149163576723a4778e11ebd01a89b37 (patch)
treee0d5e6ebf3c6868e8a11d88e84dbadc6b59152fe /recipes-ti/ipc/ti-ipc-rtos_git.bb
parent12e2064557ac7b97ed60217ad1b0f768d1ad64f1 (diff)
downloadmeta-ti-dd8400c12149163576723a4778e11ebd01a89b37.tar.gz
ti-ipc: Update to new version 3.47.02.00
Adds new example for AM571X Signed-off-by: Sam Nelson <sam.nelson@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-ti/ipc/ti-ipc-rtos_git.bb')
-rw-r--r--recipes-ti/ipc/ti-ipc-rtos_git.bb20
1 files changed, 10 insertions, 10 deletions
diff --git a/recipes-ti/ipc/ti-ipc-rtos_git.bb b/recipes-ti/ipc/ti-ipc-rtos_git.bb
index 53ab76da..b292d677 100644
--- a/recipes-ti/ipc/ti-ipc-rtos_git.bb
+++ b/recipes-ti/ipc/ti-ipc-rtos_git.bb
@@ -27,20 +27,20 @@ do_compile() {
27 cd ${S_ipc-examples}/src 27 cd ${S_ipc-examples}/src
28 oe_runmake .examples \ 28 oe_runmake .examples \
29 IPCTOOLS="${S_ipc-metadata}/src/etc" 29 IPCTOOLS="${S_ipc-metadata}/src/etc"
30 if [ ! -z ${ALT_PLATFORM} ]; then 30 for alt_platform in ${ALT_PLATFORM}; do
31 oe_runmake .examples \ 31 oe_runmake .examples \
32 IPCTOOLS="${S_ipc-metadata}/src/etc" \ 32 IPCTOOLS="${S_ipc-metadata}/src/etc" \
33 PLATFORM=${ALT_PLATFORM} 33 PLATFORM=${alt_platform}
34 fi 34 done
35 35
36 if [ "${PLATFORM}" != "UNKNOWN" ]; then 36 if [ "${PLATFORM}" != "UNKNOWN" ]; then
37 oe_runmake extract HOSTOS="bios" IPC_INSTALL_DIR="${S}" 37 oe_runmake extract HOSTOS="bios" IPC_INSTALL_DIR="${S}"
38 oe_runmake extract HOSTOS="linux" IPC_INSTALL_DIR="${S}" 38 oe_runmake extract HOSTOS="linux" IPC_INSTALL_DIR="${S}"
39 39
40 if [ ! -z ${ALT_PLATFORM} ]; then 40 for alt_platform in ${ALT_PLATFORM}; do
41 oe_runmake extract PLATFORM=${ALT_PLATFORM} HOSTOS="bios" IPC_INSTALL_DIR="${S}" 41 oe_runmake extract PLATFORM=${alt_platform} HOSTOS="bios" IPC_INSTALL_DIR="${S}"
42 oe_runmake extract PLATFORM=${ALT_PLATFORM} HOSTOS="linux" IPC_INSTALL_DIR="${S}" 42 oe_runmake extract PLATFORM=${alt_platform} HOSTOS="linux" IPC_INSTALL_DIR="${S}"
43 fi 43 done
44 fi 44 fi
45 45
46 IPC_VERSION=`echo ${PV}${RELEASE_SUFFIX} | sed -e 's|\.|_|g'` 46 IPC_VERSION=`echo ${PV}${RELEASE_SUFFIX} | sed -e 's|\.|_|g'`
@@ -54,9 +54,9 @@ do_compile() {
54 cp -pPf ${S_ipc-examples}/src/examples/*.* ${IPC_PACKAGE_DIR}/examples/ 54 cp -pPf ${S_ipc-examples}/src/examples/*.* ${IPC_PACKAGE_DIR}/examples/
55 cp -pPf ${S_ipc-examples}/src/examples/makefile ${IPC_PACKAGE_DIR}/examples/ 55 cp -pPf ${S_ipc-examples}/src/examples/makefile ${IPC_PACKAGE_DIR}/examples/
56 cp -pPrf ${S_ipc-examples}/src/examples/${PLATFORM}* ${IPC_PACKAGE_DIR}/examples/ 56 cp -pPrf ${S_ipc-examples}/src/examples/${PLATFORM}* ${IPC_PACKAGE_DIR}/examples/
57 if [ ! -z ${ALT_PLATFORM} ]; then 57 for alt_platform in ${ALT_PLATFORM}; do
58 cp -pPrf ${S_ipc-examples}/src/examples/${ALT_PLATFORM}* ${IPC_PACKAGE_DIR}/examples/ 58 cp -pPrf ${S_ipc-examples}/src/examples/${alt_platform}* ${IPC_PACKAGE_DIR}/examples/
59 fi 59 done
60 find ${IPC_PACKAGE_DIR}/examples/ -name "*zip" -type f | xargs -I {} rm {} 60 find ${IPC_PACKAGE_DIR}/examples/ -name "*zip" -type f | xargs -I {} rm {}
61 fi 61 fi
62} 62}