summaryrefslogtreecommitdiffstats
path: root/recipes-ti/ipc/ti-ipc-examples_git.bb
diff options
context:
space:
mode:
authorSam Nelson <sam.nelson@ti.com>2018-05-17 23:04:44 +0000
committerDenys Dmytriyenko <denys@ti.com>2018-06-01 18:29:37 +0000
commitdd8400c12149163576723a4778e11ebd01a89b37 (patch)
treee0d5e6ebf3c6868e8a11d88e84dbadc6b59152fe /recipes-ti/ipc/ti-ipc-examples_git.bb
parent12e2064557ac7b97ed60217ad1b0f768d1ad64f1 (diff)
downloadmeta-ti-dd8400c12149163576723a4778e11ebd01a89b37.tar.gz
ti-ipc: Update to new version 3.47.02.00
Adds new example for AM571X Signed-off-by: Sam Nelson <sam.nelson@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-ti/ipc/ti-ipc-examples_git.bb')
-rw-r--r--recipes-ti/ipc/ti-ipc-examples_git.bb24
1 files changed, 12 insertions, 12 deletions
diff --git a/recipes-ti/ipc/ti-ipc-examples_git.bb b/recipes-ti/ipc/ti-ipc-examples_git.bb
index 8aad69c9..c46e5c81 100644
--- a/recipes-ti/ipc/ti-ipc-examples_git.bb
+++ b/recipes-ti/ipc/ti-ipc-examples_git.bb
@@ -8,16 +8,16 @@ do_compile_append() {
8 if [ "${PLATFORM}" != "UNKNOWN" ]; then 8 if [ "${PLATFORM}" != "UNKNOWN" ]; then
9 oe_runmake extract HOSTOS="bios" IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" 9 oe_runmake extract HOSTOS="bios" IPC_INSTALL_DIR="${IPC_INSTALL_DIR}"
10 10
11 if [ ! -z ${ALT_PLATFORM} ]; then 11 for alt_platform in ${ALT_PLATFORM}; do
12 oe_runmake extract PLATFORM="${ALT_PLATFORM}" HOSTOS="bios" \ 12 oe_runmake extract PLATFORM="${alt_platform}" HOSTOS="bios" \
13 IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" 13 IPC_INSTALL_DIR="${IPC_INSTALL_DIR}"
14 fi 14 done
15 oe_runmake -C examples all HOSTOS="bios" \ 15 oe_runmake -C examples all HOSTOS="bios" \
16 IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" 16 IPC_INSTALL_DIR="${IPC_INSTALL_DIR}"
17 if [ ! -z ${ALT_PLATFORM} ]; then 17 for alt_platform in ${ALT_PLATFORM}; do
18 oe_runmake -C examples all HOSTOS="bios" \ 18 oe_runmake -C examples all HOSTOS="bios" \
19 IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" PLATFORM="${ALT_PLATFORM}" 19 IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" PLATFORM="${alt_platform}"
20 fi 20 done
21 fi 21 fi
22} 22}
23 23
@@ -30,14 +30,14 @@ do_install_append() {
30 oe_runmake -C examples install_rov IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \ 30 oe_runmake -C examples install_rov IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \
31 HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples/bios" 31 HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples/bios"
32 32
33 if [ ! -z ${ALT_PLATFORM} ]; then 33 for alt_platform in ${ALT_PLATFORM}; do
34 oe_runmake -C examples install IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \ 34 oe_runmake -C examples install IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \
35 HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples/bios" \ 35 HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples/${alt_platform}/bios" \
36 PLATFORM="${ALT_PLATFORM}" 36 PLATFORM="${alt_platform}"
37 oe_runmake -C examples install_rov IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \ 37 oe_runmake -C examples install_rov IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \
38 HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples/bios" \ 38 HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples/${alt_platform}/bios" \
39 PLATFORM="${ALT_PLATFORM}" 39 PLATFORM="${alt_platform}"
40 fi 40 done
41 fi 41 fi
42} 42}
43 43