diff options
author | Sam Nelson <sam.nelson@ti.com> | 2015-04-13 23:52:53 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2015-04-22 12:02:53 -0400 |
commit | 5074fec6030cb359704abbcb6c0df422fb2eb126 (patch) | |
tree | 29ae122255acd49a3d8a88d7f23055793b2c627d /recipes-ti/ipc/ipc-transport-qmss-test_git.bb | |
parent | fe401c2bfcdaf6acd60aca6d64db6d8235498ab0 (diff) | |
download | meta-ti-5074fec6030cb359704abbcb6c0df422fb2eb126.tar.gz |
ipc-transport-qmss: Add recipe for ipc qmss transport and test code
- Provides ipc transport layer using qmss module
- Supports k2h, k2k, k2e, k2l devices
Signed-off-by: Sam Nelson <sam.nelson@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-ti/ipc/ipc-transport-qmss-test_git.bb')
-rw-r--r-- | recipes-ti/ipc/ipc-transport-qmss-test_git.bb | 31 |
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes-ti/ipc/ipc-transport-qmss-test_git.bb b/recipes-ti/ipc/ipc-transport-qmss-test_git.bb new file mode 100644 index 00000000..34d37086 --- /dev/null +++ b/recipes-ti/ipc/ipc-transport-qmss-test_git.bb | |||
@@ -0,0 +1,31 @@ | |||
1 | include ipc-transport-qmss.inc | ||
2 | |||
3 | DEPENDS = "ipc-transport-qmss ti-ipc" | ||
4 | |||
5 | #FILES_${PN}-test = "${bindir}/multiProcessTest_*.out" | ||
6 | |||
7 | CHOICELIST = "yes no" | ||
8 | |||
9 | DEVICELIST = "k2h k2k k2e k2l" | ||
10 | |||
11 | do_compile () { | ||
12 | # Now build the test code | ||
13 | for device in ${DEVICELIST} | ||
14 | do | ||
15 | for choice in ${CHOICELIST} | ||
16 | do | ||
17 | oe_runmake tests \ | ||
18 | IPC_DEVKIT_INSTALL_PATH=${STAGING_INCDIR} \ | ||
19 | USEDYNAMIC_LIB="$choice" DEVICE="$device" | ||
20 | done | ||
21 | done | ||
22 | } | ||
23 | |||
24 | do_install () { | ||
25 | for device in ${DEVICELIST} | ||
26 | do | ||
27 | oe_runmake installbin \ | ||
28 | INSTALL_BIN_BASE_DIR=${D}${bindir} DEVICE="$device" | ||
29 | done | ||
30 | |||
31 | } | ||