summaryrefslogtreecommitdiffstats
path: root/recipes-ti/ipc/ipc-transport-qmss-test_git.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@konsulko.com>2022-02-22 04:13:08 +0000
committerRyan Eatmon <reatmon@ti.com>2022-02-22 12:01:31 -0600
commit53f4cdf2ce35cbb0aaac0891e5f06e8909caecdd (patch)
tree2d7a22adf169476666eda7d988767506f40f3d20 /recipes-ti/ipc/ipc-transport-qmss-test_git.bb
parentdd558151806beb2ac95356a7a8275498ccddf125 (diff)
downloadmeta-ti-53f4cdf2ce35cbb0aaac0891e5f06e8909caecdd.tar.gz
classes,recipes: remove K1/2 PDK RTOS support, FWs and IPC transports
Remove deprecated support for compiling Keystone1/2 RTOS components and Linux firmwares using PDK, CSL, etc. Signed-off-by: Denys Dmytriyenko <denys@konsulko.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'recipes-ti/ipc/ipc-transport-qmss-test_git.bb')
-rw-r--r--recipes-ti/ipc/ipc-transport-qmss-test_git.bb37
1 files changed, 0 insertions, 37 deletions
diff --git a/recipes-ti/ipc/ipc-transport-qmss-test_git.bb b/recipes-ti/ipc/ipc-transport-qmss-test_git.bb
deleted file mode 100644
index 158d1856..00000000
--- a/recipes-ti/ipc/ipc-transport-qmss-test_git.bb
+++ /dev/null
@@ -1,37 +0,0 @@
1include ipc-transport-qmss.inc
2
3PR = "${INC_PR}.0"
4
5PACKAGE_ARCH = "${MACHINE_ARCH}"
6
7DEPENDS = "ipc-transport-qmss ti-ipc"
8
9#FILES_${PN}-test = "${bindir}/multiProcessTest_*.out"
10
11CHOICELIST = "yes no"
12
13DEVICELIST:k2hk = "k2h k2k"
14DEVICELIST:k2e = "k2e"
15DEVICELIST:k2l = "k2l"
16
17do_compile () {
18# Now build the test code
19 for device in ${DEVICELIST}
20 do
21 for choice in ${CHOICELIST}
22 do
23 oe_runmake tests \
24 IPC_DEVKIT_INSTALL_PATH=${STAGING_INCDIR} \
25 USEDYNAMIC_LIB="$choice" DEVICE="$device"
26 done
27 done
28}
29
30do_install () {
31 for device in ${DEVICELIST}
32 do
33 oe_runmake installbin \
34 INSTALL_BIN_BASE_DIR=${D}${bindir} DEVICE="$device"
35 done
36
37}