diff options
author | Enric Balletbo i Serra <eballetbo@iseebcn.com> | 2014-10-08 19:47:45 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2014-10-08 13:50:09 -0400 |
commit | 888ea3744402acafa40e746a92bbca81a8b5a317 (patch) | |
tree | be9569140282d8758fc9813cdfb94d5f28e683cc /recipes-ti/dsplink | |
parent | f6c7946591dc9099855139be0e9e1a56474c6a7a (diff) | |
download | meta-ti-888ea3744402acafa40e746a92bbca81a8b5a317.tar.gz |
ti-dsplink: Fix irq mismatch for kernel versions greater than 3.7.0.
Commit 7d7e1eb (ARM: OMAP2+: Prepare for irqs.h removal) and commit
ec2c082 (ARM: OMAP2+: Remove hardcoded IRQs and enable SPARSE_IRQ)
from kernel updated the way interrupts for OMAP2/3 devices are defined.
Fix irq number as dsplink misses to add the NR_IRQS relative offset.
Signed-off-by: Enric Balletbo i Serra <eballetbo@iseebcn.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-ti/dsplink')
-rw-r--r-- | recipes-ti/dsplink/ti-dsplink.inc | 2 | ||||
-rw-r--r-- | recipes-ti/dsplink/ti-dsplink/dsplink_1_65_kernel_3_7_0_fix-irq-mismatch.patch | 16 | ||||
-rw-r--r-- | recipes-ti/dsplink/ti-dsplink_1.65.00.03.bb | 1 |
3 files changed, 18 insertions, 1 deletions
diff --git a/recipes-ti/dsplink/ti-dsplink.inc b/recipes-ti/dsplink/ti-dsplink.inc index fa1c9ddc..78b53cf0 100644 --- a/recipes-ti/dsplink/ti-dsplink.inc +++ b/recipes-ti/dsplink/ti-dsplink.inc | |||
@@ -21,7 +21,7 @@ PROVIDES += "ti-dsplink-examples" | |||
21 | 21 | ||
22 | # This package builds a kernel module, use kernel PR as base and append a local version | 22 | # This package builds a kernel module, use kernel PR as base and append a local version |
23 | PR = "${MACHINE_KERNEL_PR}" | 23 | PR = "${MACHINE_KERNEL_PR}" |
24 | PR_append = "j" | 24 | PR_append = "h" |
25 | 25 | ||
26 | S = "${WORKDIR}/dsplink_linux_${PV}" | 26 | S = "${WORKDIR}/dsplink_linux_${PV}" |
27 | 27 | ||
diff --git a/recipes-ti/dsplink/ti-dsplink/dsplink_1_65_kernel_3_7_0_fix-irq-mismatch.patch b/recipes-ti/dsplink/ti-dsplink/dsplink_1_65_kernel_3_7_0_fix-irq-mismatch.patch new file mode 100644 index 00000000..787c22e1 --- /dev/null +++ b/recipes-ti/dsplink/ti-dsplink/dsplink_1_65_kernel_3_7_0_fix-irq-mismatch.patch | |||
@@ -0,0 +1,16 @@ | |||
1 | Index: dsplink_linux_1_65_00_03/dsplink/gpp/src/osal/Linux/2.6.18/isr.c | ||
2 | =================================================================== | ||
3 | --- dsplink_linux_1_65_00_03.orig/dsplink/gpp/src/osal/Linux/2.6.18/isr.c | ||
4 | +++ dsplink_linux_1_65_00_03/dsplink/gpp/src/osal/Linux/2.6.18/isr.c | ||
5 | @@ -286,7 +286,11 @@ ISR_Create (IN IsrProc fnIS | ||
6 | |||
7 | if (DSP_SUCCEEDED (status)) { | ||
8 | (*isrObj)->signature = SIGN_ISR ; | ||
9 | +#if LINUX_VERSION_CODE < KERNEL_VERSION(3,7,0) | ||
10 | (*isrObj)->irq = intObj->intId ; | ||
11 | +#else | ||
12 | + (*isrObj)->irq = intObj->intId + NR_IRQS ; | ||
13 | +#endif | ||
14 | (*isrObj)->enabled = FALSE ; | ||
15 | (*isrObj)->dspId = intObj->dspId ; | ||
16 | (*isrObj)->checkFunc = intObj->checkFunc ; | ||
diff --git a/recipes-ti/dsplink/ti-dsplink_1.65.00.03.bb b/recipes-ti/dsplink/ti-dsplink_1.65.00.03.bb index 1d6fb009..2606cfc6 100644 --- a/recipes-ti/dsplink/ti-dsplink_1.65.00.03.bb +++ b/recipes-ti/dsplink/ti-dsplink_1.65.00.03.bb | |||
@@ -9,6 +9,7 @@ PV_DL_PATH = "DSPLink/${PV_major}/${PV}/${PV_dot}" | |||
9 | 9 | ||
10 | SRC_URI += "file://dsplink-BKL-fix.patch \ | 10 | SRC_URI += "file://dsplink-BKL-fix.patch \ |
11 | file://0001-remove-check-for-make-version-3.85-works-fine.patch \ | 11 | file://0001-remove-check-for-make-version-3.85-works-fine.patch \ |
12 | file://dsplink_1_65_kernel_3_7_0_fix-irq-mismatch.patch \ | ||
12 | " | 13 | " |
13 | 14 | ||
14 | SRC_URI[dsplinktarball.md5sum] = "1bda596b631bd2f517edc70f6be4f2ca" | 15 | SRC_URI[dsplinktarball.md5sum] = "1bda596b631bd2f517edc70f6be4f2ca" |