summaryrefslogtreecommitdiffstats
path: root/recipes-ti/dmai
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-12-22 11:19:55 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2011-12-24 16:17:44 +0100
commit97ce30236667173b826d13af354104829484d5db (patch)
tree08faf03450327a266c26b84af90e5a9ff1f341a4 /recipes-ti/dmai
parente62a63e5ffd9ff6e8705b3658f6b6568bbf5e582 (diff)
downloadmeta-ti-97ce30236667173b826d13af354104829484d5db.tar.gz
ti-dmai: clean up recipe
* remove DP = -1, there's only one recipe * remove unused files * add git patch header to remaining patches Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'recipes-ti/dmai')
-rw-r--r--recipes-ti/dmai/ti-dmai.inc4
-rw-r--r--recipes-ti/dmai/ti-dmai/0001-Correct-DMAI-s-Resize-module-for-DM365.patch34
-rw-r--r--recipes-ti/dmai/ti-dmai/dmai-built-with-angstrom.patch48
-rw-r--r--recipes-ti/dmai/ti-dmai/dmai-do-not-panic-on-mixer-failure.patch31
-rw-r--r--recipes-ti/dmai/ti-dmai/dmai-r423-add-omapl137-support.patch12
-rw-r--r--recipes-ti/dmai/ti-dmai/dmai-support-32bit-align.patch17
-rw-r--r--recipes-ti/dmai/ti-dmai/dmai-update-cpu-name.patch16
-rw-r--r--recipes-ti/dmai/ti-dmai/dmai-update-fb-display.patch77
-rw-r--r--recipes-ti/dmai/ti-dmai/dmai-update-v4l2-display.patch127
-rw-r--r--recipes-ti/dmai/ti-dmai/omap3530-r642-remove-include-videodev.diff74
-rw-r--r--recipes-ti/dmai/ti-dmai/r642-fix-config-bld.diff32
-rw-r--r--recipes-ti/dmai/ti-dmai_svn.bb12
12 files changed, 74 insertions, 410 deletions
diff --git a/recipes-ti/dmai/ti-dmai.inc b/recipes-ti/dmai/ti-dmai.inc
index 8b536fc8..8c20384a 100644
--- a/recipes-ti/dmai/ti-dmai.inc
+++ b/recipes-ti/dmai/ti-dmai.inc
@@ -47,12 +47,12 @@ DMAIPLATFORM_dm355 = "dm355_al"
47DMAIPLATFORM_dm365 = "dm365_al" 47DMAIPLATFORM_dm365 = "dm365_al"
48DMAIPLATFORM_omapl137 = "ol137_al" 48DMAIPLATFORM_omapl137 = "ol137_al"
49DMAIPLATFORM_omapl138 = "ol138_al" 49DMAIPLATFORM_omapl138 = "ol138_al"
50DMAIPLATFORM ?= "<UNDEFINED_DMAIPLATFORM>" 50DMAIPLATFORM ?= "UNDEFINED_DMAIPLATFORM"
51 51
52# Need to set this for other platforms as well 52# Need to set this for other platforms as well
53#GPPOS_dm355 = "LINUX_GCC" 53#GPPOS_dm355 = "LINUX_GCC"
54#GPPOS_dm365 = "LINUX_GCC" 54#GPPOS_dm365 = "LINUX_GCC"
55#GPPOS ?= "<UNDEFINEDGPPOS>" 55#GPPOS ?= "UNDEFINEDGPPOS"
56 56
57# Need to re-define this for OMAP-L137/L138 57# Need to re-define this for OMAP-L137/L138
58DSPSUFFIX_omapl137 = "x64P" 58DSPSUFFIX_omapl137 = "x64P"
diff --git a/recipes-ti/dmai/ti-dmai/0001-Correct-DMAI-s-Resize-module-for-DM365.patch b/recipes-ti/dmai/ti-dmai/0001-Correct-DMAI-s-Resize-module-for-DM365.patch
deleted file mode 100644
index 21e71dec..00000000
--- a/recipes-ti/dmai/ti-dmai/0001-Correct-DMAI-s-Resize-module-for-DM365.patch
+++ /dev/null
@@ -1,34 +0,0 @@
1From 9d9326c26ea990fa49842e0c57d520a5acb4d887 Mon Sep 17 00:00:00 2001
2From: Don Darling <ddarling@ti.com>
3Date: Fri, 16 Apr 2010 17:40:40 -0500
4Subject: [PATCH] Correct DMAI's Resize module for DM365.
5
6The PSP requires virtual addresses to be given for the resize buffers. This
7differs from previous releases, which required physical addresses. This
8change updates the Resize module to use virtual addresses.
9---
10 .../packages/ti/sdo/dmai/linux/dm365/Resize.c | 4 ++--
11 1 files changed, 2 insertions(+), 2 deletions(-)
12
13diff --git a/dmai/packages/ti/sdo/dmai/linux/dm365/Resize.c b/dmai/packages/ti/sdo/dmai/linux/dm365/Resize.c
14index c1716c4..3e71e46 100644
15--- a/dmai/packages/ti/sdo/dmai/linux/dm365/Resize.c
16+++ b/dmai/packages/ti/sdo/dmai/linux/dm365/Resize.c
17@@ -313,12 +313,12 @@ Int Resize_execute(Resize_Handle hResize,
18
19 rsz.in_buff.index = -1;
20 rsz.in_buff.buf_type = IMP_BUF_IN;
21- rsz.in_buff.offset = Buffer_getPhysicalPtr(hSrcBuf) + srcOffset;
22+ rsz.in_buff.offset = ((Int32)Buffer_getUserPtr(hSrcBuf)) + srcOffset;
23 rsz.in_buff.size = Buffer_getSize(hSrcBuf);
24
25 rsz.out_buff1.index = -1;
26 rsz.out_buff1.buf_type = IMP_BUF_OUT1;
27- rsz.out_buff1.offset = Buffer_getPhysicalPtr(hDstBuf) + dstOffset;
28+ rsz.out_buff1.offset = ((Int32)Buffer_getUserPtr(hDstBuf)) + dstOffset;
29 rsz.out_buff1.size = Buffer_getSize(hDstBuf);
30
31 /*
32--
331.6.3.3
34
diff --git a/recipes-ti/dmai/ti-dmai/dmai-built-with-angstrom.patch b/recipes-ti/dmai/ti-dmai/dmai-built-with-angstrom.patch
deleted file mode 100644
index fc497897..00000000
--- a/recipes-ti/dmai/ti-dmai/dmai-built-with-angstrom.patch
+++ /dev/null
@@ -1,48 +0,0 @@
1Index: dmai_1_20_00_06/packages/config.bld
2===================================================================
3--- dmai_1_20_00_06.orig/packages/config.bld 2009-02-11 19:38:51.000000000 -0600
4+++ dmai_1_20_00_06/packages/config.bld 2009-02-11 19:39:23.000000000 -0600
5@@ -42,7 +42,7 @@
6
7 /* location of the Codec Sourcery Arm9 tools */
8 var GCArmv5T = xdc.useModule('gnu.targets.arm.GCArmv5T');
9-GCArmv5T.LONGNAME = 'bin/arm-none-linux-gnueabi-gcc';
10+GCArmv5T.LONGNAME = 'bin/arm-angstrom-linux-gnueabi-gcc';
11 GCArmv5T.platform = "ti.platforms.evm3530";
12 GCArmv5T.rootDir = java.lang.System.getenv("CSTOOL_DIR");
13
14Index: dmai_1_20_00_06/packages/ti/sdo/dmai/Makefile
15===================================================================
16--- dmai_1_20_00_06.orig/packages/ti/sdo/dmai/Makefile 2009-02-11 19:39:57.000000000 -0600
17+++ dmai_1_20_00_06/packages/ti/sdo/dmai/Makefile 2009-02-11 19:58:05.000000000 -0600
18@@ -33,7 +33,7 @@
19 DMAI_INSTALL_DIR = ../../../..
20 TARGET = dmai
21
22-include $(DMAI_INSTALL_DIR)/Rules.make
23+#include $(DMAI_INSTALL_DIR)/Rules.make
24
25 # Should the full command be echoed to the console during build?
26 VERBOSE=false
27@@ -64,7 +64,7 @@
28 MVL_CPP_FLAGS = $(GNU_CPP_FLAGS) -Dxdc_target_name__=MVArm9
29 CS_CPP_FLAGS = $(GNU_CPP_FLAGS) -Dxdc_target_name__=codesourcery/GCArmv5T
30
31-GNU_C_FLAGS = $(C_FLAGS) -Wall -Werror
32+GNU_C_FLAGS = $(C_FLAGS) -Wall
33 C64P_C_FLAGS = $(C_FLAGS)
34
35 GNU_AR_FLAGS = $(AR_FLAGS)
36Index: dmai_1_20_00_06/packages/ti/sdo/dmai/apps/Makefile.app
37===================================================================
38--- dmai_1_20_00_06.orig/packages/ti/sdo/dmai/apps/Makefile.app 2009-02-11 19:58:44.000000000 -0600
39+++ dmai_1_20_00_06/packages/ti/sdo/dmai/apps/Makefile.app 2009-02-11 19:59:01.000000000 -0600
40@@ -34,7 +34,7 @@
41 ifndef DMAI_INSTALL_DIR
42 DMAI_INSTALL_DIR = ../../../../../..
43 endif
44-include $(DMAI_INSTALL_DIR)/Rules.make
45+#include $(DMAI_INSTALL_DIR)/Rules.make
46
47 # Should the full command be echoed to the console during build?
48 VERBOSE=false
diff --git a/recipes-ti/dmai/ti-dmai/dmai-do-not-panic-on-mixer-failure.patch b/recipes-ti/dmai/ti-dmai/dmai-do-not-panic-on-mixer-failure.patch
deleted file mode 100644
index 20e1aece..00000000
--- a/recipes-ti/dmai/ti-dmai/dmai-do-not-panic-on-mixer-failure.patch
+++ /dev/null
@@ -1,31 +0,0 @@
1Index: dmai_1_20_00_06/packages/ti/sdo/dmai/linux/Sound_alsa.c
2===================================================================
3--- dmai_1_20_00_06.orig/packages/ti/sdo/dmai/linux/Sound_alsa.c 2009-02-11 19:19:23.000000000 -0600
4+++ dmai_1_20_00_06/packages/ti/sdo/dmai/linux/Sound_alsa.c 2009-02-11 19:19:25.000000000 -0600
5@@ -139,7 +139,7 @@
6
7 snd_mixer_selem_id_free (sid);
8 snd_mixer_close (rcMixer);
9-
10+
11 return Dmai_EOK;
12 }
13
14@@ -431,14 +431,13 @@
15 Sound_alsa_delete(hSound);
16 return NULL;
17 }
18-
19+
20 if (setMixerVolume (attrs) <0) {
21- Sound_alsa_delete (hSound);
22- return NULL;
23+ Dmai_dbg2("Failed to set the mixer volume on %s (%s)\n",
24+ AUDIO_DEVICE, snd_strerror(status));
25 }
26 }
27
28-
29 return hSound;
30 }
31
diff --git a/recipes-ti/dmai/ti-dmai/dmai-r423-add-omapl137-support.patch b/recipes-ti/dmai/ti-dmai/dmai-r423-add-omapl137-support.patch
deleted file mode 100644
index 8f9e8b9f..00000000
--- a/recipes-ti/dmai/ti-dmai/dmai-r423-add-omapl137-support.patch
+++ /dev/null
@@ -1,12 +0,0 @@
1diff -uNr davinci_multimedia_application_interface/dmai/packages/ti/sdo/dmai/linux/Display_fbdev.c davinci_multimedia_application_interfaceb/dmai/packages/ti/sdo/dmai/linux/Display_fbdev.c
2--- davinci_multimedia_application_interface/dmai/packages/ti/sdo/dmai/linux/Display_fbdev.c 2010-03-14 22:43:20.000000000 +0000
3+++ davinci_multimedia_application_interfaceb/dmai/packages/ti/sdo/dmai/linux/Display_fbdev.c 2010-03-14 23:19:41.000000000 +0000
4@@ -43,7 +43,7 @@
5
6 #ifdef Dmai_Device_omap3530
7 #include <linux/omapfb.h>
8-#elif defined Dmai_Device_omapl138
9+#elif defined (Dmai_Device_omapl137) || defined (Dmai_Device_omapl138)
10 #include <video/davincifb.h>
11 #else
12 #include <video/davincifb_ioctl.h>
diff --git a/recipes-ti/dmai/ti-dmai/dmai-support-32bit-align.patch b/recipes-ti/dmai/ti-dmai/dmai-support-32bit-align.patch
deleted file mode 100644
index 0ee817d9..00000000
--- a/recipes-ti/dmai/ti-dmai/dmai-support-32bit-align.patch
+++ /dev/null
@@ -1,17 +0,0 @@
1Index: dmai_1_20_00_06/packages/ti/sdo/dmai/linux/omap3530/Resize.c
2===================================================================
3--- dmai_1_20_00_06.orig/packages/ti/sdo/dmai/linux/omap3530/Resize.c 2009-02-11 19:20:45.000000000 -0600
4+++ dmai_1_20_00_06/packages/ti/sdo/dmai/linux/omap3530/Resize.c 2009-02-11 19:21:09.000000000 -0600
5@@ -557,9 +557,9 @@
6 srcOffset = srcDim.y * srcDim.lineLength + srcDim.x * 2;
7 dstOffset = dstDim.y * dstDim.lineLength + dstDim.x * 2;
8
9- /* Input and output buffers must be 4096 bytes aligned */
10- assert(((Buffer_getPhysicalPtr(hDstBuf) + srcOffset) & 0xFFF) == 0);
11- assert(((Buffer_getPhysicalPtr(hSrcBuf) + dstOffset) & 0xFFF) == 0);
12+ /* Pointers must be a multiple of 32 bytes */
13+ assert((Buffer_getPhysicalPtr(hDstBuf) & 0x1F) == 0);
14+ assert((Buffer_getPhysicalPtr(hSrcBuf) & 0x1F) == 0);
15
16 /* Queue the resizer buffers */
17 for (i=0; i < 2; i++) {
diff --git a/recipes-ti/dmai/ti-dmai/dmai-update-cpu-name.patch b/recipes-ti/dmai/ti-dmai/dmai-update-cpu-name.patch
deleted file mode 100644
index 052a8e32..00000000
--- a/recipes-ti/dmai/ti-dmai/dmai-update-cpu-name.patch
+++ /dev/null
@@ -1,16 +0,0 @@
1Index: dmai_1_20_00_06/packages/ti/sdo/dmai/linux/Cpu.c
2===================================================================
3--- dmai_1_20_00_06.orig/packages/ti/sdo/dmai/linux/Cpu.c 2009-02-12 09:34:22.000000000 -0600
4+++ dmai_1_20_00_06/packages/ti/sdo/dmai/linux/Cpu.c 2009-02-12 09:34:51.000000000 -0600
5@@ -103,7 +103,10 @@
6 else if (strcmp(valBuf, "DM357 EVM") == 0) {
7 *device = Cpu_Device_DM6446;
8 }
9- else if (strcmp(valBuf, "OMAP3EVM Board") == 0) {
10+ else if ((strcmp(valBuf, "OMAP3EVM Board") == 0) ||
11+ (strcmp(valBuf, "OMAP3 EVM") == 0) ||
12+ (strcmp(valBuf, "OMAP3 Beagle Board") == 0)
13+ ){
14 *device = Cpu_Device_OMAP3530;
15 }
16 else {
diff --git a/recipes-ti/dmai/ti-dmai/dmai-update-fb-display.patch b/recipes-ti/dmai/ti-dmai/dmai-update-fb-display.patch
deleted file mode 100644
index 91c1dd15..00000000
--- a/recipes-ti/dmai/ti-dmai/dmai-update-fb-display.patch
+++ /dev/null
@@ -1,77 +0,0 @@
1Index: dmai_1_20_00_06/packages/ti/sdo/dmai/linux/Display_fbdev.c
2===================================================================
3--- dmai_1_20_00_06.orig/packages/ti/sdo/dmai/linux/Display_fbdev.c 2009-02-11 19:59:57.000000000 -0600
4+++ dmai_1_20_00_06/packages/ti/sdo/dmai/linux/Display_fbdev.c 2009-02-11 20:02:46.000000000 -0600
5@@ -41,10 +41,7 @@
6 #include <sys/ioctl.h>
7 #include <linux/fb.h>
8
9-#ifdef Dmai_Device_omap3530
10-/* OMAP specific kernel headers */
11-#include <video/omapfbdev.h>
12-#else
13+#ifndef Dmai_Device_omap3530
14 /* Davinci specific kernel headers */
15 #include <video/davincifb_ioctl.h>
16 #endif
17@@ -184,11 +181,13 @@
18 }
19 #endif
20
21+#if 0
22 /* Set up the sysfs variables before opening the display device */
23 if (_Display_sysfsSetup(attrs, channel) < 0) {
24 cleanup(hDisplay);
25 return NULL;
26 }
27+#endif
28
29 /* Open video display device */
30 hDisplay->fd = open(attrs->displayDevice, O_RDWR);
31@@ -423,6 +422,7 @@
32 ******************************************************************************/
33 Int Display_fbdev_get(Display_Handle hDisplay, Buffer_Handle *hBufPtr)
34 {
35+#if defined (FBIO_WAITFORVSYNC)
36 BufTab_Handle hBufTab = hDisplay->hBufTab;
37 int dummy;
38
39@@ -436,7 +436,8 @@
40 }
41
42 *hBufPtr = BufTab_getBuf(hBufTab, hDisplay->workingIdx);
43-
44+
45+#endif
46 return Dmai_EOK;
47 }
48
49Index: dmai_1_20_00_06/packages/ti/sdo/dmai/linux/Display.c
50===================================================================
51--- dmai_1_20_00_06.orig/packages/ti/sdo/dmai/linux/Display.c 2009-02-11 20:00:10.000000000 -0600
52+++ dmai_1_20_00_06/packages/ti/sdo/dmai/linux/Display.c 2009-02-11 20:02:07.000000000 -0600
53@@ -80,18 +80,18 @@
54
55 const Display_Attrs Display_Attrs_O3530_VID_DEFAULT = {
56 3,
57- Display_Std_V4L2,
58- VideoStd_VGA,
59- Display_Output_LCD,
60- "/dev/video1",
61+ Display_Std_FBDEV,
62+ VideoStd_D1_NTSC,
63+ Display_Output_DVI,
64+ "/dev/fb2",
65 0
66 };
67
68 const Display_Attrs Display_Attrs_O3530_OSD_DEFAULT = {
69 1,
70 Display_Std_FBDEV,
71- VideoStd_VGA,
72- Display_Output_LCD,
73+ VideoStd_D1_NTSC,
74+ Display_Output_DVI,
75 "/dev/fb0",
76 0
77 };
diff --git a/recipes-ti/dmai/ti-dmai/dmai-update-v4l2-display.patch b/recipes-ti/dmai/ti-dmai/dmai-update-v4l2-display.patch
deleted file mode 100644
index 8bb77d84..00000000
--- a/recipes-ti/dmai/ti-dmai/dmai-update-v4l2-display.patch
+++ /dev/null
@@ -1,127 +0,0 @@
1Index: dmai_1_20_00_06/packages/ti/sdo/dmai/linux/Display_v4l2.c
2===================================================================
3--- dmai_1_20_00_06.orig/packages/ti/sdo/dmai/linux/Display_v4l2.c 2009-02-11 19:22:51.000000000 -0600
4+++ dmai_1_20_00_06/packages/ti/sdo/dmai/linux/Display_v4l2.c 2009-02-11 19:27:02.000000000 -0600
5@@ -120,7 +120,9 @@
6 struct v4l2_format fmt;
7 enum v4l2_buf_type type;
8 Display_Handle hDisplay;
9- Int channel;
10+#if defined(Dmai_Device_omap3530) && defined(V4L2_CID_ROTATION)
11+ struct v4l2_control control;
12+#endif
13
14 assert(attrs);
15
16@@ -134,44 +136,6 @@
17
18 hDisplay->userAlloc = TRUE;
19
20-#ifdef Dmai_Device_omap3530
21- /* channel = 0 - digital video path
22- * channel = 1 - analog video path
23- */
24- switch (attrs->videoOutput) {
25- case Display_Output_SVIDEO:
26- case Display_Output_COMPOSITE:
27- channel = 1;
28- break;
29- case Display_Output_DVI:
30- case Display_Output_LCD:
31- case Display_Output_SYSTEM:
32- channel = 0;
33- break;
34- default:
35- /* do nothing */
36- break;
37- }
38-#else
39- if (strcmp(attrs->displayDevice, "/dev/video2") == 0) {
40- channel = 0;
41- }
42- else if (strcmp(attrs->displayDevice, "/dev/video3") == 0) {
43- channel = 1;
44- }
45- else {
46- Dmai_err1("%s not a display device\n", attrs->displayDevice);
47- cleanup(hDisplay);
48- return NULL;
49- }
50-#endif
51-
52- /* Set up the sysfs variables before opening the display device */
53- if (_Display_sysfsSetup(attrs, channel) < 0) {
54- cleanup(hDisplay);
55- return NULL;
56- }
57-
58 /* Open video capture device */
59 hDisplay->fd = open(attrs->displayDevice, O_RDWR, 0);
60
61@@ -182,9 +146,8 @@
62 return NULL;
63 }
64
65-#ifdef Dmai_Device_omap3530
66-#define VIDIOC_S_OMAP2_ROTATION _IOW ('V', 3, int)
67-
68+
69+#if defined(Dmai_Device_omap3530) && defined(V4L2_CID_ROTATION)
70 if (attrs->rotation != 0 && attrs->rotation != 90 &&
71 attrs->rotation != 180 && attrs->rotation != 270) {
72
73@@ -193,49 +156,16 @@
74 return NULL;
75 }
76
77- if (ioctl(hDisplay->fd, VIDIOC_S_OMAP2_ROTATION, &attrs->rotation) < 0) {
78- Dmai_err2("Failed VIDIOC_S_OMAP2_ROTATION on %s (%s)\n",
79+ control.id = V4L2_CID_ROTATION;
80+ control.value = attrs->rotation;
81+
82+ if (ioctl(hDisplay->fd, VIDIOC_S_CTRL, &control) < 0) {
83+ Dmai_err2("Failed VIDIOC_S_CTRL on %s (%s)\n",
84 attrs->displayDevice, strerror(errno));
85 cleanup(hDisplay);
86 return NULL;
87 }
88
89- switch (attrs->videoStd) {
90- case VideoStd_D1_NTSC:
91- fmt.fmt.pix.width = VideoStd_D1_WIDTH;
92- fmt.fmt.pix.height = VideoStd_D1_NTSC_HEIGHT;
93- break;
94- case VideoStd_D1_PAL:
95- fmt.fmt.pix.width = VideoStd_D1_WIDTH;
96- fmt.fmt.pix.height = VideoStd_D1_PAL_HEIGHT;
97- break;
98- case VideoStd_VGA:
99- fmt.fmt.pix.width = VideoStd_VGA_WIDTH;
100- fmt.fmt.pix.height = VideoStd_VGA_HEIGHT;
101- break;
102- case VideoStd_480P:
103- fmt.fmt.pix.width = VideoStd_480P_WIDTH;
104- fmt.fmt.pix.height = VideoStd_480P_HEIGHT;
105- break;
106- case VideoStd_720P_60:
107- fmt.fmt.pix.width = VideoStd_480P_WIDTH;
108- fmt.fmt.pix.height = VideoStd_480P_HEIGHT;
109- break;
110- default:
111- Dmai_err1("Unknown video standard %d\n", attrs->videoStd);
112- cleanup(hDisplay);
113- return NULL;
114- }
115-
116- fmt.fmt.pix.pixelformat = V4L2_PIX_FMT_UYVY;
117- fmt.type = V4L2_BUF_TYPE_VIDEO_OUTPUT;
118-
119- if (ioctl(hDisplay->fd, VIDIOC_S_FMT, &fmt) == -1) {
120- Dmai_err2("Failed VIDIOC_S_FMT on %s (%s)\n", attrs->displayDevice,
121- strerror(errno));
122- cleanup(hDisplay);
123- return NULL;
124- }
125 #endif /* Dmai_Device_omap3530 */
126
127 /* Determine the video image dimensions */
diff --git a/recipes-ti/dmai/ti-dmai/omap3530-r642-remove-include-videodev.diff b/recipes-ti/dmai/ti-dmai/omap3530-r642-remove-include-videodev.diff
index 54963542..63f9cc68 100644
--- a/recipes-ti/dmai/ti-dmai/omap3530-r642-remove-include-videodev.diff
+++ b/recipes-ti/dmai/ti-dmai/omap3530-r642-remove-include-videodev.diff
@@ -1,19 +1,32 @@
1Index: dmai/packages/ti/sdo/dmai/linux/omap3530/priv/_VideoBuf.h 1From 06c4cfeec98f4f1e31543878ceb74c5fff1907e4 Mon Sep 17 00:00:00 2001
2=================================================================== 2From: Enrico Butera <ebutera@users.berlios.de>
3--- dmai/packages/ti/sdo/dmai/linux/omap3530/priv/_VideoBuf.h (revisione 642) 3Date: Thu, 22 Dec 2011 11:01:58 +0100
4+++ dmai/packages/ti/sdo/dmai/linux/omap3530/priv/_VideoBuf.h (copia locale) 4Subject: [PATCH 1/2] adjust videdev headers for recent kernels
5@@ -34,7 +34,6 @@ 5
6 #ifndef ti_sdo_dai_linux_priv__VideoBuf_h_ 6Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
7 #define ti_sdo_dai_linux_priv__VideoBuf_h_ 7---
8 8 .../packages/ti/sdo/dmai/linux/omap3530/Capture.c | 1 -
9 .../ti/sdo/dmai/linux/omap3530/Display_v4l2.c | 1 -
10 .../ti/sdo/dmai/linux/omap3530/_VideoBuf.c | 1 -
11 .../ti/sdo/dmai/linux/omap3530/priv/_VideoBuf.h | 1 -
12 4 files changed, 0 insertions(+), 4 deletions(-)
13
14diff --git a/davinci_multimedia_application_interface/dmai/packages/ti/sdo/dmai/linux/omap3530/Capture.c b/davinci_multimedia_application_interface/dmai/packages/ti/sdo/dmai/linux/omap3530/Capture.c
15index a924169..c2b45d2 100644
16--- a/davinci_multimedia_application_interface/dmai/packages/ti/sdo/dmai/linux/omap3530/Capture.c
17+++ b/davinci_multimedia_application_interface/dmai/packages/ti/sdo/dmai/linux/omap3530/Capture.c
18@@ -40,7 +40,6 @@
19 #include <sys/mman.h>
20 #include <sys/ioctl.h>
21 #include <asm/types.h>
9-#include <linux/videodev.h> 22-#include <linux/videodev.h>
10 #include <linux/videodev2.h> 23 #include <linux/videodev2.h>
11 24
12 #include <ti/sdo/dmai/BufferGfx.h> 25 #include <xdc/std.h>
13Index: dmai/packages/ti/sdo/dmai/linux/omap3530/_VideoBuf.c 26diff --git a/davinci_multimedia_application_interface/dmai/packages/ti/sdo/dmai/linux/omap3530/Display_v4l2.c b/davinci_multimedia_application_interface/dmai/packages/ti/sdo/dmai/linux/omap3530/Display_v4l2.c
14=================================================================== 27index 0d01b39..0c35efe 100644
15--- dmai/packages/ti/sdo/dmai/linux/omap3530/_VideoBuf.c (revisione 642) 28--- a/davinci_multimedia_application_interface/dmai/packages/ti/sdo/dmai/linux/omap3530/Display_v4l2.c
16+++ dmai/packages/ti/sdo/dmai/linux/omap3530/_VideoBuf.c (copia locale) 29+++ b/davinci_multimedia_application_interface/dmai/packages/ti/sdo/dmai/linux/omap3530/Display_v4l2.c
17@@ -38,7 +38,6 @@ 30@@ -38,7 +38,6 @@
18 #include <sys/ioctl.h> 31 #include <sys/ioctl.h>
19 #include <sys/mman.h> 32 #include <sys/mman.h>
@@ -22,22 +35,10 @@ Index: dmai/packages/ti/sdo/dmai/linux/omap3530/_VideoBuf.c
22 #include <linux/videodev2.h> 35 #include <linux/videodev2.h>
23 36
24 #include <xdc/std.h> 37 #include <xdc/std.h>
25Index: dmai/packages/ti/sdo/dmai/linux/omap3530/Capture.c 38diff --git a/davinci_multimedia_application_interface/dmai/packages/ti/sdo/dmai/linux/omap3530/_VideoBuf.c b/davinci_multimedia_application_interface/dmai/packages/ti/sdo/dmai/linux/omap3530/_VideoBuf.c
26=================================================================== 39index 5615e2f..5cb712d 100644
27--- dmai/packages/ti/sdo/dmai/linux/omap3530/Capture.c (revisione 642) 40--- a/davinci_multimedia_application_interface/dmai/packages/ti/sdo/dmai/linux/omap3530/_VideoBuf.c
28+++ dmai/packages/ti/sdo/dmai/linux/omap3530/Capture.c (copia locale) 41+++ b/davinci_multimedia_application_interface/dmai/packages/ti/sdo/dmai/linux/omap3530/_VideoBuf.c
29@@ -40,7 +40,6 @@
30 #include <sys/mman.h>
31 #include <sys/ioctl.h>
32 #include <asm/types.h>
33-#include <linux/videodev.h>
34 #include <linux/videodev2.h>
35
36 #include <xdc/std.h>
37Index: dmai/packages/ti/sdo/dmai/linux/omap3530/Display_v4l2.c
38===================================================================
39--- dmai/packages/ti/sdo/dmai/linux/omap3530/Display_v4l2.c (revisione 642)
40+++ dmai/packages/ti/sdo/dmai/linux/omap3530/Display_v4l2.c (copia locale)
41@@ -38,7 +38,6 @@ 42@@ -38,7 +38,6 @@
42 #include <sys/ioctl.h> 43 #include <sys/ioctl.h>
43 #include <sys/mman.h> 44 #include <sys/mman.h>
@@ -46,3 +47,18 @@ Index: dmai/packages/ti/sdo/dmai/linux/omap3530/Display_v4l2.c
46 #include <linux/videodev2.h> 47 #include <linux/videodev2.h>
47 48
48 #include <xdc/std.h> 49 #include <xdc/std.h>
50diff --git a/davinci_multimedia_application_interface/dmai/packages/ti/sdo/dmai/linux/omap3530/priv/_VideoBuf.h b/davinci_multimedia_application_interface/dmai/packages/ti/sdo/dmai/linux/omap3530/priv/_VideoBuf.h
51index b2128a3..dbaa4eb 100644
52--- a/davinci_multimedia_application_interface/dmai/packages/ti/sdo/dmai/linux/omap3530/priv/_VideoBuf.h
53+++ b/davinci_multimedia_application_interface/dmai/packages/ti/sdo/dmai/linux/omap3530/priv/_VideoBuf.h
54@@ -34,7 +34,6 @@
55 #ifndef ti_sdo_dai_linux_priv__VideoBuf_h_
56 #define ti_sdo_dai_linux_priv__VideoBuf_h_
57
58-#include <linux/videodev.h>
59 #include <linux/videodev2.h>
60
61 #include <ti/sdo/dmai/BufferGfx.h>
62--
631.7.2.5
64
diff --git a/recipes-ti/dmai/ti-dmai/r642-fix-config-bld.diff b/recipes-ti/dmai/ti-dmai/r642-fix-config-bld.diff
index 06ffbec4..2f328c0e 100644
--- a/recipes-ti/dmai/ti-dmai/r642-fix-config-bld.diff
+++ b/recipes-ti/dmai/ti-dmai/r642-fix-config-bld.diff
@@ -1,8 +1,18 @@
1Index: dmai/packages/config.bld 1From 86e89bb160cfe67c173f1260b93066b12dd73580 Mon Sep 17 00:00:00 2001
2=================================================================== 2From: Enrico Butera <ebutera@users.berlios.de>
3--- dmai/packages/config.bld (revisione 642) 3Date: Thu, 22 Dec 2011 11:03:58 +0100
4+++ dmai/packages/config.bld (copia locale) 4Subject: [PATCH 2/2] fix toolchain names in config.bld
5@@ -44,29 +44,9 @@ 5
6Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
7---
8 .../dmai/packages/config.bld | 24 +------------------
9 1 files changed, 2 insertions(+), 22 deletions(-)
10
11diff --git a/davinci_multimedia_application_interface/dmai/packages/config.bld b/davinci_multimedia_application_interface/dmai/packages/config.bld
12index 8c2e96e..566f907 100644
13--- a/davinci_multimedia_application_interface/dmai/packages/config.bld
14+++ b/davinci_multimedia_application_interface/dmai/packages/config.bld
15@@ -44,28 +44,8 @@ var C6X = xdc.useModule('ti.targets.C64P');
6 C6X.rootDir = codegen; 16 C6X.rootDir = codegen;
7 C6X.platform = xdcplat; 17 C6X.platform = xdcplat;
8 18
@@ -10,9 +20,7 @@ Index: dmai/packages/config.bld
10- Then the TOOLDIR and LONGNAME are derived based on a regex of CROSS_COMPILE 20- Then the TOOLDIR and LONGNAME are derived based on a regex of CROSS_COMPILE
11-*/ 21-*/
12-var crosscompile = "" + java.lang.System.getenv("CROSS_COMPILE"); 22-var crosscompile = "" + java.lang.System.getenv("CROSS_COMPILE");
13+var tooldir = "" + java.lang.System.getenv("CSTOOL_DIR"); 23-
14+var longName = "" + java.lang.System.getenv("MVTOOL_PREFIX") + "gcc";
15
16-var tooldir = ""; 24-var tooldir = "";
17-var longName = ""; 25-var longName = "";
18- 26-
@@ -30,7 +38,11 @@ Index: dmai/packages/config.bld
30-} else { 38-} else {
31- longName = crosscompile + "gcc"; 39- longName = crosscompile + "gcc";
32-} 40-}
33- 41+var tooldir = "" + java.lang.System.getenv("CSTOOL_DIR");
42+var longName = "" + java.lang.System.getenv("MVTOOL_PREFIX") + "gcc";
43
34 /* location of the GCC Arm9 tools */ 44 /* location of the GCC Arm9 tools */
35 var GCArmv5T = xdc.useModule('gnu.targets.arm.GCArmv5T'); 45 var GCArmv5T = xdc.useModule('gnu.targets.arm.GCArmv5T');
36 GCArmv5T.LONGNAME = longName; 46--
471.7.2.5
48
diff --git a/recipes-ti/dmai/ti-dmai_svn.bb b/recipes-ti/dmai/ti-dmai_svn.bb
index cae4c1f7..43b2833d 100644
--- a/recipes-ti/dmai/ti-dmai_svn.bb
+++ b/recipes-ti/dmai/ti-dmai_svn.bb
@@ -3,15 +3,13 @@ require ti-dmai.inc
3# Hack to be able to use recent kernel headers from userspace 3# Hack to be able to use recent kernel headers from userspace
4TARGET_CC_ARCH += " -D__EXPORTED_HEADERS__" 4TARGET_CC_ARCH += " -D__EXPORTED_HEADERS__"
5 5
6DEFAULT_PREFERENCE = "-1"
7
8PV = "2_10_00_01+svnr${SRCPV}" 6PV = "2_10_00_01+svnr${SRCPV}"
9 7
10LIC_FILES_CHKSUM = "file://dmai_${PV}_License.html;md5=3302f728a5a42f97cabc26a54d7fa607" 8LIC_FILES_CHKSUM = "file://dmai_${PV}_License.html;md5=3302f728a5a42f97cabc26a54d7fa607"
11 9
12# This package has high dependence on kernel, use kernel PR as base and append a local version 10# This package has high dependence on kernel, use kernel PR as base and append a local version
13PR = "${MACHINE_KERNEL_PR}" 11PR = "${MACHINE_KERNEL_PR}"
14PR_append = "n" 12PR_append = "o"
15 13
16DMAIBRANCH_dm6446 = "trunk" 14DMAIBRANCH_dm6446 = "trunk"
17DMAIBRANCH_dm6467 = "branches/GITPSP_INT_101009" 15DMAIBRANCH_dm6467 = "branches/GITPSP_INT_101009"
@@ -20,7 +18,7 @@ DMAIBRANCH_dm355 = "branches/GITPSP_INT_101009"
20DMAIBRANCH_dm365 = "trunk" 18DMAIBRANCH_dm365 = "trunk"
21DMAIBRANCH_omapl137 = "trunk" 19DMAIBRANCH_omapl137 = "trunk"
22DMAIBRANCH_omapl138 = "trunk" 20DMAIBRANCH_omapl138 = "trunk"
23DMAIBRANCH ?= "<UNDEFINED_DMAIBRANCH>" 21DMAIBRANCH ?= "UNDEFINED_DMAIBRANCH"
24 22
25SRCREV_dm6446 = "482" 23SRCREV_dm6446 = "482"
26SRCREV_dm6467 = "441" 24SRCREV_dm6467 = "441"
@@ -29,9 +27,9 @@ SRCREV_dm355 = "424"
29SRCREV_dm365 = "570" 27SRCREV_dm365 = "570"
30SRCREV_omapl137 = "482" 28SRCREV_omapl137 = "482"
31SRCREV_omapl138 = "570" 29SRCREV_omapl138 = "570"
32SRCREV ?= "<UNDEFINED_SRCREV>" 30SRCREV ?= "UNDEFINED_SRCREV"
33 31
34SRC_URI_append = " file://omap3530-r642-remove-include-videodev.diff \ 32SRC_URI_append = " file://omap3530-r642-remove-include-videodev.diff;striplevel=2 \
35 file://r642-fix-config-bld.diff \ 33 file://r642-fix-config-bld.diff;striplevel=2 \
36 " 34 "
37 35