diff options
author | Enrico Butera <ebutera@users.berlios.de> | 2011-08-08 18:10:31 +0200 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2011-08-16 09:46:08 +0200 |
commit | f3e46c9bbe77dd8937c2667dfa55f731be31c636 (patch) | |
tree | 00f8c445f9ddf8b98d17ea9cf7b8a12f831221c1 /recipes-ti/dmai | |
parent | 17c027e2aede4fb92c82cf92f91fc38529789a7b (diff) | |
download | meta-ti-f3e46c9bbe77dd8937c2667dfa55f731be31c636.tar.gz |
dmai: fix build and update omap3 srcrev to 642
Signed-off-by: Enrico Butera <ebutera@users.berlios.de>
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'recipes-ti/dmai')
-rw-r--r-- | recipes-ti/dmai/ti-dmai.inc | 3 | ||||
-rw-r--r-- | recipes-ti/dmai/ti-dmai/omap3530-r642-remove-include-videodev.diff | 48 | ||||
-rw-r--r-- | recipes-ti/dmai/ti-dmai/r642-fix-config-bld.diff | 36 | ||||
-rw-r--r-- | recipes-ti/dmai/ti-dmai_svn.bb | 8 |
4 files changed, 93 insertions, 2 deletions
diff --git a/recipes-ti/dmai/ti-dmai.inc b/recipes-ti/dmai/ti-dmai.inc index c3d45a7b..a84f303a 100644 --- a/recipes-ti/dmai/ti-dmai.inc +++ b/recipes-ti/dmai/ti-dmai.inc | |||
@@ -114,7 +114,8 @@ do_compile () { | |||
114 | BIOS_INSTALL_DIR="${BIOS_INSTALL_DIR}"\ | 114 | BIOS_INSTALL_DIR="${BIOS_INSTALL_DIR}"\ |
115 | LINUXLIBS_INSTALL_DIR="${STAGING_DIR_TARGET}/usr" \ | 115 | LINUXLIBS_INSTALL_DIR="${STAGING_DIR_TARGET}/usr" \ |
116 | USER_XDC_PATH="${USER_XDC_PATH}" \ | 116 | USER_XDC_PATH="${USER_XDC_PATH}" \ |
117 | CROSS_COMPILE="${TOOLCHAIN_PATH}/bin/${TARGET_PREFIX}" \ | 117 | CROSS_COMPILE="${TOOLCHAIN_PATH}/${TARGET_PREFIX}" \ |
118 | CSTOOL_DIR="${TOOLCHAIN_PATH}" \ | ||
118 | VERBOSE="true" \ | 119 | VERBOSE="true" \ |
119 | XDAIS_INSTALL_DIR="${XDAIS_INSTALL_DIR}" \ | 120 | XDAIS_INSTALL_DIR="${XDAIS_INSTALL_DIR}" \ |
120 | LINK_INSTALL_DIR="${LINK_INSTALL_DIR}" \ | 121 | LINK_INSTALL_DIR="${LINK_INSTALL_DIR}" \ |
diff --git a/recipes-ti/dmai/ti-dmai/omap3530-r642-remove-include-videodev.diff b/recipes-ti/dmai/ti-dmai/omap3530-r642-remove-include-videodev.diff new file mode 100644 index 00000000..54963542 --- /dev/null +++ b/recipes-ti/dmai/ti-dmai/omap3530-r642-remove-include-videodev.diff | |||
@@ -0,0 +1,48 @@ | |||
1 | Index: dmai/packages/ti/sdo/dmai/linux/omap3530/priv/_VideoBuf.h | ||
2 | =================================================================== | ||
3 | --- dmai/packages/ti/sdo/dmai/linux/omap3530/priv/_VideoBuf.h (revisione 642) | ||
4 | +++ dmai/packages/ti/sdo/dmai/linux/omap3530/priv/_VideoBuf.h (copia locale) | ||
5 | @@ -34,7 +34,6 @@ | ||
6 | #ifndef ti_sdo_dai_linux_priv__VideoBuf_h_ | ||
7 | #define ti_sdo_dai_linux_priv__VideoBuf_h_ | ||
8 | |||
9 | -#include <linux/videodev.h> | ||
10 | #include <linux/videodev2.h> | ||
11 | |||
12 | #include <ti/sdo/dmai/BufferGfx.h> | ||
13 | Index: dmai/packages/ti/sdo/dmai/linux/omap3530/_VideoBuf.c | ||
14 | =================================================================== | ||
15 | --- dmai/packages/ti/sdo/dmai/linux/omap3530/_VideoBuf.c (revisione 642) | ||
16 | +++ dmai/packages/ti/sdo/dmai/linux/omap3530/_VideoBuf.c (copia locale) | ||
17 | @@ -38,7 +38,6 @@ | ||
18 | #include <sys/ioctl.h> | ||
19 | #include <sys/mman.h> | ||
20 | #include <errno.h> | ||
21 | -#include <linux/videodev.h> | ||
22 | #include <linux/videodev2.h> | ||
23 | |||
24 | #include <xdc/std.h> | ||
25 | Index: dmai/packages/ti/sdo/dmai/linux/omap3530/Capture.c | ||
26 | =================================================================== | ||
27 | --- dmai/packages/ti/sdo/dmai/linux/omap3530/Capture.c (revisione 642) | ||
28 | +++ dmai/packages/ti/sdo/dmai/linux/omap3530/Capture.c (copia locale) | ||
29 | @@ -40,7 +40,6 @@ | ||
30 | #include <sys/mman.h> | ||
31 | #include <sys/ioctl.h> | ||
32 | #include <asm/types.h> | ||
33 | -#include <linux/videodev.h> | ||
34 | #include <linux/videodev2.h> | ||
35 | |||
36 | #include <xdc/std.h> | ||
37 | Index: dmai/packages/ti/sdo/dmai/linux/omap3530/Display_v4l2.c | ||
38 | =================================================================== | ||
39 | --- dmai/packages/ti/sdo/dmai/linux/omap3530/Display_v4l2.c (revisione 642) | ||
40 | +++ dmai/packages/ti/sdo/dmai/linux/omap3530/Display_v4l2.c (copia locale) | ||
41 | @@ -38,7 +38,6 @@ | ||
42 | #include <sys/ioctl.h> | ||
43 | #include <sys/mman.h> | ||
44 | #include <errno.h> | ||
45 | -#include <linux/videodev.h> | ||
46 | #include <linux/videodev2.h> | ||
47 | |||
48 | #include <xdc/std.h> | ||
diff --git a/recipes-ti/dmai/ti-dmai/r642-fix-config-bld.diff b/recipes-ti/dmai/ti-dmai/r642-fix-config-bld.diff new file mode 100644 index 00000000..06ffbec4 --- /dev/null +++ b/recipes-ti/dmai/ti-dmai/r642-fix-config-bld.diff | |||
@@ -0,0 +1,36 @@ | |||
1 | Index: dmai/packages/config.bld | ||
2 | =================================================================== | ||
3 | --- dmai/packages/config.bld (revisione 642) | ||
4 | +++ dmai/packages/config.bld (copia locale) | ||
5 | @@ -44,29 +44,9 @@ | ||
6 | C6X.rootDir = codegen; | ||
7 | C6X.platform = xdcplat; | ||
8 | |||
9 | -/* User passes in $(CROSS_COMPILE) where $(CROSS_COMPILE)gcc is their compiler | ||
10 | - Then the TOOLDIR and LONGNAME are derived based on a regex of CROSS_COMPILE | ||
11 | -*/ | ||
12 | -var crosscompile = "" + java.lang.System.getenv("CROSS_COMPILE"); | ||
13 | +var tooldir = "" + java.lang.System.getenv("CSTOOL_DIR"); | ||
14 | +var longName = "" + java.lang.System.getenv("MVTOOL_PREFIX") + "gcc"; | ||
15 | |||
16 | -var tooldir = ""; | ||
17 | -var longName = ""; | ||
18 | - | ||
19 | -/* Search CROSS_COMPILE for bin/ If only 1 bin/ is found, set the tooldir to | ||
20 | - the path prior to bin/ and the prefix to "bin/" + remainder of path, | ||
21 | - else leave the tooldir as "" and set the LONGNAME to the full CROSS_COMPILE | ||
22 | - path | ||
23 | -*/ | ||
24 | -var regex = new RegExp("bin/"); | ||
25 | -var find = crosscompile.split( regex ); | ||
26 | - | ||
27 | -if (find[0]!=crosscompile && find.length==2) { | ||
28 | - tooldir = find[0]; | ||
29 | - longName = "bin/" + find[1] + "gcc"; | ||
30 | -} else { | ||
31 | - longName = crosscompile + "gcc"; | ||
32 | -} | ||
33 | - | ||
34 | /* location of the GCC Arm9 tools */ | ||
35 | var GCArmv5T = xdc.useModule('gnu.targets.arm.GCArmv5T'); | ||
36 | GCArmv5T.LONGNAME = longName; | ||
diff --git a/recipes-ti/dmai/ti-dmai_svn.bb b/recipes-ti/dmai/ti-dmai_svn.bb index 374acce7..cae4c1f7 100644 --- a/recipes-ti/dmai/ti-dmai_svn.bb +++ b/recipes-ti/dmai/ti-dmai_svn.bb | |||
@@ -7,6 +7,8 @@ DEFAULT_PREFERENCE = "-1" | |||
7 | 7 | ||
8 | PV = "2_10_00_01+svnr${SRCPV}" | 8 | PV = "2_10_00_01+svnr${SRCPV}" |
9 | 9 | ||
10 | LIC_FILES_CHKSUM = "file://dmai_${PV}_License.html;md5=3302f728a5a42f97cabc26a54d7fa607" | ||
11 | |||
10 | # This package has high dependence on kernel, use kernel PR as base and append a local version | 12 | # This package has high dependence on kernel, use kernel PR as base and append a local version |
11 | PR = "${MACHINE_KERNEL_PR}" | 13 | PR = "${MACHINE_KERNEL_PR}" |
12 | PR_append = "n" | 14 | PR_append = "n" |
@@ -22,10 +24,14 @@ DMAIBRANCH ?= "<UNDEFINED_DMAIBRANCH>" | |||
22 | 24 | ||
23 | SRCREV_dm6446 = "482" | 25 | SRCREV_dm6446 = "482" |
24 | SRCREV_dm6467 = "441" | 26 | SRCREV_dm6467 = "441" |
25 | SRCREV_omap3 = "570" | 27 | SRCREV_omap3 = "642" |
26 | SRCREV_dm355 = "424" | 28 | SRCREV_dm355 = "424" |
27 | SRCREV_dm365 = "570" | 29 | SRCREV_dm365 = "570" |
28 | SRCREV_omapl137 = "482" | 30 | SRCREV_omapl137 = "482" |
29 | SRCREV_omapl138 = "570" | 31 | SRCREV_omapl138 = "570" |
30 | SRCREV ?= "<UNDEFINED_SRCREV>" | 32 | SRCREV ?= "<UNDEFINED_SRCREV>" |
31 | 33 | ||
34 | SRC_URI_append = " file://omap3530-r642-remove-include-videodev.diff \ | ||
35 | file://r642-fix-config-bld.diff \ | ||
36 | " | ||
37 | |||