summaryrefslogtreecommitdiffstats
path: root/recipes-ti/devtools
diff options
context:
space:
mode:
authorJacob Stiffler <j-stiffler@ti.com>2019-07-29 23:37:26 +0000
committerDenys Dmytriyenko <denys@ti.com>2019-07-31 19:28:16 +0000
commit5b1f2650e9e2150716b5258d355234bad9c7d736 (patch)
tree15e56639f6f61fa8a6f8b6c61c670cfe026e1716 /recipes-ti/devtools
parent3d2ff2e2079347e6ee3d820b77c46e0321bb305f (diff)
downloadmeta-ti-5b1f2650e9e2150716b5258d355234bad9c7d736.tar.gz
ti-cgt-arm: consolidate into single file
Signed-off-by: Jacob Stiffler <j-stiffler@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-ti/devtools')
-rw-r--r--recipes-ti/devtools/ti-cgt-arm-native_18.12.1.bb38
-rw-r--r--recipes-ti/devtools/ti-cgt-arm.inc36
2 files changed, 35 insertions, 39 deletions
diff --git a/recipes-ti/devtools/ti-cgt-arm-native_18.12.1.bb b/recipes-ti/devtools/ti-cgt-arm-native_18.12.1.bb
index 7df9660c..5d724069 100644
--- a/recipes-ti/devtools/ti-cgt-arm-native_18.12.1.bb
+++ b/recipes-ti/devtools/ti-cgt-arm-native_18.12.1.bb
@@ -1,6 +1,38 @@
1include ti-cgt-arm.inc 1SUMMARY = "TI ARM Code Generation Tools"
2HOMEPAGE = "https://www-a.ti.com/downloads/sds_support/TICodegenerationTools/download.htm"
3LICENSE = "(TI-TSPA & Thai-Open-Source-Software-Center) & BSD-3-Clause & BSL-1.0 & Hewlett-Packard & Patrick-Powell & AFL-3.0 & MIT & BSD-2-Clause & PD & BSD-4-Clause"
2 4
3LIC_FILES_CHKSUM = "file://ti-cgt-arm_${PV}.LTS/README.txt;md5=ab7a61241e90fcd144a756d88294cf30" 5LIC_FILES_CHKSUM = "file://ti-cgt-arm_${PV}.LTS/README.txt;md5=ab7a61241e90fcd144a756d88294cf30"
4 6
5BINFILE_MD5 = "af2378cf8d5d6f200ef3329f5a065529" 7inherit native
6BINFILE_SHA256 = "d90ae2360cd5b22912715ae7898d99352da1b97fd655f9a55d0d19a2a46bab0e" 8require recipes-ti/includes/ti-unpack.inc
9require recipes-ti/includes/ti-staging.inc
10require recipes-ti/includes/ti-paths.inc
11
12S = "${WORKDIR}/ti-cgt-arm-${PV}"
13
14PR = "r0"
15
16SRC_URI = "http://software-dl.ti.com/codegen/esd/cgt_public_sw/TMS470/${PV}.LTS/${BINFILE};name=${BINFILE_NAME}"
17
18BINFILE = "ti_cgt_tms470_${PV}.LTS_linux_installer_x86.bin"
19TI_BIN_UNPK_ARGS = "--prefix ${S}"
20TI_BIN_UNPK_CMDS = ""
21
22do_install() {
23 install -d ${D}${M4_TOOLCHAIN_INSTALL_DIR_RECIPE}
24 cp -r ${S}/ti-cgt-arm*/. ${D}${M4_TOOLCHAIN_INSTALL_DIR_RECIPE}
25}
26
27SRC_URI[cgt_arm_installer.md5sum] = "af2378cf8d5d6f200ef3329f5a065529"
28SRC_URI[cgt_arm_installer.sha256sum] = "d90ae2360cd5b22912715ae7898d99352da1b97fd655f9a55d0d19a2a46bab0e"
29
30BINFILE_NAME = "cgt_arm_installer"
31
32FILES_${PN} += "${M4_TOOLCHAIN_INSTALL_DIR_RECIPE}"
33
34INHIBIT_PACKAGE_STRIP = "1"
35INHIBIT_SYSROOT_STRIP = "1"
36INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
37
38INSANE_SKIP_${PN} += "arch staticdev"
diff --git a/recipes-ti/devtools/ti-cgt-arm.inc b/recipes-ti/devtools/ti-cgt-arm.inc
deleted file mode 100644
index d2d768ce..00000000
--- a/recipes-ti/devtools/ti-cgt-arm.inc
+++ /dev/null
@@ -1,36 +0,0 @@
1SUMMARY = "TI ARM Code Generation Tools"
2HOMEPAGE = "https://www-a.ti.com/downloads/sds_support/TICodegenerationTools/download.htm"
3LICENSE = "(TI-TSPA & Thai-Open-Source-Software-Center) & BSD-3-Clause & BSL-1.0 & Hewlett-Packard & Patrick-Powell & AFL-3.0 & MIT & BSD-2-Clause & PD & BSD-4-Clause"
4
5inherit native
6require recipes-ti/includes/ti-unpack.inc
7require recipes-ti/includes/ti-staging.inc
8require recipes-ti/includes/ti-paths.inc
9
10S = "${WORKDIR}/ti-cgt-arm-${PV}"
11
12PR = "r0"
13
14SRC_URI = "http://software-dl.ti.com/codegen/esd/cgt_public_sw/TMS470/${PV}.LTS/${BINFILE};name=${BINFILE_NAME}"
15
16BINFILE = "ti_cgt_tms470_${PV}.LTS_linux_installer_x86.bin"
17TI_BIN_UNPK_ARGS = "--prefix ${S}"
18TI_BIN_UNPK_CMDS = ""
19
20do_install() {
21 install -d ${D}${M4_TOOLCHAIN_INSTALL_DIR_RECIPE}
22 cp -r ${S}/ti-cgt-arm*/. ${D}${M4_TOOLCHAIN_INSTALL_DIR_RECIPE}
23}
24
25SRC_URI[cgt_arm_installer.md5sum] = "${BINFILE_MD5}"
26SRC_URI[cgt_arm_installer.sha256sum] = "${BINFILE_SHA256}"
27
28BINFILE_NAME = "cgt_arm_installer"
29
30FILES_${PN} += "${M4_TOOLCHAIN_INSTALL_DIR_RECIPE}"
31
32INHIBIT_PACKAGE_STRIP = "1"
33INHIBIT_SYSROOT_STRIP = "1"
34INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
35
36INSANE_SKIP_${PN} += "arch staticdev"