summaryrefslogtreecommitdiffstats
path: root/recipes-ti/devtools
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2018-07-10 07:06:01 +0000
committerDenys Dmytriyenko <denys@ti.com>2018-07-10 18:39:09 +0000
commita5ecd90543b0842555662ea92e129d78e6f8c08b (patch)
treee78c524c27bd0922dbe64879c84fa2405dd6e30e /recipes-ti/devtools
parentf64a19d3e99027030decbf4ae9760f3a22a4e584 (diff)
downloadmeta-ti-a5ecd90543b0842555662ea92e129d78e6f8c08b.tar.gz
meta-ti: cleanup use of d.getVar()
1. drop use of True as second parameter, which is default, to align with master 2. there were instances of incorrectly passing 'd' as second parameter from previous conversion from bb.data.getVar() usage Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-ti/devtools')
-rw-r--r--recipes-ti/devtools/ti-cgt6x_8.2.2.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/recipes-ti/devtools/ti-cgt6x_8.2.2.bb b/recipes-ti/devtools/ti-cgt6x_8.2.2.bb
index 04e55ae9..53f52526 100644
--- a/recipes-ti/devtools/ti-cgt6x_8.2.2.bb
+++ b/recipes-ti/devtools/ti-cgt6x_8.2.2.bb
@@ -13,14 +13,14 @@ COMPATIBLE_HOST_class-target = "arm.*-linux"
13 13
14# For now we only have hardfp version for target class 14# For now we only have hardfp version for target class
15python __anonymous() { 15python __anonymous() {
16 c = d.getVar("CLASSOVERRIDE", d, 1) 16 c = d.getVar("CLASSOVERRIDE")
17 17
18 if c == "class-target": 18 if c == "class-target":
19 tunes = d.getVar("TUNE_FEATURES", d, 1) 19 tunes = d.getVar("TUNE_FEATURES")
20 if not tunes: 20 if not tunes:
21 return 21 return
22 pkgn = d.getVar("PN", d, 1) 22 pkgn = d.getVar("PN")
23 pkgv = d.getVar("PV", d, 1) 23 pkgv = d.getVar("PV")
24 if "callconvention-hard" not in tunes: 24 if "callconvention-hard" not in tunes:
25 bb.warn("%s-%s ONLY supports hardfp mode for now" % (pkgn, pkgv)) 25 bb.warn("%s-%s ONLY supports hardfp mode for now" % (pkgn, pkgv))
26 raise bb.parse.SkipPackage("%s-%s ONLY supports hardfp mode for now" % (pkgn, pkgv)) 26 raise bb.parse.SkipPackage("%s-%s ONLY supports hardfp mode for now" % (pkgn, pkgv))