diff options
author | Jacob Stiffler <j-stiffler@ti.com> | 2018-02-14 00:18:47 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2018-02-14 15:30:07 -0500 |
commit | b42044aaf51323d6948e6837884327b182ef9022 (patch) | |
tree | 6681e3f0ea71de13b5dc921e63f06cb8d5963f8e /recipes-ti/devtools | |
parent | a48d804cf710b99389962e3578e74f5a0e261be0 (diff) | |
download | meta-ti-b42044aaf51323d6948e6837884327b182ef9022.tar.gz |
ti-xdctools: do not create target package
* ti-xdctools is a host development package, but the target recipe is
needed to create the sourceipk used in SDKs.
* And move class extension to common include.
Signed-off-by: Jacob Stiffler <j-stiffler@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-ti/devtools')
-rw-r--r-- | recipes-ti/devtools/ti-xdctools-common.inc | 6 | ||||
-rw-r--r-- | recipes-ti/devtools/ti-xdctools_3.50.03.33.bb | 4 |
2 files changed, 5 insertions, 5 deletions
diff --git a/recipes-ti/devtools/ti-xdctools-common.inc b/recipes-ti/devtools/ti-xdctools-common.inc index 17166caf..d2d0df45 100644 --- a/recipes-ti/devtools/ti-xdctools-common.inc +++ b/recipes-ti/devtools/ti-xdctools-common.inc | |||
@@ -7,10 +7,14 @@ require recipes-ti/includes/ti-paths.inc | |||
7 | require recipes-ti/includes/ti-staging.inc | 7 | require recipes-ti/includes/ti-staging.inc |
8 | 8 | ||
9 | do_install() { | 9 | do_install() { |
10 | CP_ARGS="-Prf --preserve=mode,timestamps --no-preserve=ownership" | ||
11 | |||
10 | install -d ${D}${XDC_INSTALL_DIR_RECIPE} | 12 | install -d ${D}${XDC_INSTALL_DIR_RECIPE} |
11 | cp -pPrf ${S}/* ${D}${XDC_INSTALL_DIR_RECIPE} | 13 | cp ${CP_ARGS} ${S}/* ${D}${XDC_INSTALL_DIR_RECIPE} |
12 | } | 14 | } |
13 | 15 | ||
16 | BBCLASSEXTEND = "native nativesdk" | ||
17 | |||
14 | INHIBIT_PACKAGE_STRIP = "1" | 18 | INHIBIT_PACKAGE_STRIP = "1" |
15 | INHIBIT_SYSROOT_STRIP = "1" | 19 | INHIBIT_SYSROOT_STRIP = "1" |
16 | INHIBIT_PACKAGE_DEBUG_SPLIT = "1" | 20 | INHIBIT_PACKAGE_DEBUG_SPLIT = "1" |
diff --git a/recipes-ti/devtools/ti-xdctools_3.50.03.33.bb b/recipes-ti/devtools/ti-xdctools_3.50.03.33.bb index 6ab2b94a..73ab3bdf 100644 --- a/recipes-ti/devtools/ti-xdctools_3.50.03.33.bb +++ b/recipes-ti/devtools/ti-xdctools_3.50.03.33.bb | |||
@@ -7,7 +7,3 @@ LIC_FILES_CHKSUM = "file://docs/license/xdc/shelf/package.html;beginline=1;endli | |||
7 | 7 | ||
8 | SRC_URI[xdczip.md5sum] = "21310b647275a7c7dd5b37dcb96c0b1b" | 8 | SRC_URI[xdczip.md5sum] = "21310b647275a7c7dd5b37dcb96c0b1b" |
9 | SRC_URI[xdczip.sha256sum] = "afe8616773e63b01e79e8cfacaf4d2c8d3b92c798c7f8cf5d1c7b5fe2060bbe4" | 9 | SRC_URI[xdczip.sha256sum] = "afe8616773e63b01e79e8cfacaf4d2c8d3b92c798c7f8cf5d1c7b5fe2060bbe4" |
10 | |||
11 | FILES_${PN} += "${XDC_INSTALL_DIR_RECIPE}" | ||
12 | |||
13 | BBCLASSEXTEND = "native nativesdk" | ||