diff options
author | Ivan Pang <i-pang@ti.com> | 2017-08-01 11:45:04 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2017-08-22 16:04:24 -0400 |
commit | 62b190a82b899bccdd5f8a5f2af1d33739652708 (patch) | |
tree | c6e4b271a099b21d9c57d1d67ac7fcad1ba9b747 /recipes-ti/devtools | |
parent | 091ec70293eb595323bada40c58f5f2c8107387c (diff) | |
download | meta-ti-62b190a82b899bccdd5f8a5f2af1d33739652708.tar.gz |
ti-cgt6x-7: added recipe for TI CGT6x 7.x.x
This recipe specifically installs the 7.x.x series of TI CGT6x.
Signed-off-by: Ivan Pang <i-pang@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-ti/devtools')
-rw-r--r-- | recipes-ti/devtools/ti-cgt6x-7-native_7.4.16.bb | 41 |
1 files changed, 41 insertions, 0 deletions
diff --git a/recipes-ti/devtools/ti-cgt6x-7-native_7.4.16.bb b/recipes-ti/devtools/ti-cgt6x-7-native_7.4.16.bb new file mode 100644 index 00000000..7bb4c75e --- /dev/null +++ b/recipes-ti/devtools/ti-cgt6x-7-native_7.4.16.bb | |||
@@ -0,0 +1,41 @@ | |||
1 | SUMMARY = "TI DSP Code Generation Tools" | ||
2 | DESCRIPTION = "Texas Instrument (TI) Code Generation Tools are custom \ | ||
3 | utilities targeted for TI embedded processors. This Digital Signal \ | ||
4 | Processor (DSP) suite contains tools needed to create and debug \ | ||
5 | applications for the C6000 DSP family. This includes tools such as: \ | ||
6 | compiler, linker, assembler, etc. This also includes C runtime \ | ||
7 | libraries and standard header files needed to produce a working DSP application." | ||
8 | |||
9 | HOMEPAGE = "https://www-a.ti.com/downloads/sds_support/TICodegenerationTools/download.htm" | ||
10 | LICENSE = "TI-TSPA" | ||
11 | |||
12 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=b6311962635a4f15630e36ec2d875eca" | ||
13 | |||
14 | S = "${WORKDIR}/c6000_7.4.16" | ||
15 | |||
16 | inherit native | ||
17 | require recipes-ti/includes/ti-paths.inc | ||
18 | require recipes-ti/includes/ti-unpack.inc | ||
19 | |||
20 | BINFILE = "ti_cgt_c6000_7.4.16_linux_installer_x86.bin" | ||
21 | BINFILE_NAME = "cgt6x_7.4.16_x86_installer" | ||
22 | TI_BIN_UNPK_ARGS = "--prefix ${WORKDIR} --mode unattended" | ||
23 | TI_BIN_UNPK_CMDS="" | ||
24 | |||
25 | SRC_URI = "http://install.source.dir.local/${BINFILE};name=${BINFILE_NAME}" | ||
26 | |||
27 | SRC_URI[cgt6x_7.4.16_x86_installer.md5sum] = "21ca55c5b1f6b2d8d4fb7570d5eb5513" | ||
28 | SRC_URI[cgt6x_7.4.16_x86_installer.sha256sum] = "baa0d1ef20397383f99f45068a6d160963a01419d42fbbb851263b54c91df82f" | ||
29 | |||
30 | do_install() { | ||
31 | install -d ${D}/${TI_CGT6X_7_INSTALL_DIR_RECIPE} | ||
32 | cp -rP --preserve=mode,links,timestamps --no-preserve=ownership ${WORKDIR}/c6000_7.4.16/. ${D}/${TI_CGT6X_7_INSTALL_DIR_RECIPE} | ||
33 | } | ||
34 | |||
35 | FILES_${PN} += "${TI_CGT6X_7_INSTALL_DIR_RECIPE}" | ||
36 | |||
37 | INSANE_SKIP_${PN} += "arch staticdev" | ||
38 | |||
39 | INHIBIT_PACKAGE_STRIP = "1" | ||
40 | INHIBIT_SYSROOT_STRIP = "1" | ||
41 | INHIBIT_PACKAGE_DEBUG_SPLIT = "1" | ||