summaryrefslogtreecommitdiffstats
path: root/recipes-ti/devtools
diff options
context:
space:
mode:
authorJacob Stiffler <j-stiffler@ti.com>2015-10-24 01:56:46 +0000
committerDenys Dmytriyenko <denys@ti.com>2015-10-28 16:05:57 -0400
commit6a022be98ffc62b8908b60fcf1f16300eb2a0f84 (patch)
treed11cd6d7ca4a96a8b46944c0f48b41564a64b166 /recipes-ti/devtools
parent51f0cdc888ad5725b08e5d623b39309029f85c3e (diff)
downloadmeta-ti-6a022be98ffc62b8908b60fcf1f16300eb2a0f84.tar.gz
gcc-arm-none-eabi-native: Add GCC baremetal toolchain
Signed-off-by: Jacob Stiffler <j-stiffler@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-ti/devtools')
-rw-r--r--recipes-ti/devtools/gcc-arm-none-eabi-native_4.8.2014q3.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes-ti/devtools/gcc-arm-none-eabi-native_4.8.2014q3.bb b/recipes-ti/devtools/gcc-arm-none-eabi-native_4.8.2014q3.bb
new file mode 100644
index 00000000..971ae489
--- /dev/null
+++ b/recipes-ti/devtools/gcc-arm-none-eabi-native_4.8.2014q3.bb
@@ -0,0 +1,21 @@
1DESCRIPTION = "Baremetal GCC for ARM"
2LICENSE = "GPL-3.0-with-GCC-exception & GPLv3"
3
4LIC_FILES_CHKSUM = "file://share/doc/gcc-arm-none-eabi/license.txt;md5=cba77c7fde3ed13e866b04a2f3d93918"
5
6inherit native
7require recipes-ti/includes/ti-paths.inc
8
9SRC_URI = "https://launchpad.net/gcc-arm-embedded/4.8/4.8-2014-q3-update/+download/gcc-arm-none-eabi-4_8-2014q3-20140805-linux.tar.bz2;name=gcc-arm-none"
10
11SRC_URI[gcc-arm-none.md5sum] = "acc8c8ff45f8801e2155934214309a87"
12SRC_URI[gcc-arm-none.sha256sum] = "e33d7546de1e02844239c72b3ef5563f472fcd6b4637419d513770ae13f551c0"
13
14S = "${WORKDIR}/gcc-arm-none-eabi-4_8-2014q3"
15
16do_install() {
17 install -d ${D}${GCC_ARM_NONE_TOOLCHAIN_RECIPE}
18 cp -r ${S}/. ${D}${GCC_ARM_NONE_TOOLCHAIN_RECIPE}
19}
20
21FILES_${PN} = "${GCC_ARM_NONE_TOOLCHAIN_RECIPE}/*"