summaryrefslogtreecommitdiffstats
path: root/recipes-ti/devtools
diff options
context:
space:
mode:
authorJacob Stiffler <j-stiffler@ti.com>2015-10-22 20:49:39 +0000
committerDenys Dmytriyenko <denys@ti.com>2015-10-22 13:00:08 -0400
commitffeefcb8e537d7f26eca186866075667bfac9fa7 (patch)
tree707e62b40c5428c48a04f5d97dbffe2c07ae4df8 /recipes-ti/devtools
parent5ae46649cd82a7c05695a089642eeb51f583627a (diff)
downloadmeta-ti-ffeefcb8e537d7f26eca186866075667bfac9fa7.tar.gz
ti-ccsv6-native: Add CCS 6.1.1.00022
* Due to licensing, this installer must be downloaded manually and placed into either the downloads directory, or placed on a mirror. * Please see http://processors.wiki.ti.com/index.php/Download_CCS#Code_Composer_Studio_Version_6_Downloads * NOTE: That the Linux off-line installation tarball is the file required. Signed-off-by: Jacob Stiffler <j-stiffler@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-ti/devtools')
-rw-r--r--recipes-ti/devtools/ti-ccsv6-native_6.1.1.00022.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/recipes-ti/devtools/ti-ccsv6-native_6.1.1.00022.bb b/recipes-ti/devtools/ti-ccsv6-native_6.1.1.00022.bb
new file mode 100644
index 00000000..c5a4f333
--- /dev/null
+++ b/recipes-ti/devtools/ti-ccsv6-native_6.1.1.00022.bb
@@ -0,0 +1,42 @@
1DESCRIPTION = "TI DSP Code Generation Tools"
2HOMEPAGE = "http://processors.wiki.ti.com/index.php/Download_CCS#Code_Composer_Studio_Version_6_Downloads"
3LICENSE = "(TI-TSPA & Thai-Open-Source-Software-Center) & BSD-3-Clause & BSL-1.0 & Hewlett-Packard & AFL-3.0 & MIT & BSD-2-Clause & PD"
4
5LIC_FILES_CHKSUM = "file://${WORKDIR}/ccsv6/doc/EULA/EULA.doc;md5=24fb8a52ac52d3938b5888362edb295a"
6
7inherit native
8
9require recipes-ti/includes/ti-unpack.inc
10require recipes-ti/includes/ti-staging.inc
11require recipes-ti/includes/ti-paths.inc
12
13TI_CGT_ARM_VERSION = "5.2.5"
14
15SRC_URI = "http://install.source.dir.local/CCS${PV}_linux.tar.gz;name=ccsv6"
16
17S = "${WORKDIR}/CCS${PV}_linux"
18
19BINFILE = "CCS${PV}_linux/ccs_setup_${PV}.bin"
20TI_BIN_UNPK_ARGS = "--mode unattended --prefix ${WORKDIR}"
21TI_BIN_UNPK_CMDS = ""
22
23SRC_URI[ccsv6.md5sum] = "648d5f41e8a7a93c16d51cd34045ba15"
24SRC_URI[ccsv6.sha256sum] = "b82958a125d5c6bea07cfc12a6f2a77c45e1560217c1aac02194b6e3408c5105"
25
26do_install() {
27 install -d ${D}${CCSV6_INSTALL_DIR_RECIPE}
28 cp -r ${WORKDIR}/ccsv6/. ${D}${CCSV6_INSTALL_DIR_RECIPE}
29
30 install -d ${D}${M4_TOOLCHAIN_INSTALL_DIR_RECIPE}
31 cp -r ${WORKDIR}/ccsv6/tools/compiler/ti-cgt-arm_${TI_CGT_ARM_VERSION}/. \
32 ${D}${M4_TOOLCHAIN_INSTALL_DIR_RECIPE}
33}
34
35FILES_${PN} += "\
36 ${CCSV6_INSTALL_DIR_RECIPE} \
37 ${M4_TOOLCHAIN_INSTALL_DIR_RECIPE} \
38"
39
40INSANE_SKIP_${PN} = "arch libdir ldflags staticdev textrel dev-so"
41
42EXCLUDE_FROM_SHLIBS = "1"