summaryrefslogtreecommitdiffstats
path: root/recipes-ti/devtools
diff options
context:
space:
mode:
authorJacob Stiffler <j-stiffler@ti.com>2016-01-27 03:16:40 +0000
committerDenys Dmytriyenko <denys@ti.com>2016-01-27 15:53:45 -0500
commit183b1828ed831a9e3d0f817a513cfbcc33186a0d (patch)
treeabb3c9a8833a8d67a5f20c4f989793d42f4b2684 /recipes-ti/devtools
parent5437ef8b7a2babc5246fcec8b9f2f272e0de973b (diff)
downloadmeta-ti-183b1828ed831a9e3d0f817a513cfbcc33186a0d.tar.gz
ti-cg-xml: Add version 2.41.00
Signed-off-by: Jacob Stiffler <j-stiffler@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-ti/devtools')
-rw-r--r--recipes-ti/devtools/ti-cg-xml_2.41.00.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/recipes-ti/devtools/ti-cg-xml_2.41.00.bb b/recipes-ti/devtools/ti-cg-xml_2.41.00.bb
new file mode 100644
index 00000000..115254eb
--- /dev/null
+++ b/recipes-ti/devtools/ti-cg-xml_2.41.00.bb
@@ -0,0 +1,36 @@
1DESCRIPTION = "TI CG_XML"
2HOMEPAGE = "http://software-dl.ti.com/ccs/non-esd/releases/other/applications_packages/cg_xml/index.htm"
3SECTION = "devel"
4LICENSE = "BSD"
5
6require recipes-ti/includes/ti-paths.inc
7require recipes-ti/includes/ti-staging.inc
8require recipes-ti/includes/ti-unpack.inc
9
10PV = "2_41_00"
11
12S = "${WORKDIR}/cg_xml_${PV}"
13
14SRC_URI = "\
15 http://software-dl.ti.com/ccs/non-esd/releases/other/applications_packages/cg_xml/cg_xml_v${PV}/cg_xml-v${PV}-Linux-x86-Install;name=cgxmlbin_linux \
16"
17
18LIC_FILES_CHKSUM = "file://cg_xml_${PV}_Manifest.pdf;md5=ba23d76ef3d5ec111b03267105c91bd4"
19
20SRC_URI[cgxmlbin_linux.md5sum] = "9e421f25f6da455b0155570ce0e62628"
21SRC_URI[cgxmlbin_linux.sha256sum] = "bbc25f4abe27a8b93bae1d8581c3dee87111c3769c305d086287038ee9038cbf"
22
23BINFILE="cg_xml-v${PV}-Linux-x86-Install"
24TI_BIN_UNPK_CMDS=""
25TI_BIN_UNPK_ARGS="--prefix ${S} --mode silent"
26
27do_install() {
28 install -d ${D}${CG_XML_INSTALL_DIR_RECIPE}
29 cp -pPrf ${S}/* ${D}${CG_XML_INSTALL_DIR_RECIPE}
30}
31
32FILES_${PN} += "${CG_XML_INSTALL_DIR_RECIPE}"
33
34INSANE_SKIP_${PN} = "arch ldflags"
35
36BBCLASSEXTEND = "native nativesdk"