diff options
author | Koen Kooi <koen@dominion.thruhere.net> | 2011-03-14 19:10:15 +0100 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2011-03-14 19:10:15 +0100 |
commit | c1af7e34f0f780e7fdd93a529445fedb3057c5f3 (patch) | |
tree | 5c5d1a77cd2d492cbce4f2bf7823bf02b3764474 /recipes-ti/devtools | |
parent | 4884692d7f6b9cc76ab3535fc0790a148b1137f6 (diff) | |
download | meta-ti-c1af7e34f0f780e7fdd93a529445fedb3057c5f3.tar.gz |
recipes-ti: initial check in of dsplink stack
* the focus was on to get it to build, not to make the recipes perfect
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'recipes-ti/devtools')
-rw-r--r-- | recipes-ti/devtools/ti-cgt6x.inc | 26 | ||||
-rw-r--r-- | recipes-ti/devtools/ti-cgt6x_6.1.17.bb | 9 | ||||
-rw-r--r-- | recipes-ti/devtools/ti-xdctools.inc | 65 | ||||
-rw-r--r-- | recipes-ti/devtools/ti-xdctools/arm-linker-hack.diff | 19 | ||||
-rw-r--r-- | recipes-ti/devtools/ti-xdctools_3.20.03.63.bb | 7 | ||||
-rw-r--r-- | recipes-ti/devtools/ti-xdctools_3.20.06.81.bb | 12 |
6 files changed, 138 insertions, 0 deletions
diff --git a/recipes-ti/devtools/ti-cgt6x.inc b/recipes-ti/devtools/ti-cgt6x.inc new file mode 100644 index 00000000..c9c3fda4 --- /dev/null +++ b/recipes-ti/devtools/ti-cgt6x.inc | |||
@@ -0,0 +1,26 @@ | |||
1 | DESCRIPTION = "TI DSP Code Generation Tools" | ||
2 | HOMEPAGE = "https://www-a.ti.com/downloads/sds_support/TICodegenerationTools/download.htm" | ||
3 | SECTION = "devel" | ||
4 | LICENSE = "TI" | ||
5 | |||
6 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=712a8c64bb70c5ea5fa193faef3bed6f" | ||
7 | |||
8 | require ../includes/ti-paths.inc | ||
9 | require ../includes/ti-staging.inc | ||
10 | require ../includes/ti-eula-unpack.inc | ||
11 | |||
12 | PR = "r4" | ||
13 | |||
14 | S = "${WORKDIR}/cgt6x_${PV}" | ||
15 | |||
16 | SRC_URI = "http://install.source.dir.local/ti_cgt_c6000_${PVwithdots}_setup_linux_x86.bin;name=cgt6xbin" | ||
17 | |||
18 | BINFILE="ti_cgt_c6000_${PVwithdots}_setup_linux_x86.bin" | ||
19 | TI_BIN_UNPK_CMDS="Y:qY:workdir: : " | ||
20 | TI_BIN_UNPK_WDEXT="/cgt6x_${PV}" | ||
21 | |||
22 | do_install() { | ||
23 | install -d ${D}${CODEGEN_INSTALL_DIR_RECIPE} | ||
24 | cp -pPrf ${S}/* ${D}${CODEGEN_INSTALL_DIR_RECIPE} | ||
25 | } | ||
26 | |||
diff --git a/recipes-ti/devtools/ti-cgt6x_6.1.17.bb b/recipes-ti/devtools/ti-cgt6x_6.1.17.bb new file mode 100644 index 00000000..7798d400 --- /dev/null +++ b/recipes-ti/devtools/ti-cgt6x_6.1.17.bb | |||
@@ -0,0 +1,9 @@ | |||
1 | require ti-cgt6x.inc | ||
2 | |||
3 | PE = "1" | ||
4 | PV = "6_1_17" | ||
5 | PVwithdots = "6.1.17" | ||
6 | |||
7 | SRC_URI[cgt6xbin.md5sum] = "41ee41cc74800b06705804f7ef901447" | ||
8 | SRC_URI[cgt6xbin.sha256sum] = "7e1c8b67420abf6f2f44786811d0a2b5692e76194743bed714ec9087cc1a75c7" | ||
9 | |||
diff --git a/recipes-ti/devtools/ti-xdctools.inc b/recipes-ti/devtools/ti-xdctools.inc new file mode 100644 index 00000000..d462d9f0 --- /dev/null +++ b/recipes-ti/devtools/ti-xdctools.inc | |||
@@ -0,0 +1,65 @@ | |||
1 | DESCRIPTION = "TI XDCtools (RTSC - Real Time Software Components - http://rtsc.eclipse.org)" | ||
2 | HOMEPAGE = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/rtsc" | ||
3 | SECTION = "devel" | ||
4 | LICENSE = "BSD, GPLv2" | ||
5 | |||
6 | LIC_FILES_CHKSUM = "file://docs/license/xdc/shelf/package.html;md5=fd6d0bfcac476bd22c1f1525a91c9807" | ||
7 | |||
8 | PR = "r2" | ||
9 | |||
10 | require ../includes/ti-paths.inc | ||
11 | require ../includes/ti-staging.inc | ||
12 | require ../includes/ti-eula-unpack.inc | ||
13 | |||
14 | S = "${WORKDIR}/xdctools_${PV}" | ||
15 | |||
16 | SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/rtsc/${PV}/exports/xdctools_setuplinux_${PV}.bin;name=xdcbin" | ||
17 | |||
18 | BINFILE="xdctools_setuplinux_${PV}.bin" | ||
19 | TI_BIN_UNPK_CMDS="Y: qY:workdir:Y" | ||
20 | |||
21 | do_install() { | ||
22 | install -d ${D}${XDC_INSTALL_DIR_RECIPE} | ||
23 | cp -pPrf ${S}/* ${D}${XDC_INSTALL_DIR_RECIPE} | ||
24 | } | ||
25 | |||
26 | # Prevent internal libs from getting picked up | ||
27 | PRIVATE_LIBS = " \ | ||
28 | libncdb.so \ | ||
29 | libcdb.so \ | ||
30 | libjavaplugin_oji.so \ | ||
31 | libjavaplugin_jni.so \ | ||
32 | libjsound.so \ | ||
33 | libinstrument.so \ | ||
34 | libjawt.so \ | ||
35 | libzip.so \ | ||
36 | libjava_crw_demo.so \ | ||
37 | libjavaplugin_nscp_gcc29.so \ | ||
38 | libhprof.so \ | ||
39 | libcmm.so \ | ||
40 | libjdwp.so \ | ||
41 | libmlib_image.so \ | ||
42 | libjpeg.so \ | ||
43 | libverify.so \ | ||
44 | libjavaplugin_nscp.so \ | ||
45 | libmanagement.so \ | ||
46 | libunpack.so \ | ||
47 | librmi.so \ | ||
48 | libJdbcOdbc.so \ | ||
49 | libawt.so \ | ||
50 | libnet.so \ | ||
51 | libjaas_unix.so \ | ||
52 | libnio.so \ | ||
53 | libdcpr.so \ | ||
54 | libioser12.so \ | ||
55 | libjsoundalsa.so \ | ||
56 | libjava.so \ | ||
57 | libfontmanager.so \ | ||
58 | libdt_socket.so \ | ||
59 | libmawt.so \ | ||
60 | libjvm.so \ | ||
61 | libhpi.so \ | ||
62 | lib.so \ | ||
63 | libcairo.so.2 \ | ||
64 | " | ||
65 | |||
diff --git a/recipes-ti/devtools/ti-xdctools/arm-linker-hack.diff b/recipes-ti/devtools/ti-xdctools/arm-linker-hack.diff new file mode 100644 index 00000000..26debf8f --- /dev/null +++ b/recipes-ti/devtools/ti-xdctools/arm-linker-hack.diff | |||
@@ -0,0 +1,19 @@ | |||
1 | --- a/packages/gnu/targets/arm/linkcmd.xdt 2010-12-30 19:33:53.000000000 +0100 | ||
2 | +++ b/packages/gnu/targets/arm/linkcmd.xdt 2010-12-30 19:42:55.000000000 +0100 | ||
3 | @@ -40,12 +40,13 @@ | ||
4 | |||
5 | %if ("BINVERS" in prog.build.target) { | ||
6 | % var _utils = xdc.loadCapsule("gnu/targets/linkUtils.xs"); | ||
7 | +% if (prog.build.target.GCCVERS < "4.3.3") { | ||
8 | SECTIONS { | ||
9 | `_utils.genSections(prog)` | ||
10 | } | ||
11 | - | ||
12 | -% if (!prog.build.target.noStdLinkScript | ||
13 | -% && prog.build.target.BINVERS >= "2.19") { | ||
14 | +% } | ||
15 | +% if (prog.build.target.noStdLinkScript | ||
16 | +% && prog.build.target.BINVERS >= "2.19") { | ||
17 | INSERT BEFORE .gnu.attributes | ||
18 | % } | ||
19 | |||
diff --git a/recipes-ti/devtools/ti-xdctools_3.20.03.63.bb b/recipes-ti/devtools/ti-xdctools_3.20.03.63.bb new file mode 100644 index 00000000..a743a6d3 --- /dev/null +++ b/recipes-ti/devtools/ti-xdctools_3.20.03.63.bb | |||
@@ -0,0 +1,7 @@ | |||
1 | require ti-xdctools.inc | ||
2 | |||
3 | PV = "3_20_03_63" | ||
4 | |||
5 | SRC_URI[xdcbin.md5sum] = "ef3e7ab06dca1d346731d87a6525d2a7" | ||
6 | SRC_URI[xdcbin.sha256sum] = "da5df132c96c8d73c6ca1e03dcd3b854a1850e3abab04749d858d6fbb9111e0f" | ||
7 | |||
diff --git a/recipes-ti/devtools/ti-xdctools_3.20.06.81.bb b/recipes-ti/devtools/ti-xdctools_3.20.06.81.bb new file mode 100644 index 00000000..110ee356 --- /dev/null +++ b/recipes-ti/devtools/ti-xdctools_3.20.06.81.bb | |||
@@ -0,0 +1,12 @@ | |||
1 | require ti-xdctools.inc | ||
2 | |||
3 | PV = "3_20_06_81" | ||
4 | |||
5 | # This fixes c6accel, but breaks codec-engine and lpm | ||
6 | #SRC_URI += "file://arm-linker-hack.diff" | ||
7 | |||
8 | SRC_URI[xdcbin.md5sum] = "65151268d6be6ad6eb940ef7ed03af16" | ||
9 | SRC_URI[xdcbin.sha256sum] = "8ea6b851521ce41fe0b4a349b2d922af7e70f48c50ad9fd21f62627446a834f8" | ||
10 | |||
11 | |||
12 | |||