summaryrefslogtreecommitdiffstats
path: root/recipes-ti/devtools/ti-cgt6x_8.3.2.bb
diff options
context:
space:
mode:
authorMahesh Radhakrishnan <m-radhakrishnan2@ti.com>2019-03-14 09:18:07 +0000
committerDenys Dmytriyenko <denys@ti.com>2019-03-19 02:46:00 +0000
commitdde59d16ec5969ff69c41c2ca2c11f1ebb3bc983 (patch)
tree713c0e0ddf9d8968aac63f876a6a693361647842 /recipes-ti/devtools/ti-cgt6x_8.3.2.bb
parent8c3b1bd943a19e05d69b709364ed4b811f8a3f2f (diff)
downloadmeta-ti-dde59d16ec5969ff69c41c2ca2c11f1ebb3bc983.tar.gz
ti-cgt6x: Update to version 8.3.2
The license checksum changed due to the version and also because Hewlett Packard license is no longer applicable. The Patrick Powell license which was present earlier too was not mentioned in the recipe, now it has been explicitly mentioned as well. Signed-off-by: Mahesh Radhakrishnan <m-radhakrishnan2@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-ti/devtools/ti-cgt6x_8.3.2.bb')
-rw-r--r--recipes-ti/devtools/ti-cgt6x_8.3.2.bb104
1 files changed, 104 insertions, 0 deletions
diff --git a/recipes-ti/devtools/ti-cgt6x_8.3.2.bb b/recipes-ti/devtools/ti-cgt6x_8.3.2.bb
new file mode 100644
index 00000000..deee61c7
--- /dev/null
+++ b/recipes-ti/devtools/ti-cgt6x_8.3.2.bb
@@ -0,0 +1,104 @@
1DESCRIPTION = "TI DSP Code Generation Tools"
2HOMEPAGE = "https://www-a.ti.com/downloads/sds_support/TICodegenerationTools/download.htm"
3LICENSE = "(TI-TSPA & Thai-Open-Source-Software-Center) & BSD-3-Clause & BSL-1.0 & Patrick-Powell & AFL-3.0 & MIT & BSD-2-Clause & PD"
4
5LIC_FILES_CHKSUM = "file://ti-cgt-c6000_${PV}/C6000CodeGenerationTools_8.3.x_manifest.html;md5=d06c6f9acebf78df4108a8535396e9f1"
6LIC_FILES_CHKSUM_class-target = "file://usr/share/doc/ti/cgt-c6x/C6000CodeGenerationTools_8.3.x_manifest.html;md5=d06c6f9acebf78df4108a8535396e9f1"
7
8PE = "1"
9
10require recipes-ti/includes/ti-unpack.inc
11
12COMPATIBLE_HOST_class-target = "arm.*-linux"
13
14# For now we only have hardfp version for target class
15python __anonymous() {
16 c = d.getVar("CLASSOVERRIDE")
17
18 if c == "class-target":
19 tunes = d.getVar("TUNE_FEATURES")
20 if not tunes:
21 return
22 pkgn = d.getVar("PN")
23 pkgv = d.getVar("PV")
24 if "callconvention-hard" not in tunes:
25 bb.warn("%s-%s ONLY supports hardfp mode for now" % (pkgn, pkgv))
26 raise bb.parse.SkipPackage("%s-%s ONLY supports hardfp mode for now" % (pkgn, pkgv))
27}
28
29BINFILE = "ti_cgt_c6000_${PV}_linux_installer_x86.bin"
30BINFILE_NAME = "cgt6x_x86_installer"
31TI_BIN_UNPK_ARGS = "--prefix ${S}"
32TI_BIN_UNPK_CMDS = ""
33
34BINFILE_class-target = "ti_cgt_c6000_${PV}_armlinuxa8hf_busybox_installer.sh"
35BINFILE_NAME_class-target = "cgt6x_arm_installer"
36
37SRC_URI = "http://software-dl.ti.com/codegen/esd/cgt_public_sw/C6000/${PV}/${BINFILE};name=${BINFILE_NAME}"
38
39SRC_URI[cgt6x_x86_installer.md5sum] = "f1f534e6a4bdee6df39e8d0cb458d161"
40SRC_URI[cgt6x_x86_installer.sha256sum] = "1fba2a8f5532b33a23677771d686a866171ce7a0e567fed50d900d0ecd2e17e6"
41
42SRC_URI[cgt6x_arm_installer.md5sum] = "425d82308e71202ad004a36b7ec3cec9"
43SRC_URI[cgt6x_arm_installer.sha256sum] = "70c387ddde379194fed712087be6cb0ca5f4f0e65d7f29bd7462c38ee011928f"
44
45do_install() {
46 install -d ${D}${bindir}
47 for binfile in ${S}/ti-cgt-c6000_${PV}/bin/*; do
48 install -m 755 ${binfile} ${D}${bindir}
49 done
50
51 install -d ${D}${datadir}/ti/cgt-c6x/bin
52 for binfile in ${S}/ti-cgt-c6000_${PV}/bin/*; do
53 install -m 755 ${binfile} ${D}${datadir}/ti/cgt-c6x/bin
54 done
55
56 CP_ARGS="-Prf --preserve=mode,timestamps --no-preserve=ownership"
57 cp ${CP_ARGS} ${S}/ti-cgt-c6000_${PV}/include ${D}${datadir}/ti/cgt-c6x/include
58
59 install -d ${D}${datadir}/ti/cgt-c6x/lib
60 for libfile in ${S}/ti-cgt-c6000_${PV}/lib/*.a; do
61 install -m 644 ${libfile} ${D}${datadir}/ti/cgt-c6x/lib
62 done
63
64 for libfile in ${S}/ti-cgt-c6000_${PV}/lib/*.cmd; do
65 install -m 644 ${libfile} ${D}${datadir}/ti/cgt-c6x/lib
66 done
67
68 for libfile in ${S}/ti-cgt-c6000_${PV}/lib/*.lib; do
69 install -m 644 ${libfile} ${D}${datadir}/ti/cgt-c6x/lib
70 done
71
72 install -d ${D}${datadir}/man/man1
73 for manfile in ${S}/ti-cgt-c6000_${PV}/man/man1/*; do
74 if [ -e ${manfile} ]; then
75 install -m 644 ${manfile} ${D}${datadir}/man/man1
76 fi
77 done
78
79 install -d ${D}${datadir}/doc/ti/cgt-c6x
80 for docfile in ${S}/ti-cgt-c6000_${PV}/*.txt; do
81 install -m 644 ${docfile} ${D}${datadir}/doc/ti/cgt-c6x
82 done
83
84 for docfile in ${S}/ti-cgt-c6000_${PV}/*.html; do
85 install -m 644 ${docfile} ${D}${datadir}/doc/ti/cgt-c6x
86 done
87
88 for docfile in ${S}/ti-cgt-c6000_${PV}/*.spdx; do
89 install -m 644 ${docfile} ${D}${datadir}/doc/ti/cgt-c6x
90 done
91
92}
93
94do_install_class-target() {
95 ${WORKDIR}/${BINFILE} --prefix ${D}
96}
97
98FILES_${PN} += "${datadir}/ti/*"
99
100FILES_${PN}-dbg += "${datadir}/ti/cgt-c6x/bin/.debug"
101
102INSANE_SKIP_${PN} += "staticdev"
103
104BBCLASSEXTEND = "native nativesdk"