diff options
author | Jacob Stiffler <j-stiffler@ti.com> | 2019-07-29 23:37:27 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2019-07-31 22:07:50 +0000 |
commit | e7bf456f6b2cdc5c8a5cf7c59773c4266d1c4dcd (patch) | |
tree | bcf718d2cae11fd1e514c5f2bd25888ae804d402 /recipes-ti/devtools/ti-cgt-arm_18.12.1.bb | |
parent | 6c29b2c924959d61c4a53bcb05a18091a1f78777 (diff) | |
download | meta-ti-e7bf456f6b2cdc5c8a5cf7c59773c4266d1c4dcd.tar.gz |
ti-cgt-arm: extend to nativesdk
Signed-off-by: Jacob Stiffler <j-stiffler@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-ti/devtools/ti-cgt-arm_18.12.1.bb')
-rw-r--r-- | recipes-ti/devtools/ti-cgt-arm_18.12.1.bb | 43 |
1 files changed, 43 insertions, 0 deletions
diff --git a/recipes-ti/devtools/ti-cgt-arm_18.12.1.bb b/recipes-ti/devtools/ti-cgt-arm_18.12.1.bb new file mode 100644 index 00000000..eecde58f --- /dev/null +++ b/recipes-ti/devtools/ti-cgt-arm_18.12.1.bb | |||
@@ -0,0 +1,43 @@ | |||
1 | SUMMARY = "TI ARM Code Generation Tools" | ||
2 | HOMEPAGE = "https://www-a.ti.com/downloads/sds_support/TICodegenerationTools/download.htm" | ||
3 | LICENSE = "(TI-TSPA & Thai-Open-Source-Software-Center) & BSD-3-Clause & BSL-1.0 & Hewlett-Packard & Patrick-Powell & AFL-3.0 & MIT & BSD-2-Clause & PD & BSD-4-Clause" | ||
4 | |||
5 | LIC_FILES_CHKSUM = "file://ti-cgt-arm_${PV}.LTS/README.txt;md5=ab7a61241e90fcd144a756d88294cf30" | ||
6 | |||
7 | require recipes-ti/includes/ti-unpack.inc | ||
8 | require recipes-ti/includes/ti-staging.inc | ||
9 | require recipes-ti/includes/ti-paths.inc | ||
10 | |||
11 | S = "${WORKDIR}/ti-cgt-arm-${PV}" | ||
12 | |||
13 | PR = "r0" | ||
14 | |||
15 | SRC_URI = "http://software-dl.ti.com/codegen/esd/cgt_public_sw/TMS470/${PV}.LTS/${BINFILE};name=${BINFILE_NAME}" | ||
16 | |||
17 | BINFILE = "ti_cgt_tms470_${PV}.LTS_linux_installer_x86.bin" | ||
18 | TI_BIN_UNPK_ARGS = "--prefix ${S}" | ||
19 | TI_BIN_UNPK_CMDS = "" | ||
20 | |||
21 | # only x86_64 is supported | ||
22 | COMPATIBLE_HOST = "x86_64.*-linux" | ||
23 | COMPATIBLE_HOST_class-target = "null" | ||
24 | |||
25 | do_install() { | ||
26 | install -d ${D}${M4_TOOLCHAIN_INSTALL_DIR_RECIPE} | ||
27 | cp -r ${S}/ti-cgt-arm*/. ${D}${M4_TOOLCHAIN_INSTALL_DIR_RECIPE} | ||
28 | } | ||
29 | |||
30 | SRC_URI[cgt_arm_installer.md5sum] = "af2378cf8d5d6f200ef3329f5a065529" | ||
31 | SRC_URI[cgt_arm_installer.sha256sum] = "d90ae2360cd5b22912715ae7898d99352da1b97fd655f9a55d0d19a2a46bab0e" | ||
32 | |||
33 | BINFILE_NAME = "cgt_arm_installer" | ||
34 | |||
35 | FILES_${PN} += "${M4_TOOLCHAIN_INSTALL_DIR_RECIPE}" | ||
36 | |||
37 | INHIBIT_PACKAGE_STRIP = "1" | ||
38 | INHIBIT_SYSROOT_STRIP = "1" | ||
39 | INHIBIT_PACKAGE_DEBUG_SPLIT = "1" | ||
40 | |||
41 | INSANE_SKIP_${PN} += "arch staticdev" | ||
42 | |||
43 | BBCLASSEXTEND = "native nativesdk" | ||