summaryrefslogtreecommitdiffstats
path: root/recipes-ti/devtools/gcc-linaro-baremetal-native.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2020-08-24 23:30:42 +0000
committerDenys Dmytriyenko <denys@ti.com>2020-08-25 17:58:03 +0000
commitb80306b74c1450c54bb94f0cb8928a78079d95dd (patch)
tree5d639a172008cd8d0a5c419d886f63d051e76cee /recipes-ti/devtools/gcc-linaro-baremetal-native.bb
parent9f29dab2e7c652cccdc233262c4818fdcc704ca3 (diff)
downloadmeta-ti-b80306b74c1450c54bb94f0cb8928a78079d95dd.tar.gz
Revert "gcc-arm, gcc-aarch64: upgrade baremetal gcc compilers to 9.2-2019.12"
This reverts commit 3a657f7d350149dc277e735d96ef2d66360a3ac3. Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-ti/devtools/gcc-linaro-baremetal-native.bb')
-rw-r--r--recipes-ti/devtools/gcc-linaro-baremetal-native.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes-ti/devtools/gcc-linaro-baremetal-native.bb b/recipes-ti/devtools/gcc-linaro-baremetal-native.bb
new file mode 100644
index 00000000..0268ae3d
--- /dev/null
+++ b/recipes-ti/devtools/gcc-linaro-baremetal-native.bb
@@ -0,0 +1,23 @@
1include recipes-ti/devtools/gcc-linaro.inc
2
3PACKAGE_DIR = "gcc-linaro-${PV}-${GCC_ARM_YEAR}-x86_64_arm-eabi"
4S = "${WORKDIR}/${PACKAGE_DIR}"
5
6LIC_CHKSUM = "bc7fad4bba98e7a4cd5ab3042506493c"
7
8inherit native
9require recipes-ti/includes/ti-paths.inc
10
11SRC_URI = "https://releases.linaro.org/components/toolchain/binaries/7.2-${GCC_ARM_YEAR}/arm-eabi/gcc-linaro-${PV}-${GCC_ARM_YEAR}-x86_64_arm-eabi.tar.xz;name=gcc-linaro"
12
13SRC_URI[gcc-linaro.md5sum] = "9a4a39cfc78c84375b1160aa93587aed"
14SRC_URI[gcc-linaro.sha256sum] = "45fc4f90af2e2e9c3197a275f6005ef5639f7a1889fa3eb24c3125ccd70fcd3d"
15
16do_install() {
17 install -d ${D}${GCC_LINARO_BAREMETAL_TOOLCHAIN_RECIPE}
18 cp -r ${S}/. ${D}${GCC_LINARO_BAREMETAL_TOOLCHAIN_RECIPE}
19}
20
21FILES_${PN} = "${GCC_LINARO_BAREMETAL_TOOLCHAIN_RECIPE}/*"
22
23INSANE_SKIP_${PN} = "already-stripped"