summaryrefslogtreecommitdiffstats
path: root/recipes-ti/codec-engine
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2016-12-21 04:35:22 +0000
committerDenys Dmytriyenko <denys@ti.com>2016-12-21 13:23:11 -0500
commit16a794009702db32c6c6570cda656e9732858573 (patch)
tree39253c90744975ce21eee84491f18ef185118e9a /recipes-ti/codec-engine
parentd8827afedc66b610f1fc9c5990bc4271917643b6 (diff)
downloadmeta-ti-16a794009702db32c6c6570cda656e9732858573.tar.gz
remaining recipes: fix build issue due to bb.data.* deprecation
Causes following error: Exception: AttributeError: module 'bb.data' has no attribute 'getVar' Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-ti/codec-engine')
-rw-r--r--recipes-ti/codec-engine/ti-codecs-omap3530_4.00.00.00.bb46
1 files changed, 23 insertions, 23 deletions
diff --git a/recipes-ti/codec-engine/ti-codecs-omap3530_4.00.00.00.bb b/recipes-ti/codec-engine/ti-codecs-omap3530_4.00.00.00.bb
index 5c87b4cd..633e0985 100644
--- a/recipes-ti/codec-engine/ti-codecs-omap3530_4.00.00.00.bb
+++ b/recipes-ti/codec-engine/ti-codecs-omap3530_4.00.00.00.bb
@@ -76,49 +76,49 @@ DSPSUFFIX_omap3530 = "x64P"
76python do_unpack () { 76python do_unpack () {
77 bb.build.exec_func('base_do_unpack', d) 77 bb.build.exec_func('base_do_unpack', d)
78 78
79 bb.data.setVar("BINFILE", "omap3530_h264enc_2_01_013_production.bin", d) 79 d.setVar("BINFILE", "omap3530_h264enc_2_01_013_production.bin", d)
80 bb.data.setVar("TARFILE", "omap3530_h264enc_2_01_013_production.tar", d) 80 d.setVar("TARFILE", "omap3530_h264enc_2_01_013_production.tar", d)
81 bb.build.exec_func('ti_bin_do_unpack', d) 81 bb.build.exec_func('ti_bin_do_unpack', d)
82 82
83 bb.data.setVar("BINFILE", "omap3530_h264dec_2_01_007_production.bin", d) 83 d.setVar("BINFILE", "omap3530_h264dec_2_01_007_production.bin", d)
84 bb.data.setVar("TARFILE", "omap3530_h264dec_2_01_007_production.tar", d) 84 d.setVar("TARFILE", "omap3530_h264dec_2_01_007_production.tar", d)
85 bb.build.exec_func('ti_bin_do_unpack', d) 85 bb.build.exec_func('ti_bin_do_unpack', d)
86 86
87 bb.data.setVar("BINFILE", "omap3530_jpegenc_02_01_01_00_production.bin", d) 87 d.setVar("BINFILE", "omap3530_jpegenc_02_01_01_00_production.bin", d)
88 bb.data.setVar("TARFILE", "omap3530_jpegenc_02_01_01_00_production.tar", d) 88 d.setVar("TARFILE", "omap3530_jpegenc_02_01_01_00_production.tar", d)
89 bb.build.exec_func('ti_bin_do_unpack', d) 89 bb.build.exec_func('ti_bin_do_unpack', d)
90 90
91 bb.data.setVar("BINFILE", "c64xplus_jpegdec_02_00_01_01_production.bin", d) 91 d.setVar("BINFILE", "c64xplus_jpegdec_02_00_01_01_production.bin", d)
92 bb.data.setVar("TARFILE", "c64xplus_jpegdec_02_00_01_01_production.tar", d) 92 d.setVar("TARFILE", "c64xplus_jpegdec_02_00_01_01_production.tar", d)
93 bb.build.exec_func('ti_bin_do_unpack', d) 93 bb.build.exec_func('ti_bin_do_unpack', d)
94 94
95 bb.data.setVar("BINFILE", "c64xplus_mpeg2dec_02_00_02_00_production.bin", d) 95 d.setVar("BINFILE", "c64xplus_mpeg2dec_02_00_02_00_production.bin", d)
96 bb.data.setVar("TARFILE", "c64xplus_mpeg2dec_02_00_02_00_production.tar", d) 96 d.setVar("TARFILE", "c64xplus_mpeg2dec_02_00_02_00_production.tar", d)
97 bb.build.exec_func('ti_bin_do_unpack', d) 97 bb.build.exec_func('ti_bin_do_unpack', d)
98 98
99 bb.data.setVar("BINFILE", "omap3530_mpeg4enc_02_04_00_00_production.bin", d) 99 d.setVar("BINFILE", "omap3530_mpeg4enc_02_04_00_00_production.bin", d)
100 bb.data.setVar("TARFILE", "omap3530_mpeg4enc_02_04_00_00_production.tar", d) 100 d.setVar("TARFILE", "omap3530_mpeg4enc_02_04_00_00_production.tar", d)
101 bb.build.exec_func('ti_bin_do_unpack', d) 101 bb.build.exec_func('ti_bin_do_unpack', d)
102 102
103 bb.data.setVar("BINFILE", "c64xplus_mpeg4dec_02_01_00_00_production.bin", d) 103 d.setVar("BINFILE", "c64xplus_mpeg4dec_02_01_00_00_production.bin", d)
104 bb.data.setVar("TARFILE", "c64xplus_mpeg4dec_02_01_00_00_production.tar", d) 104 d.setVar("TARFILE", "c64xplus_mpeg4dec_02_01_00_00_production.tar", d)
105 bb.build.exec_func('ti_bin_do_unpack', d) 105 bb.build.exec_func('ti_bin_do_unpack', d)
106 106
107 bb.data.setVar("BINFILE", "c64xplus_aachedec_01_30_03_00_production.bin", d) 107 d.setVar("BINFILE", "c64xplus_aachedec_01_30_03_00_production.bin", d)
108 bb.data.setVar("TARFILE", "dm6446_aachedec_01_30_03_00_production.tar", d) 108 d.setVar("TARFILE", "dm6446_aachedec_01_30_03_00_production.tar", d)
109 bb.build.exec_func('ti_bin_do_unpack', d) 109 bb.build.exec_func('ti_bin_do_unpack', d)
110 110
111 bb.data.setVar("BINFILE", "c64xplus_g711_1_12_00_000_production.bin", d) 111 d.setVar("BINFILE", "c64xplus_g711_1_12_00_000_production.bin", d)
112 bb.data.setVar("TARFILE", "dm6446_g711enc_1_12_00_000_production.tar", d) 112 d.setVar("TARFILE", "dm6446_g711enc_1_12_00_000_production.tar", d)
113 bb.build.exec_func('ti_bin_do_unpack', d) 113 bb.build.exec_func('ti_bin_do_unpack', d)
114 114
115 bb.data.setVar("BINFILE", "c64xplus_g711_1_12_00_000_production.bin", d) 115 d.setVar("BINFILE", "c64xplus_g711_1_12_00_000_production.bin", d)
116 bb.data.setVar("TARFILE", "dm6446_g711dec_1_12_00_000_production.tar", d) 116 d.setVar("TARFILE", "dm6446_g711dec_1_12_00_000_production.tar", d)
117 bb.build.exec_func('ti_bin_do_unpack', d) 117 bb.build.exec_func('ti_bin_do_unpack', d)
118 118
119 bb.data.setVar("BINFILE", "c64xplus_deinterlacer_01_00_00_07_production.bin", d) 119 d.setVar("BINFILE", "c64xplus_deinterlacer_01_00_00_07_production.bin", d)
120 bb.data.setVar("TARFILE", "c64xplus_deinterlacer_01_00_00_07/c64xplus_deinterlacer_01_00_00_07_production.tar", d) 120 d.setVar("TARFILE", "c64xplus_deinterlacer_01_00_00_07/c64xplus_deinterlacer_01_00_00_07_production.tar", d)
121 bb.data.setVar("TI_BIN_UNPK_CMDS", "y: :q: ", d) 121 d.setVar("TI_BIN_UNPK_CMDS", "y: :q: ", d)
122 bb.build.exec_func('ti_bin_do_unpack', d) 122 bb.build.exec_func('ti_bin_do_unpack', d)
123 123
124} 124}