summaryrefslogtreecommitdiffstats
path: root/recipes-ti/beagleboard
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2012-03-07 10:11:27 +0100
committerDenys Dmytriyenko <denys@ti.com>2012-03-07 16:51:53 -0500
commited29286f2b16b48206ba788f790c1082c7724bb0 (patch)
tree18ea0667f5b5d602656aafd89a75521f7e42e606 /recipes-ti/beagleboard
parentedc2621facf8147e02f7a3d929220106d5bd94db (diff)
downloadmeta-ti-ed29286f2b16b48206ba788f790c1082c7724bb0.tar.gz
gadget init: don't dump info to info.txt on boot
This script adds ~10s to the boot time, doesn't have error checking and prevents loading the storage gadget 3 out of 10 times. Remove it from ExecStartPre to get a fast, consistent boot. The functionality should be moved to bone101. Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-ti/beagleboard')
-rw-r--r--recipes-ti/beagleboard/gadget-init.bb2
-rw-r--r--recipes-ti/beagleboard/gadget-init/storage-gadget-init.service1
2 files changed, 1 insertions, 2 deletions
diff --git a/recipes-ti/beagleboard/gadget-init.bb b/recipes-ti/beagleboard/gadget-init.bb
index 016877d3..1a6a3364 100644
--- a/recipes-ti/beagleboard/gadget-init.bb
+++ b/recipes-ti/beagleboard/gadget-init.bb
@@ -1,6 +1,6 @@
1DESCRIPTION = "Units to initialize usb gadgets" 1DESCRIPTION = "Units to initialize usb gadgets"
2 2
3PR = "r18" 3PR = "r19"
4 4
5LICENSE = "MIT" 5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58" 6LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
diff --git a/recipes-ti/beagleboard/gadget-init/storage-gadget-init.service b/recipes-ti/beagleboard/gadget-init/storage-gadget-init.service
index 601e0d7c..9a8513e8 100644
--- a/recipes-ti/beagleboard/gadget-init/storage-gadget-init.service
+++ b/recipes-ti/beagleboard/gadget-init/storage-gadget-init.service
@@ -4,7 +4,6 @@ After=dev-mmcblk0p1.device
4 4
5[Service] 5[Service]
6RemainAfterExit=yes 6RemainAfterExit=yes
7ExecStartPre=/usr/bin/update-image-info-on-mmcblk0p1.sh
8ExecStart=/sbin/modprobe g_mass_storage file=/dev/mmcblk0p1 cdrom=0 stall=0 removable=1 nofua=1 7ExecStart=/sbin/modprobe g_mass_storage file=/dev/mmcblk0p1 cdrom=0 stall=0 removable=1 nofua=1
9ExecStop=/sbin/rmmod g_mass_storage 8ExecStop=/sbin/rmmod g_mass_storage
10 9