diff options
author | Koen Kooi <koen@dominion.thruhere.net> | 2012-06-07 17:40:43 +0200 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2012-06-11 16:59:07 -0400 |
commit | c5e5c304b86a398d65330f430330ce5f730b56c5 (patch) | |
tree | 23d6cae7b8905893d6c9182f6b11d5b593d9b63b /recipes-ti/beagleboard | |
parent | 536748db584b77158c166c068ffe8960b0847ea5 (diff) | |
download | meta-ti-c5e5c304b86a398d65330f430330ce5f730b56c5.tar.gz |
beaglebone-capes: add support for 4.3" LCD cape
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-ti/beagleboard')
-rw-r--r-- | recipes-ti/beagleboard/beaglebone-capes.bb | 2 | ||||
-rwxr-xr-x | recipes-ti/beagleboard/beaglebone-capes/cape-stop.sh | 3 | ||||
-rwxr-xr-x | recipes-ti/beagleboard/beaglebone-capes/cape.sh | 4 |
3 files changed, 8 insertions, 1 deletions
diff --git a/recipes-ti/beagleboard/beaglebone-capes.bb b/recipes-ti/beagleboard/beaglebone-capes.bb index f1289247..2a9f1fb2 100644 --- a/recipes-ti/beagleboard/beaglebone-capes.bb +++ b/recipes-ti/beagleboard/beaglebone-capes.bb | |||
@@ -3,7 +3,7 @@ DESCRIPTION = "Userspace setup for beaglebone capes" | |||
3 | LICENSE = "MIT" | 3 | LICENSE = "MIT" |
4 | LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58" | 4 | LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58" |
5 | 5 | ||
6 | PR = "r1" | 6 | PR = "r2" |
7 | 7 | ||
8 | inherit allarch | 8 | inherit allarch |
9 | 9 | ||
diff --git a/recipes-ti/beagleboard/beaglebone-capes/cape-stop.sh b/recipes-ti/beagleboard/beaglebone-capes/cape-stop.sh index a08498d7..49500176 100755 --- a/recipes-ti/beagleboard/beaglebone-capes/cape-stop.sh +++ b/recipes-ti/beagleboard/beaglebone-capes/cape-stop.sh | |||
@@ -5,6 +5,9 @@ for eeprom in /sys/bus/i2c/devices/3-005*/eeprom ; do | |||
5 | "BB-BONE-LCD3-01.") | 5 | "BB-BONE-LCD3-01.") |
6 | echo "Turning off backlight for LCD3 cape" | 6 | echo "Turning off backlight for LCD3 cape" |
7 | i2cset -f -y 1 0x24 0x07 0x00;; | 7 | i2cset -f -y 1 0x24 0x07 0x00;; |
8 | "BB-BONE-LCD4-01.") | ||
9 | echo "Turning off backlight for LCD3 cape" | ||
10 | i2cset -f -y 1 0x24 0x07 0x00;; | ||
8 | *) | 11 | *) |
9 | echo "unknown cape: $PARTNUMBER";; | 12 | echo "unknown cape: $PARTNUMBER";; |
10 | esac | 13 | esac |
diff --git a/recipes-ti/beagleboard/beaglebone-capes/cape.sh b/recipes-ti/beagleboard/beaglebone-capes/cape.sh index 69accfff..61240a5f 100755 --- a/recipes-ti/beagleboard/beaglebone-capes/cape.sh +++ b/recipes-ti/beagleboard/beaglebone-capes/cape.sh | |||
@@ -6,6 +6,10 @@ for eeprom in /sys/bus/i2c/devices/3-005*/eeprom ; do | |||
6 | echo "Turning on backlight for LCD3 cape" | 6 | echo "Turning on backlight for LCD3 cape" |
7 | i2cset -f -y 1 0x24 0x07 0x09 | 7 | i2cset -f -y 1 0x24 0x07 0x09 |
8 | i2cset -f -y 1 0x24 0x08 0x60;; | 8 | i2cset -f -y 1 0x24 0x08 0x60;; |
9 | "BB-BONE-LCD4-01.") | ||
10 | echo "Turning on backlight for LCD4 cape" | ||
11 | i2cset -f -y 1 0x24 0x07 0x09 | ||
12 | i2cset -f -y 1 0x24 0x08 0x60;; | ||
9 | *) | 13 | *) |
10 | echo "unknown cape: $PARTNUMBER";; | 14 | echo "unknown cape: $PARTNUMBER";; |
11 | esac | 15 | esac |