diff options
author | Denys Dmytriyenko <denys@ti.com> | 2013-10-13 18:25:19 -0400 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2013-10-14 12:32:52 -0400 |
commit | b3df09902da0d2469a02e9975d404e26c4c5ec0e (patch) | |
tree | 48364a64fc8a5804659a373c378a7624cc086cd3 /recipes-ti/beagleboard | |
parent | 466575a7e7312b57c4b43241d16894dea8692049 (diff) | |
download | meta-ti-b3df09902da0d2469a02e9975d404e26c4c5ec0e.tar.gz |
recipes: cruft removal and seasonal cleanup
* Eliminate need for BBMASK - remove images requiring systemd/angstrom dependency
* Move ti-test packagegroup to proper location and update from latest Arago
* Move BoneScript and Bone GSG recipes to recipes-ti/beagleboard
* README in recipes-ti warns about unsupported nature of those packages
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-ti/beagleboard')
-rw-r--r-- | recipes-ti/beagleboard/beaglebone-getting-started.bb | 20 | ||||
-rw-r--r-- | recipes-ti/beagleboard/bonescript.bb | 38 | ||||
-rw-r--r-- | recipes-ti/beagleboard/bonescript/bone101.service | 11 | ||||
-rw-r--r-- | recipes-ti/beagleboard/bonescript/bonescript-git | 11 |
4 files changed, 80 insertions, 0 deletions
diff --git a/recipes-ti/beagleboard/beaglebone-getting-started.bb b/recipes-ti/beagleboard/beaglebone-getting-started.bb new file mode 100644 index 00000000..603a01a7 --- /dev/null +++ b/recipes-ti/beagleboard/beaglebone-getting-started.bb | |||
@@ -0,0 +1,20 @@ | |||
1 | DESCRIPTION = "BeagleBone Getting Started Guide" | ||
2 | |||
3 | PR = "r21" | ||
4 | |||
5 | inherit allarch | ||
6 | |||
7 | LICENSE = "GPLv2+ & MIT & PD & others" | ||
8 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=603591dea023c3c75b48e07cb47ce639" | ||
9 | |||
10 | SRCREV = "6c548a307c948b28a99d48fd17d9790b56182196" | ||
11 | SRC_URI = "git://github.com/jadonk/beaglebone-getting-started.git" | ||
12 | |||
13 | S = "${WORKDIR}/git" | ||
14 | |||
15 | do_install() { | ||
16 | install -d ${D}${datadir}/${PN} | ||
17 | cp -a ${S}/* ${D}${datadir}/${PN} | ||
18 | } | ||
19 | |||
20 | FILES_${PN} += "${datadir}/${PN}" | ||
diff --git a/recipes-ti/beagleboard/bonescript.bb b/recipes-ti/beagleboard/bonescript.bb new file mode 100644 index 00000000..b9dfbe63 --- /dev/null +++ b/recipes-ti/beagleboard/bonescript.bb | |||
@@ -0,0 +1,38 @@ | |||
1 | DESCRIPTION = "Scripting tools for the BeagleBoard and BeagleBone" | ||
2 | |||
3 | PR = "r15" | ||
4 | |||
5 | inherit systemd | ||
6 | |||
7 | LICENSE = "MIT" | ||
8 | LIC_FILES_CHKSUM = "file://LICENSE;md5=659ee0c98db2664403c769d6b9ab50eb" | ||
9 | |||
10 | SRC_URI = "http://dominion.thruhere.net/koen/angstrom/beaglebone/bonescript-6af82b41178c37644399b19039ea7e80c1dbf8ee.tar.bz2 \ | ||
11 | file://bonescript-git \ | ||
12 | file://bone101.service \ | ||
13 | " | ||
14 | SRC_URI[md5sum] = "e5e214857afbd2e59b52171e60810be2" | ||
15 | SRC_URI[sha256sum] = "e703416a63406c8b6c89fb1079406833ce6a9eb0ae1ba0a55fe3802b83186c50" | ||
16 | |||
17 | S = "${WORKDIR}/bonescript" | ||
18 | |||
19 | do_install() { | ||
20 | install -d ${D}${localstatedir}/lib/cloud9/ | ||
21 | cp -a ${S}/* ${D}${localstatedir}/lib/cloud9/ | ||
22 | cp -a ${S}/.git ${D}${localstatedir}/lib/cloud9/ | ||
23 | |||
24 | install -d ${D}${base_libdir}/systemd/system | ||
25 | install -m 0644 ${WORKDIR}/bone101.service ${D}${base_libdir}/systemd/system | ||
26 | |||
27 | rm -f ${D}${localstatedir}/lib/cloud9/node_modules/binary/node_modules/put/test/c/itof | ||
28 | rm -f ${D}${localstatedir}/lib/cloud9/node_modules/binary/node_modules/put/test/c/ftoi | ||
29 | } | ||
30 | |||
31 | NATIVE_SYSTEMD_SUPPORT = "1" | ||
32 | SYSTEMD_PACKAGES = "${PN}" | ||
33 | SYSTEMD_SERVICE_${PN} = "bone101.service" | ||
34 | |||
35 | FILES_${PN} += "${localstatedir} ${base_libdir}/systemd/system" | ||
36 | CONFFILES_${PN} += "${localstatedir}/lib/cloud9/.git/config" | ||
37 | RDEPENDS_${PN} = "nodejs cloud9" | ||
38 | RRECOMMENDS_${PN} = "git" | ||
diff --git a/recipes-ti/beagleboard/bonescript/bone101.service b/recipes-ti/beagleboard/bonescript/bone101.service new file mode 100644 index 00000000..49562ba4 --- /dev/null +++ b/recipes-ti/beagleboard/bonescript/bone101.service | |||
@@ -0,0 +1,11 @@ | |||
1 | [Unit] | ||
2 | Description=Beaglebone 101 presentation | ||
3 | ConditionPathExists=|/var/lib/cloud9 | ||
4 | |||
5 | [Service] | ||
6 | WorkingDirectory=/var/lib/cloud9 | ||
7 | ExecStart=/usr/bin/node bone101.js | ||
8 | |||
9 | [Install] | ||
10 | WantedBy=multi-user.target | ||
11 | |||
diff --git a/recipes-ti/beagleboard/bonescript/bonescript-git b/recipes-ti/beagleboard/bonescript/bonescript-git new file mode 100644 index 00000000..d9e66cfb --- /dev/null +++ b/recipes-ti/beagleboard/bonescript/bonescript-git | |||
@@ -0,0 +1,11 @@ | |||
1 | [core] | ||
2 | repositoryformatversion = 0 | ||
3 | filemode = true | ||
4 | bare = false | ||
5 | logallrefupdates = true | ||
6 | [remote "origin"] | ||
7 | fetch = +refs/heads/*:refs/remotes/origin/* | ||
8 | url = git://github.com/jadonk/bonescript.git | ||
9 | [branch "master"] | ||
10 | remote = origin | ||
11 | merge = refs/heads/master | ||