summaryrefslogtreecommitdiffstats
path: root/recipes-ti/beagleboard/gadget-init.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-10-18 10:22:48 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-10-18 10:22:48 +0200
commit8757f93089b0f2a9f4bb504813eea4aac3ae4fbe (patch)
tree22a4f269a85614336e599017945a6fa22ea464ba /recipes-ti/beagleboard/gadget-init.bb
parentff7221f486bda6c89690b441523f3e75fb4ed1ab (diff)
downloadmeta-ti-8757f93089b0f2a9f4bb504813eea4aac3ae4fbe.tar.gz
gadget-init: add ugly, ugly hack to make USB work on ti33x boards
This is NOT suitable for customers or production. Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'recipes-ti/beagleboard/gadget-init.bb')
-rw-r--r--recipes-ti/beagleboard/gadget-init.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes-ti/beagleboard/gadget-init.bb b/recipes-ti/beagleboard/gadget-init.bb
new file mode 100644
index 00000000..f3300e19
--- /dev/null
+++ b/recipes-ti/beagleboard/gadget-init.bb
@@ -0,0 +1,22 @@
1DESCRIPTION = "Units to initialize usb gadgets"
2
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
5
6COMPATIBLE_MACHINE = "(ti33x)"
7PACKAGE_ARCH = "${MACHINE_ARCH}"
8
9SRC_URI = "file://storage-gadget-init.service \
10 file://hokey-pokey.service \
11 "
12
13do_install() {
14 install -d ${D}${base_libdir}/systemd/system/basic.target.wants
15 install -m 0644 ${WORKDIR}/*.service ${D}${base_libdir}/systemd/system
16 for i in ${WORKDIR}/*.service ; do
17 install -m 0644 $i ${D}${base_libdir}/systemd/system
18 ln -sf ../$(basename $i) ${D}${base_libdir}/systemd/system/basic.target.wants/
19 done
20}
21
22FILES_${PN} = "${base_libdir}/systemd"