summaryrefslogtreecommitdiffstats
path: root/recipes-ti/beagleboard/beaglebone-capes.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2012-04-17 14:47:42 +0200
committerDenys Dmytriyenko <denys@ti.com>2012-04-18 12:19:55 -0400
commitf026aa7bd09a75034b28a0aa7e750059fd2c2813 (patch)
tree9a12a1b42249fba2368f19ad298a829bd7b8b6b3 /recipes-ti/beagleboard/beaglebone-capes.bb
parent41053c22a786de9026b85b125554eea55d381a39 (diff)
downloadmeta-ti-f026aa7bd09a75034b28a0aa7e750059fd2c2813.tar.gz
beaglebone-capes: userspace support for capes
Not everything can be done inside the kernel yet, so have a script that does the userspace portion. Only the LCD3 cape is supported currently, more will follow later. Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-ti/beagleboard/beaglebone-capes.bb')
-rw-r--r--recipes-ti/beagleboard/beaglebone-capes.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes-ti/beagleboard/beaglebone-capes.bb b/recipes-ti/beagleboard/beaglebone-capes.bb
new file mode 100644
index 00000000..88d4a173
--- /dev/null
+++ b/recipes-ti/beagleboard/beaglebone-capes.bb
@@ -0,0 +1,23 @@
1DESCRIPTION = "Userspace setup for beaglebone capes"
2
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
5
6inherit allarch
7
8SRC_URI = "file://cape.service \
9 file://cape.sh \
10 "
11
12do_install() {
13 install -d ${D}${base_libdir}/systemd/system/
14 install -m 0644 ${WORKDIR}/cape.service ${D}${base_libdir}/systemd/system
15
16 install -d ${D}${base_libdir}/systemd/system/basic.target.wants
17 ln -sf ../cape.service ${D}${base_libdir}/systemd/system/basic.target.wants/
18
19 install -d ${D}${bindir}
20 install -m 0755 ${WORKDIR}/cape.sh ${D}${bindir}
21}
22
23FILES_${PN} += "${base_libdir}/systemd/system"